Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't open Render Setup window

22 REPLIES 22
SOLVED
Reply
Message 1 of 23
ljadick
9642 Views, 22 Replies

Can't open Render Setup window

Hi there,

I have a rig I'm referencing into multiple scenes.  As soon as it's referenced in, I'm unable to open the Render Setup window.

 

Error: line 1: AttributeError: file C:\Program Files\Autodesk\Maya2018\Python\lib\site-packages\maya\app\renderSetup\model\renderSetup.py line 422: 'RenderSetup' object has no attribute '_defaultRenderLayer' // 

 

I can open the render setup window and then open the scene file and the window remains, but that's not really a long-term solution.

 

I have't made any changes to the window (no layers, overrides, etc).

 

I have no trouble opening the render setup window in the rig file.

 

If I import the rig, sometimes I'm only able to open the Render Setup window about half the time.

 

I tried resetting my preferences but that didn't solve the issue.  This happens on multiple machines, so a fresh install isn't the solution either.

 

I'd appreciate any ideas.  I'm a bit at a loss at the moment.

 

Thanks!

-Lauren

22 REPLIES 22
Message 2 of 23
sean.heasley
in reply to: ljadick

Hi @ljadick

 

Does this happen on any other scene files?

 

You could try exporting everything as an fbx, import it into a fresh scene, save that and then reference it to see if anything changes.

 

Please let me know how that goes for you!

 

 

Message 3 of 23
ljadick
in reply to: sean.heasley

Thank you so much, Sean.

 

Actually, just discovered it was a namespacing issue!

Message 4 of 23
sean.heasley
in reply to: ljadick

Hi @ljadick

 

Glad you figured it out! Thanks for explaining what you did and marking it as the solution!

 

 

Message 5 of 23
cwu17360
in reply to: ljadick

Hi, I also have the same issue at the moment. Could you explain to me how you fix the problem?

 

Message 6 of 23

"It was a namespacing issue" isn't a solution.

Message 7 of 23
ljadick
in reply to: donsmith5UBUJ

Enable "Use Namespaces" and select one of the "Use selected namespace" as options.  "Merge into selected" caused this issue.

Message 8 of 23

Yeah, this is not really a solution...

I guess we're supposed to import into a fresh scene, forcing us to use a namespace? I really don't want all of my nodes to be cluttered with the long name of my scene... Just to be able to use render layers. How are the two even connected?

 

Edit: I tried this and even though I can open the render setup window now, it now gives off errors constantly when switching layers:

// Error: AttributeError: file C:\Program Files\Autodesk\Maya2019\Python\lib\site-packages\maya\app\renderSetup\views\proxy\scene.py line 385: 'PySide2.QtCore.Signal' object has no attribute 'emit' // 

And Maya ignores any overrides I add to the layer... There's always something going wrong in Maya 2019... ALWAYS. None of it is getting fixed, either.

Good job, Autodesk.

Message 9 of 23
ljadick
in reply to: andreas.olofsson

Unfortunately, After about 40 hours of troubleshooting, this was the only solution I was able to come up with.  It's a pain, but it's worked every single time.

 

 

Message 10 of 23
andreas.olofsson
in reply to: ljadick

Are you able to add overrides to your render layers?

For me the overrides gets added to the render setup window, but the attributes don't turn orange and they don't change when I switch layers 😕

Message 11 of 23
rluZQTMU
in reply to: ljadick

Hi, I am having the same issue that I merged the namespace...could you tell us where did you enable "use namespace"?

Message 12 of 23
ljadick
in reply to: rluZQTMU

You have to export your animation, remove your reference from the scene,
and recreate a reference, using one of the other two namespace options.
Just don't use "merge into."
Message 13 of 23
Artificial1980
in reply to: ljadick

Right, so having composed a scene with references with mentioned referencing techniques prevents use of a render setup then? Because this is exactly how we've been putting together scenes for years, and it is unfeasible to revert this.

This is not a solved issue Autodesk; this is a bug that persists in Maya still.

Message 14 of 23

Ive just encountered this....

 

I had to remove the reference. I cleared all namespaces in the scene, also in the reference file. I ran optimise scene and ticked all the options in the render scene and the reference. Deleted any extra "defaultlayers"

 

After clearing all of this I was able to bring the reference back in with "merge" selected to avoid silly long naming and render setup re-appeared. Im not sure exactly which thing it was that fixed it, but generally junking off lots of extra data and cleaning up assets helped.

Message 15 of 23

This is now happening even on new scenes with no namespaces. Im using the "merge" option when referencing, and cleaning out all junk data in all scenes....but still getting the render setup error. AUTODESK! anyone fancy looking into this??!

Message 16 of 23
cld926
in reply to: ljadick

pls try imported all reference file if have  .and save as other. and open new file.

Message 17 of 23

Please mark this at NOT solved. Its driving me mad on Maya 2022 and is happening more and more with references. Makes my job literally impossible!

Message 18 of 23
misaramirez94
in reply to: ljadick

Where do you find this options? I can't find them.

 

Thanks ❤️ ❤️

Message 19 of 23
MShephardNG7YP
in reply to: ljadick

This Issue is still a problem. Is there a Autodesk solution coming so you can merge into namespace?

Message 20 of 23

UP

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report