Revit Architecture Forum
Welcome to Autodesk’s Revit Architecture Forums. Share your knowledge, ask questions, and explore popular Revit Architecture topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Installation of Revit 2017 Content Libraries

62 REPLIES 62
SOLVED
Reply
Message 1 of 63
IMCornish
111444 Views, 62 Replies

Installation of Revit 2017 Content Libraries

I have read solutions for the installation of 2015 and 2016 Revit Content libraries which apparently also apply to 2017 but since the first step is to find 'Autodesk Revit Content Libraries 2017' in your Control Panel's 'Programs and Features' and it does not exist I would ask how do you actually install the Revit 2017 Content?

 

See snipit below of my 'Programs and Features':

 

Revit Content 00.JPG

Revit 2017 is installed, as can be seen, but no Content Library!

 

Any ideas

Andrew Robertson
Chartered Architect
Robertson Partnership
Truro. UK
62 REPLIES 62
Message 2 of 63
L.Maas
in reply to: IMCornish

Something did not go ok with the installation I think.

Screenshot from my computer

 

Contnet.png

 

What I normally do when installing a new version is to completely download (browser download) everything from the server, before installing it.

Content issues seem to be often caused by, that at time of installation, content files are goiing to be downloaded. When than an error occurs you run into these kind of problems.

 

Maybe you can check your journal files to see if something got reprorted

Louis

EESignature

Please mention Revit version, especially when uploading Revit files.

Message 3 of 63
RDAOU
in reply to: IMCornish

@IMCornish

 

If you go for the webinstall, you will always face this problem...Best to download on your PC then install locally.

 

2017 dlm files can be found on the following two lonks --->> HERE PART 1 and HERE PART 2 (Alternatively; you can download from your account management or Adsk Dsktop App; however, using a different method than webinstall/install now)

 

Extract them both then run the installation again and install the content library

YOUTUBE | BIM | COMPUTATIONAL DESIGN | PARAMETRIC DESIGN | GENERATIVE DESIGN | VISUAL PROGRAMMING
If you find this reply helpful kindly hit the LIKE BUTTON and if applicable please ACCEPT AS SOLUTION


Message 4 of 63
IMCornish
in reply to: RDAOU

Had this response from Autodesk:-

 

Thank you for your recent support inquiry.
As concerns  missing libraries you may try to follow these articles:

https://knowledge.autodesk.com/support/revit-products/troubleshooting/caas/sfdcarticles/sfdcarticles...

https://knowledge.autodesk.com/support/revit-products/troubleshooting/caas/sfdcarticles/sfdcarticles...

But if the libraries are not installed you may download US Imperial and US Metric libraries from this temporary link: https://we.tl/JTBZvoDjJ6
UK library: https://we.tl/mHfNvjSaTk
Belgium library: https://we.tl/j8e5yqow3x

and the please unpack them to these folders

c:\ProgramData\Autodesk\RVT 2017\Libraries\US Imperial\

c:\ProgramData\Autodesk\RVT 2017\Libraries\US Metric\

c:\ProgramData\Autodesk\RVT 2017\Libraries\UK\

c:\ProgramData\Autodesk\RVT 2017\Libraries\Belgium\

respectively.

Let me know if you need any other country libraries.

 

Not surprisingly the first two suggestions would not work, since they arrived at the original problem I had pointed identified, however I resorted to the download option and instaled them succesfully.  This may be what RDAOU may have been suggesting.  The sad thing though is that whilst I am forced to mark this as a solution  it isn't really since the installation software should work.  Whilst I love the software this 'woolly' ending is typical of Autodesk and their attitude to their software, or it seems to me at least.

Andrew Robertson
Chartered Architect
Robertson Partnership
Truro. UK
Message 5 of 63
Anonymous
in reply to: IMCornish

Is it possible to have the french version of content Libraries ?

I am downloading the Belgium one but am not sure they are the same.

 

Message 6 of 63
Anonymous
in reply to: IMCornish

Unfortunately the download of US and Imperial Content Library does not exist anymore in the first link. We hope referring to anothrt valid link. 

 

regards...

Message 7 of 63
Anonymous
in reply to: IMCornish

2016 revit türkçe olarak family dosyası istiyorum çok zorlananıyorum malzeme bulmada yardımcı olursanız mail adresinden ulaşırsanız sevinirm. turkey family istiyorum.

yalcin_simsek_57@hotmail.com

Message 8 of 63
Tony_Michniewicz
in reply to: Anonymous

We've recently identified a sporadic issue that will result in content not being installed via the Revit LT 2017 web installer. After our investigation, we found that a required content file is not always included in the extracted files and its absence results in the installation bypassing Revit content files. We are investigating the root cause of this problem and hope to have a resolution in place soon. Until then, the following steps will allow you to work around this issue:

 

  1. From this post, download the Revit_2017_MasterXML.zip file and extract the contents to a local folder.
  2. Download and run the Revit LT 2017 web installer, Revit_LT_2017_G1_Win_64bit_wi_en-US_Setup.exe.
  3. When the initial Autodesk Revit LT dialog is displayed, click Cancel.
  4. Copy the master.rlt.xml file that was extracted in step 1 and paste it into the C:\Autodesk\WI\Autodesk Revit LT 2017\Content\Revit folder.
  5. Launch the Revit LT 2017 installer using the Revit_LT_2017_G1_Win_64bit_wi_en-US_Setup_webinstall.exe that should reside in your Downloads folder or the folder to which the original Revit_LT_2017_G1_Win_64bit_wi_en-US_Setup.exe was downloaded.
  6. Step through the installation and when you get to the product selection page, expand the Revit LT 2017 Content Libraries entry and verify that the list of content packs is populated and at least one of the underlying option is selected.
  7. Collapse the Revit LT 2017 Content Libraries entry and click Install.

 

At this point, we've only seen this problem occur with the Revit LT 2017 web installer but based on the numerous reports of Revit content installation problems, a similar problem may impact other Revit versions, including previous releases. For this reason, I've attached zip files that contain the master XML files for each version of Revit 2015, 2016, and 2017. Once the appropriate master XML file is extracted and copied to the appropriate ...\Content\Revit folder, the installation of Revit content should complete successfully.

 

Tony Michniewicz

Autodesk Revit QA


Tony Michniewicz
Revit Software QA Analyst
Message 9 of 63

Tony,

 

I have had the same issue on a number of 2017 updates (LT Suite), for which your workaround works. I have now updated 7 workstations to 2017 and they all have this problem. Why has Autodesk not corrected this since your post on 20th May ? 

 

I now have to do this workaround 7 times - and then have to manually update the templete paths as well.

 

Is there a faster method to this ?

 

Thanks

Message 10 of 63
xtianparedes
in reply to: IMCornish

Dear Andrew Robertson

Can you please attached the US Imperial and US Metric libraries in a new temporary link again, becuase these don´t work anymore

 

Christian A P

Message 11 of 63
darrenpedder
in reply to: xtianparedes

2017 attached:

Message 12 of 63
Anonymous
in reply to: Tony_Michniewicz

Thanks for the info Tony.

 

Couldn't workout why all the training video's show templates and families working correctly, I've just spent a 1/2 day researching and fixing this issue for a trail version which only lasts for 30 days.

 

Not a very good track record to report back to my manager who is deciding which of three products our company will be using, I've been assigned the Autodesk product.

 

Regards.

Message 13 of 63

Have been trying to figure out this problem for sometime now. These steps worked for Revit 2017. The folder paths and file names were a bit different but replacing the XML files within the Revit 2017\Content\Revit folder worked. Hope this is fixed for future release as I know that R2016 had the same problem.

Message 14 of 63

Have been trying to figure out this problem for sometime now. These steps worked for Revit 2017. The folder paths and file names were a bit different but replacing the XML files within the Revit 2017\Content\Revit folder worked. Hope this is fixed for future release as I know that R2016 had the same problem.
Message 15 of 63
arkelec
in reply to: IMCornish

Hey, Autodesk - if you read this - please, please please look into making things easier for the users who don't have a IT team to deal with fixing these problems.

 

I have spent the last TWO DAYS going around in circles because these problems exist.  And I still haven't resolved my initial issue.

 

Many thanks.

 

 

Message 16 of 63
Anonymous
in reply to: Tony_Michniewicz

Hi Tony,

 

I am having the same issue with Revit LT 2017, but am not having any success with your instructions. I copied the files to the right folder and the US Imperial and Metric now show up under Content Pack in the installer. When I install the content libraries, it all seems to go well, but when I open Revit I still get an error message that the default family template file is invalid.

 

Because the content pack seems to be installed but not loading, I tried the steps here:

https://knowledge.autodesk.com/support/revit-products/troubleshooting/caas/sfdcarticles/sfdcarticles...

 

This also didn't help. I seem to be going in circles- any additional help? I have no IT department, just me, and I have no idea what to do next.

 

Thank you.

Message 17 of 63
wally111
in reply to: IMCornish

the UK path fom we transfer   https://www.wetransfer.com/downloads/798ae737d92f6cb1f466c20b0e1b593120160505065313/bed62d

 

tell me that isn't available anymore.

 

I really need to have the library and templates of revit 2017

 

Regards

 

Walter

Message 18 of 63
Anonymous
in reply to: wally111

The best method -as I see- to fix this problem is to:

1-  uninstall "Autodesk Revit Content Libraries 2017" using Microsoft application Tool "MicrosoftFixit.ProgramInstallUninstall" which could be downloaded from Microsoft website. I have been attached it here.

2- Reinstall the "Autodesk Revit 2017". Ensure that "Autodesk Revit Content Libraries 2017" option is checked while keeping your PC connected with the internet. This will take a while but do not disconnect the PC from the internet during this time.

3- When it is finished, you will find that "C:\ProgramData\Autodesk\RVT 2017" folders and their contents are exist with a size of about 2 Gb.

Message 19 of 63
arkelec
in reply to: wally111

Tony posted further down page with master libraries listed, here's the link Revit 2017 Master XML

 

Message 20 of 63
wally111
in reply to: Anonymous

It tells me that this folder was already uninstalled...but appears in -programs data -in my computer but the folders are empty...What can I do?Theres a possibility to install tehe?
Regards
Walter

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Customer Advisory Groups


Autodesk Design & Make Report