Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't add device to library because of footprint version error

13 REPLIES 13
SOLVED
Reply
Message 1 of 14
matthew_goulart
672 Views, 13 Replies

Can't add device to library because of footprint version error

I am trying to add a device with footprint DO35-7 to a library that does not have a footprint with the same name. I get:

Capture.PNG

As you can see the "current" version is DO15-TVS and it's complaining that DO35-7 is a newer version. I'm not really sure how to solve this. I tried closing everything and restarting fusion to no avail.

13 REPLIES 13
Message 2 of 14

Something must have gone wrong at some point in the past when working with these libraries. I talked with the team and we suspect it's a result of copying DO35-7 in the past from the original library to the new one and renaming it to DO15-TVS. We are working right now to reproduce this. It definitely feels like a bug. Thanks for reporting!

 

What you can do right now to move on, is duplicating DO15-TVS and removing the original one (also re-mapping all the devices that use this). Sorry for the inconvenience. 

Pieter-Jan Van de Maele
Senior Engineering Manager, Fusion Electronics
Message 3 of 14

Is this something I can see/fix directly in the library XML file? Maybe just an attribute that didn't get switched? I'll try your resolution either way, I only have one component using that footprint so it's no big deal.

Message 4 of 14

Generally we don't recommend fixing issues like this through the XML, especially in the Fusion environment as it would force you to export & import the library which might become a bit messy w.r.t. the references we keep in the library index (used by library manager and add dialog). However, as you have asked for it: the suspicion is that both of these footprints have the same value in the URN field which you should be able to validate in the XML. This would be a consequence of this library being managed at some point and a bug in the copy operation. We're working on fixing that right now and hope to deliver the fix not too far in the future. 

Pieter-Jan Van de Maele
Senior Engineering Manager, Fusion Electronics
Message 5 of 14

Just wanted to follow up and report that the first solution did indeed fix the problem. Thanks!

Message 6 of 14

The problem is still there.
It can be reproduced by importing a device into an existing library and then trying to import another
device. I'm using version 2.0.11186 of Fusion 360.

 

Message 7 of 14
martongr
in reply to: C.Fischer4CTPL

I am having the same issue.
Message 8 of 14

Hi @martongr ,

 

What version of EAGLE are you working with?

 

I'll report this in the meantime, but let me know if you are using anything but the latest version of EAGLE (9.6.2).

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 9 of 14
martongr
in reply to: jorge_garcia2

Hi Jorge

 

I was using the latest Fusion 360 in fact. I am a bit confused regarding what is the difference?

 

I managed to solve this issue by deleting the devices from the library, waiting a bit, and then step by step reconstructing the devices - symbol, footprint, 3D model. My suspicion is that it has to do with timing: Fusion 360 needs some time to sync.

 

 

Message 10 of 14

Hi @C.Fischer4CTPL , @matthew_goulart , @martongr ,

 

Sorry to hear that you're having trouble.

May I know where the libraries you used to import and original libraries is come from?

If the libraries were downloaded from ultralibrarian.com, there is a known issue that importing the downloaded Fusion360 PCB libraries from there could result the unexpected footprint different version error issue.

If this is the case, please download the Eagle6 Library instead and then create the library in Fusion with the downloaded script by yourself, and later importing library will have no such issue.

ultralibrarian.PNG

If it's not the case, do you mind to attach the 2 libraries which cause the issue that we could have a check?

You could duplicate the libraries and just delete others devices but only left the ones which have the issue in the new libraries.

 

Thank you very much for your help and so sorry for any inconvienence.

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 11 of 14

I am not sure if that particular library was from ultra librarian or not - it could very well have been! It was the footprint for the B05B-PASK-1 and B07B-PASK-1 connectors. I first downloaded it from RS, with gives an .epw file, which then I needed to convert with some sketchy software. (What is the best way to do this?) I then started using ultra librarian I think, which gives me a lbr right away. (What is the best way to merge a single-device lbr into my larger library?)

 

The trouble was that  when I uploaded a footprint to B05B, it would also update the footprint in B07B... Super annoying.

 

https://app.ultralibrarian.com/details/1e916f7c-2d7b-11ec-9033-0a34d6323d74/JST/B05B-PASK-1-LF-SN-?u...

 

Sorry for the not-so-accurate problem description - once I managed to get past it, I didn't bother to make notes on what was wrong before. And thank you for the tip on using the Eagle version, it will save me some trouble in the future! 🙂

Message 12 of 14
PW_VOX
in reply to: matthew_goulart

I'm having a similar problem.

PW_VOX_0-1644914396660.png

as shown here.  However I know how I created the first part, I imported T05 footprint from the standard transistor library and then edited it, as you can see, renaming it as a new footprint.  I then wanted to bring in the same footprint again and I gat the error.  As far as I can tell the current version of the part in my library has nothing to Identify it as TO 5.  Any ideas?   

Message 13 of 14

Hi @PW_VOX ,

 

Sorry to hear that you're having trouble.

Whether your  standard transistor library  is also downloaded from other website? If yes, sorry that please follow the workaround I mentioned above to download the EAGLE 6 script and run the script in library to generate the library in Fusion instead.

 

Please feel free to let us know if it's not the case.

Thanks.

 

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 14 of 14

The part came form the standard transistor library v7 here

urn:adsk.wipprod:fs.file:vf.DiSOllsWR-utFmzoBmJ1aA

I've solved the issue by opening the transistor library, copying all of the footprint and pasting it into a new footprint which I could then save as "TO5" without any complaints.  Seems to me that the import function some how gets the name from a previous version of the part.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report