AutoCAD Architecture Forum
Welcome to Autodesk’s AutoCAD Architecture Forums. Share your knowledge, ask questions, and explore popular AutoCAD Architecture topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Utitled viewports in pdfs

38 REPLIES 38
Reply
Message 1 of 39
WLAjem57
8945 Views, 38 Replies

Utitled viewports in pdfs

AutoCAD is creating untitled viewports in pdfs when plotting or publishing to pdf. pdf editor, Bluebeam in our case is prompting us to delete them, since they interfere with snapping dimensions in the editor.

 

We cannot find any setting that would disable this, either in the pdf editor or AutoCAD.

 

we are running ACA 2017, in Windows 10 operating systems.

 

See screenshots of pdf editor.

 

Anyone else having this issue?

38 REPLIES 38
Message 2 of 39
Victoria.Studley
in reply to: WLAjem57

Hi @WLAjem57,

 

Welcome to the Autodesk Community and thank you for posting your question here in the AutoCAD Architecture forum!

 

This looks like a feature that Bluebeam added to their software to alert users to viewports with null values (seems to have something to do with the scaling of the viewport). Brian F from Bluebeam explains the behavior in detail in this thread over on their forum:

Here's another post from when the feature was first added to Bluebeam Revu 12:

 

Could you take a look at these links and let me know if they help explain what's happening, and how to get around it?

 

If one or more of these posts helped answer your question, please click Accept as Solution on the posts that helped you so others in the community can find them easily.


Victoria Studley
Content Experience Designer - Fusion 360
Fusion 360 | Learn & Support
Documentation | Contact Support
Message 3 of 39
WLAjem57
in reply to: Victoria.Studley

Thanks, it looks like their solution was to plot not using the DWG to PDF plot setting. This did correct the problem, however using the Bluebeam PDF setting, did not preserve the line weights for some reason. The plot was very flat looking. We will put up with the viewport issue as the pen weights are not altered using this. Will keep you posted if we find other fixes.

Thanks

Message 4 of 39
Anonymous
in reply to: WLAjem57

Hi,

 

I'm also having issues with this. Has there been any recent developments on this issue? Is there a way to make Autocad export to PDF without including the viewport objects?

 

Best regards

Per D

Message 5 of 39
pendean
in reply to: Anonymous

viewport objects?
Message 6 of 39
Anonymous
in reply to: pendean

Sorry, maybe viewport objects isn't the correct term. I mean the viewport frames that Bill describes above. They are interfering with the scale when meassuring in Bluebeam.

Message 7 of 39
pendean
in reply to: Anonymous

Does placing the viewport frames on a unique layer and freezing that layer resolve the problem?
Our layer for these is just called VIEWPORTS and is always set to noplot as well.
Message 8 of 39
Anonymous
in reply to: pendean

Thank you for the tip, although it doesn't seem to solve the issue.

I used the plotter PDF995 and a Truetype font. This seems to get rid of viewports and also make the text searchable on the PDFs.

Message 9 of 39
Victoria.Studley
in reply to: Anonymous

Hi @Anonymous,

 

When I looked into this a few months ago, I found the linked posted from Bluebeam (see my previous post in this thread). This is a feature that Bluebeam has added on their end.

 

If the workarounds described in those links don't work for you, the best way to get help addressing this issue maybe be to contact Bluebeam directly to see if they recommend any other specific settings or adjustments to work around the problem.

 

Have you reached out to Bluebeam about this yet?

 

If one or more of these posts helped answer your question, please click Accept as Solution on the posts that helped you so others in the community can find them easily.


Victoria Studley
Content Experience Designer - Fusion 360
Fusion 360 | Learn & Support
Documentation | Contact Support
Message 10 of 39
WLAjem57
in reply to: Victoria.Studley

Hi @Victoria.Studley

I found a work around, the problem seems to be generated by any AutoCAD .pc3 file, I tried plotting directly with the BluebeamPSDriver printer settings. The drawing did plot without generating the "untitled viewports". However, the line weights are washed out and the drawing is very flat and light. I will look editing the DWG to PDF .pc3 file, to see if I can find a setting there to turn off.

Message 11 of 39
Victoria.Studley
in reply to: WLAjem57

Hi @WLAjem57,

 

Thanks for the update. Let us know what you find.

 

It is still a good idea to report this to Bluebeam, since their software doesn't seem to be working properly with the out-of-the-box AutoCAD PDF configurations. They can't fix what they're not aware of.

 

If one or more of these posts helped answer your question, please click Accept as Solution on the posts that helped you so others in the community can find them easily.


Victoria Studley
Content Experience Designer - Fusion 360
Fusion 360 | Learn & Support
Documentation | Contact Support
Message 12 of 39
WLAjem57
in reply to: Victoria.Studley

@Victoria.StudleyI did not find anything to edit in the .pc3 files. thanks for your suggestion, i will reach out to Bluebeam.

 

will keep you posted.

Message 13 of 39

Hi Victoria / all,

 

Something else to note on this issue.  I have found that it does not just affect PDF's when opened in Bluebeam, but in Adobe Acrobat also.  The untitled viewports, generated by the DWG To PDF.pc3 file, cause dimension scaling and limits to dimension extents when I open up a PDF in Adobe Acrobat.  The difference being that Adobe has no way to get rid of the viewports.

 

I think the pc3 file is actually generating the untitled viewports and Bluebeam just does a better job at using them and deleting them.

 

Bottom line is that it is not just Bluebeam's issue, it is also an issue with the out of the box Autodesk PC3 file.

 

Regards,

James

Message 14 of 39
_James_Johnson
in reply to: WLAjem57

Bill - Not sure if you found a cure for this issue.

 

We have experienced the same thing.  And it isn't just when using Bluebeam to open a PDF, but also Adobe Acrobat Pro.  From what I can tell, the stock dwg to pdf PC3 file does generate the untitled viewports.  We do not have a Bluebeam PDF driver at my office so we are stuck using the Autodesk provided PC3 file.  I am currently trying to figure out a way to deal with this issue.

When we submit PDF's to our clients, we do not want them to see the untitled viewports if they try to use the dimensioning tools.

Regards,

James

Message 15 of 39
Anonymous
in reply to: WLAjem57

I'm having the same issues. Would be very interested to know if anyone found a workaround while using the stock DWG to PDF pc3 file to create PDF's without the viewports. This certainly seems to be an AutoCAD issue.

Message 16 of 39
WLAjem57
in reply to: Anonymous


@Anonymous wrote:

I'm having the same issues. Would be very interested to know if anyone found a workaround while using the stock DWG to PDF pc3 file to create PDF's without the viewports. This certainly seems to be an AutoCAD issue.


No, have not found a solution.

Message 17 of 39
Anonymous
in reply to: Victoria.Studley

Please see the post by jamesjD6KEP. He was able to verify that this is not a Bluebeam issue (in fact, Bluebeam just "handles it better") but an ACAD issue with the default DWG to PDF file.

 

Regards,

 

Message 18 of 39
bill
in reply to: Anonymous

The untitled viewports are more of a nuisance than anything and are easily remove when you first open the PDF in Bluebeam.  To me, the question is why does AutoCAD PDF generate them in the first place.  I really think this is an AutoCAD problem.

 

Also, I tried using the Bluebeam PDF plotter and, for the file I plotted, it generated an 87 MB PDF file that was essentially unusable.  The only plus in that file was there were no untitled viewports.  The same file plotted with every other PDF plotter created  a PDF file with a size range between 1.2 MB (Smallest File - had text errors in the PDF display) and 1.7 (High Quality Print) MB.  By the way, the "DWG to PDF" file was 1.3 MB in size.

 

For all of these plots, I tried everything available on the "PDF Options" button and none of them prevented the plotting of the untitled viewports.  Again, my question is why does AutoCAD generate them at all?

Message 19 of 39
pendean
in reply to: bill

>>>...my question is why does AutoCAD generate them at all?...<<<
No one here is from the AutoCAD developer team, he people to answer then possibly fix the issue.

Try reporting the problem to Autodesk through here and get everyone you know to do that same, the developer teams respond to quantities of identical reports more readily than "me too" replies to posts in these forums https://knowledge.autodesk.com/contact-support/using-my-product

HTH

Message 20 of 39
myles.mcnickle
in reply to: bill

You can turn off or delete the view ports in order that it does not affect scaling and measuring in the Measurements Palette in Blu Beam, there is a View ports section of the palette, they are listed there and you can delete them. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report