Revit MEP Forum
Welcome to Autodesk’s Revit MEP Forums. Share your knowledge, ask questions, and explore popular Revit MEP topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Revit Legend Electrical Devices show 3d element (back box)

21 REPLIES 21
SOLVED
Reply
Message 1 of 22
rkernPBQSM
5429 Views, 21 Replies

Revit Legend Electrical Devices show 3d element (back box)

Is there a method or visibility adjustment for the legend to show only the floor plan symbol and not the symbol and the 3d element on the legend in Revit.  See attached example legend, which shows the 3d element along with the symbol.  We would like only the symbol to show on the legend and not the 3d back box and the symbol.  

 

 

21 REPLIES 21
Message 2 of 22
cbcarch
in reply to: rkernPBQSM

Typically a "nested" generic annotation family is loaded into the device family. Use visibility parameters to control the annotation visibility in the project.

Cliff B. Collins
Registered Architect The Lamar Johnson Collaborative Architects-St. Louis, MO
Message 3 of 22
kadmonkee
in reply to: rkernPBQSM

we typically only use the 2d symbols (separate from the 3d model families) to create our legends.

go into the family and see what category the back box is and turn that category off in your legends visibility graphics

it could currently be the same category as your generic annotative family (2d symbol)






If there is any information shared that is of value please give Kudos
If a solution is provided by any posters please mark them as Solved to benefit everyone else.
thank you
Message 4 of 22
rkernPBQSM
in reply to: kadmonkee

I don't see how you can turn it off on the legend in VV.  Here are the steps to re-create...

  1. Create a new project (Mechanical Template)
  2. Create some generic walls
  3. Go to System > Device
  4. Load the device you selected (I did a data outlet)
  5. drop the device in the project (make sure VV is set for the floor plan to see the device)
  6. Click View . Create > Legend
  7. Drop the device on the legend (Annotate > Detail > Component > Legend Component)
  8. Note the device will not match the from the legend plan to the floor plan (see attached).

How can you have the device match both on the floor plan and the legend?

  1. drop some electrical icons, and then create a legend, then 
Message 5 of 22
ToanDN
in reply to: rkernPBQSM

Make sure the Device placed on the Legend view is set to Floor Plan View from the Option bar.
Message 6 of 22
rkernPBQSM
in reply to: ToanDN

Yes, it is set to Floor Plan view.


Message 7 of 22
rkernPBQSM
in reply to: rkernPBQSM

So there is no way to use the Revit Legend, to show floor plan devices on a legend and have them match what they will look like on the floor plan?  Every device we place on the Legend comes in with the 3D element.  

Message 8 of 22
kadmonkee
in reply to: rkernPBQSM

create a generic Annotative (2d Symbol) family for the device.

this can now be used in a drafting view or a detail.

match the symbology with the 3d Family

create a drafting view and use that view to layout your Master legend.

this is a flexible standard that will reduce the size of your model due to the fact all symbols are only 2d in your legends and details or drafting views.

now your Master Legend is all the same scale 1:1 and will fit on any sheet as desired by the project needs.

create a legend view and copy paste all the relevant content from your Master Legend onto your Legend view.






If there is any information shared that is of value please give Kudos
If a solution is provided by any posters please mark them as Solved to benefit everyone else.
thank you
Message 9 of 22
SteveKStafford
in reply to: rkernPBQSM

Most if not all of these families have a nested 2D annotation element. These can be loaded into the project separately and used in Legend views.

 

The Phase technique for Legends it effective assuming the Legend does not have to go on many sheets. Duplicating the phased legend view isn't hard though, to work around that.

My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 10 of 22
J.Wehmer
in reply to: rkernPBQSM

Most electrical receptacle families I have used need to be shown on "Coarse" detail level setting;coarse setting.png

 

 

Change the Detail Level: Coarse in your view, and see if the Wall Box goes away.


-Please click accept as solution if this answers your question!
Message 11 of 22
J.Wehmer
in reply to: rkernPBQSM

I also forgot to mention; that also happens when you place the family on a level-orientated work plane as opposed to a vertical work plane or wall. 

 

Advice: make a work plane vertical, as to simulate a wall and place the receptacles on the "wall" work plane


-Please click accept as solution if this answers your question!
Message 12 of 22
ToanDN
in reply to: rkernPBQSM


@rkernPBQSM wrote:

So there is no way to use the Revit Legend, to show floor plan devices on a legend and have them match what they will look like on the floor plan?  Every device we place on the Legend comes in with the 3D element.  


Is it a face based family?  If so, try Front view instead of plan view for it in the Legend.

Message 13 of 22
rkernPBQSM
in reply to: ToanDN

Thank you for all of the suggestions.  

 

  • Yes tried Front view instead of plan view.
  • Tried visibility parameters.
  • Made sure the device is set on Floor Plan View.
  • Tried Coarse detail level.
  • Yes, most default electrical components in Revit are face hosted, but switching to front view only shows the 3D element and not the floor plan symbol.  One would want to show the floor plan symbol only. 
  • There are no work planes that I can see in a legend view, so not sure how to change that in a legend view.
  • The other options suggested appear to be work arounds to the limitation in the built in Revit Legend.

 

 

I think the answer to this is the Revit Legend only shows the entire family, including the Elevation/3Dview elements of the family for electrical devices at least.  Ideally a Revit Legend would be able to display only the Floor plan portion of the family, but based on the suggests, none appear to work.  

Message 14 of 22
SteveKStafford
in reply to: rkernPBQSM

Mine works...use the nested annotation symbol separately in the Legend View. Save it out of the family, store it in a folder and load it into the project. Use the Symbol tool to place it. Easy and it is the same symbol used with the device.

My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 15 of 22
ToanDN
in reply to: rkernPBQSM

Face based families have this problem.  Wall based or non host families work fine.  I suggest load the symbols to you project and use them for Legend.

 

Capture.PNG

Message 16 of 22
rkernPBQSM
in reply to: SteveKStafford

If you do this, use the annotation symbol separately, if you update the original family/device, will the Legend Symbol update? I thought it would not, and then you would have to duplicate efforts during any change update.


Message 17 of 22
ToanDN
in reply to: rkernPBQSM

The model family should use the same symbol family, should it not? When you update the symbol load it in both the model family and the project then you will be fine.

Message 18 of 22
kadmonkee
in reply to: rkernPBQSM

see post 8-18






If there is any information shared that is of value please give Kudos
If a solution is provided by any posters please mark them as Solved to benefit everyone else.
thank you
Message 19 of 22
SteveKStafford
in reply to: rkernPBQSM

Yes, like @ToanDN wrote... if it changes the hosting family had to change too. Load it into both the family and the project. Legends don't generally change endlessly on projects. Once when the project starts because a special situation exists...maybe later on because a project review demands it. It's not nearly as significant as all of the other change that happens on every project.

My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 20 of 22
Anonymous
in reply to: cbcarch

I just came across this issue, if you already have a solution, please disregard.  I encountered the same problem with my devices.  In our office, we use DETAIL LEVEL = FINE for rendering and 3D views only.  All of our families are set to show that box (element) only in FINE detail level, for detail levels MEDIUM and COARSE, this element view is unchecked.  Once this element is placed on the LEGEND view, the family is set to MEDIUM.  Since that box (element) is shown only on FINE detail level setting, it goes away in the LEGEND.  So, how to turn it off on the family?  Right click the family is question, EDIT the family and you will have to click on all views of the family, including FAMILY ELEVATIONS, and uncheck view visibility on COARSE and MEDIUM.  Now this box (element) will only show up on views set to FINE detail level but, will remain hidden on views set to MEDIUM and or COARSE.  This solution might be too late for you but, it might help someone else. 

Tags (2)

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Forma Design Contest


Technology Administrators