Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Zoom out (with mouse scroll) is too strong in Ortho Mode.

31 REPLIES 31
SOLVED
Reply
Message 1 of 32
Br0ken1334
18344 Views, 31 Replies

Zoom out (with mouse scroll) is too strong in Ortho Mode.

Hi again!

In ortho mode zoom out with mouse scroll from close distance much stronger than zoom in, it jumps back too much. Alt-RMB zoom works fine, without this issue.

Another threads about that problem: 

https://forums.autodesk.com/t5/maya-forum/mouse-scroll-zoom-out-problem/m-p/4919598 (no solution)

https://forums.autodesk.com/t5/maya-modeling/fast-zoom-out-problem-re/m-p/6262813 (solution doesn't help)

31 REPLIES 31
Message 2 of 32
sean.heasley
in reply to: Br0ken1334

Hi @Br0ken1334

 

 

This may be due to how your mouse is configured. If you open your mouse settings you can increase/decrease the "steps" when using the scroll wheel.

 

You can also go to  View -> Camera Tools -> Zoom Tool and use that when zooming to have more precise control.

 

Please let me know if this helps or if you need any more assistance!

 

If one or more of these posts helped answer your question, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

 

Kudos are greatly appreciated. Everyone likes a thumbs up!

 

 

Message 3 of 32
Br0ken1334
in reply to: sean.heasley

I tried that, but nothing has changed.

Zoom out from close distance in ortho is still stronger than zoom in. Persp camera doesn't have this problem.

Can you check this issue on your machine?

Without the mouse scroll, zoom works perfectly. But I want to keep the mouse scroll as my zoom tool...

Message 4 of 32
sean.heasley
in reply to: Br0ken1334

Hi @Br0ken1334

 

Hmm ok.

 

I tested it on my machine and there's no difference in zoom in/out.

 

You can try deleting your settings/preferences to reset everything and let me know how that goes for you!

 

 

Message 5 of 32
Br0ken1334
in reply to: sean.heasley

Ok, I deleted my settings, but same issue is still here...

So, maybe this video helps to recognize my problem.

 

 

 

Message 6 of 32
sean.heasley
in reply to: Br0ken1334

Hi @Br0ken1334

 

I understand the issue and thanks for the video!

 

This is just tough to troubleshoot since I can't reproduce the issue.

 

One thing you can try is making sure the pivot point is centered on your object Modify->Center Pivot.

 

Aside from this, you can also try pressing the F key to frame your object and or going to View->Center view of Selection or View-> Look at Selection and then try zooming in and out to see if anything changes.

 

 

Message 7 of 32
Br0ken1334
in reply to: sean.heasley

Nope, it doesn't help at all.

Look at Orthographic Width in Camera Attributes.

For example, when you zooming out with a mousewheel from 0, it will be 6, but zooming in gives you 5.357, not 0. Let's zoom out again... 11,357!

This behavior is almost unnoticeable at big values of Width, if you don't look at numbers (but still here). But small Width (0-10) gives us more visible difference between zoom in and zoom out.

Message 8 of 32
sean.heasley
in reply to: Br0ken1334

Hi @Br0ken1334

 

If you make a fresh scene and scale a cube up so it's somewhat large does this still happen?

 

By chance do you have another mouse you can test this with as well?

 

 

Message 9 of 32
Br0ken1334
in reply to: sean.heasley

Even on large scene (Ortho Width more than 1000), this issue is still there.

Mouse change doesn't help. I even tried to redefine mouse wheel up/down to keyboard keys with help of AutoHotKey.  

 

And I find some inconsistency in Persp camera too in case of small CoI (less than 1).

Scene with cube 1x1x1:

From Center of Interest 20.0, zoom in to 16.139, zoom out back to 20.0, zoom out to 24.768, zoom out back to 20.0. Fine!

From Center of Interest 0.955, zoom in to 0.643, zoom out to 0.955, zoom out to 1.341, zoom in to 1.082(!!!)...

Message 10 of 32
sean.heasley
in reply to: Br0ken1334

Hi @Br0ken1334

 

 I did some more testing and talked with my co-workers and I believe this is simply how the camera works.

 

Like what you noticed with the values not being the exact same when you zoom out/in, this is because the number to move is constantly changing based on viewport space, where the camera is etc.

 

If this is really bothering you, you may want to perform a clean uninstall/reinstall of Maya.

 

However that said, the Ortho with number will never be perfect numbers every time like 6+ for zoom out and 6- for zoom in.

 

 

Message 11 of 32
Br0ken1334
in reply to: sean.heasley

Then why Persp Camera works without that issue? It's quite precise (besides CoI >1).

Message 12 of 32
sean.heasley
in reply to: Br0ken1334

Hi @Br0ken1334

 

It's possible something just affected your Ortho cameras.

 

The cameras get reset to default when you make a new scene so you could try that or you could try creating a new camera and then moving that one to see if this same issue occurs.

 

 

Message 13 of 32
Br0ken1334
in reply to: sean.heasley

I re-install Maya, create a new scene, a new camera, turn on Ortho... But the issue still here.

I was looked at other apps (3ds Max and Blender) that installed on my machine and all of it have a consistent zoom in Ortho.

Message 14 of 32
sean.heasley
in reply to: Br0ken1334

Hi @Br0ken1334

 

I did some more digging and reached out to development on this and this is indeed an issue others a experiencing so this has been logged with our dev team and they are going to work on a fix for a future update/release of Maya.

 

 

Message 15 of 32
Br0ken1334
in reply to: sean.heasley

Good to know that and thanks for cooperation!

Message 16 of 32
xpn.003
in reply to: sean.heasley

Please, please fix this. I am having the same issue.

Message 17 of 32
caner_ozdemir
in reply to: Br0ken1334

The problem still exists in Maya 2019.1

It only occurs in combination of ortographics cameras and small sized objects and mouse wheel scrolls.

When you zoom like 20 times and just zoom out 3 time, you will quickly return almost to the point where you started.

Whoever added this feature, well, it is disgusting and it exists Maya for years and years.

Please fix this.

Message 18 of 32

I have been facing this issue for around 10 years now and have resorted to alt+right click drag (which still zooms out too fast).

 

24 scroll wheel increments for zoom in = 1 zoom out in orthographic views!

I am working on geometry that is 1 default maya unit (grid square) thick. A phone model 1 square thick usually fills the whole default grid so I am not working at an unnecessarily small scale.

 

I teach around 100 different college students Maya each week and this is something they all complain about on day one of modelling in maya.

It is becoming more difficult to keep them away from Blender when such basic things like this and the ghastly mirror tool issues create such a frustrating experience for them.

 

You should do some field research for maya 2020 and visit a nearby school/college that is teaching maya to beginners and see how quickly they uncover glaring issues on the first day.

Message 19 of 32
enalNomad93
in reply to: bshelleyE4YY8

This issue has been driving me crazy for a while! Please fix it!! It happens SO easily, you're looking at what you're working on and accidentally scroll out one wheel click and you're like half a mile away. It must stop.

Message 20 of 32
gilleybaba
in reply to: Br0ken1334

I thought I would reply to this thread to give some more insight to this problem.

 

This has been a problem with Maya since it's first release.  I've been using Maya since Maya 4.5 and it has been in every version.  The issue only happens with the orthographic viewport.  It happens with both scroll wheel and the alt+RMB scroll.  It's harder to see with the alt+RMB but it's there if you look closely.  If you alt+RMB then drag your arm left/right at a constant speed, you'll see how the viewport zooming will speed up or slow down at a certain point.  The scroll wheel problem has been discussed so I won't repeat that.

 

This isn't a mouse issue, and it's not a Maya preferences issue.  It's the way Maya works unfortunately and it has always annoyed me.  It really needs fixed.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report