Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

XGen Guide Turn into curves after rebuild.

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
jasonkohjiazhen
3776 Views, 9 Replies

XGen Guide Turn into curves after rebuild.

Hi,

 

I just started learning how to use XGen. I've been having a problem where the hair guide turns into curves whenever I rebuild it and a warning kept appearing.Forum.jpg

 

Forum 2.jpg

Note: This only happen to the second collection I create.

 

Thank you guys in advance for any of your help!

 

Tags (1)
9 REPLIES 9
Message 2 of 10
mspeer
in reply to: jasonkohjiazhen

Hi!

I don't have any problems here with Maya 2018.4 and Maya 2020.

Also i am not sure if i understand this correct, please upload a scene-file and a video showing detailed your actions.

Message 3 of 10
jasonkohjiazhen
in reply to: mspeer

 Something went wrong with mt previous file so I'll use a sphere and a disc as example. But this time it crashes the moment I place a guide. I'm sure I'm doing something wrong here.

Message 4 of 10
mspeer
in reply to: jasonkohjiazhen

Hi!

 

Sorry, i can't reproduce this here.

What i recommend

1. Delete all XGen date from your project folder, if you don't need it anymore.

2. Update your Maya.

Message 5 of 10

Hi 👋😊 @jasonkohjiazhen 

if we don't need the utilities anymore we have to turn them off

watch the video attachment "gudeToCuerveProblem_01.mp4"

🤍

Message 6 of 10

Thank you so much, this actually helps but in a different way 😂. There is no utilities at all but it still convert to curves. It fixed after I turn on the "Curves to Guides" utilities. It still help helps a lot. Thank you so much.

 

Edited: After restarting Maya, turns out it doesn't always fix it. It still convert to curves even after turning on the

Utilities. This time It fixed after I turn on " Guide To Curves" and turn it off again, it works for me too.

Message 7 of 10

Same thing here and I am using Maya 2023

Message 8 of 10
styloaryan890
in reply to: Moreno_Abel

Even After Turing On/Off the utilities, it doesn't work.

The problem I think was the Mesh.

 

Make a copy of the file for Backup 

My solution was : 

 

1) Select the scalp mesh > Retopologize it. 

image.png

*Now Apply Xgen on the clean mesh and try to rebuild the guides, Check the utilities again for confirmation they are off

if it works then go for it, if it doesn't then follow,

 

2) After Retopologizing, Export the scalp mesh with these settings, turn off "Include these Inputs"

styloaryan890_0-1664518459364.png

 

3) Import the mesh.obj file and then Add the Xgen hair description and test the rebuild functions, This finally worked for me after long time of experimenting.

Hope it works for you.  

 

Message 9 of 10
Kenn00
in reply to: jasonkohjiazhen

Using Maya 2023 here and I ran into the same issue but none of the solutions on this post worked for me, however I did find a solution on another forum.

For me, this issue began occurring later down the line in my scene when I began having multiple collections and descriptions. When adding the first guide to my newest description, the guide in the outliner would be called xgGuide1

 

according to the post I read, xgen begins to freak out when you already have multiple xgGuide1 names throughout your other descriptions/collections

 

So I went and looked for my highest numbered xgGuide and for me it was xgGuide391 on some other collection.

 

So the xgGuide1 on my most recent description I renamed it to xgGuide392 and then the rebuild curve function worked again as intended without generating a new curve and hiding the guide.

Now any future guide I add works as long as it has its own unique name in the outliner. Hope this helps anyone running into this issue!

Message 10 of 10
ngc5585
in reply to: Kenn00

I wonder what Autodesk do knowing about all these issues with XGen. Oh, nothing. As it still bugs the same way

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report