Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Vertex colours not exporting with .FBX

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
deanogibson55
11469 Views, 9 Replies

Vertex colours not exporting with .FBX

I'm trying to export my models as FBX files however the vertex colours are not exporting with it. I've exported the colours before with the FBX format but it's not working anymore. I presumed it was somthing in the export setting but having checked it out I cannot find any option to get the vertex colours to export.

9 REPLIES 9
Message 2 of 10
mspeer
in reply to: deanogibson55

Hi!

 

Are you sure the colors will not be exported?

Please make sure Display Colors is enabled for your mesh in Maya  AFTER  import.

Message 3 of 10
deanogibson55
in reply to: mspeer

I just checked to be sure that wasn't the issue and the colours definitely aren't exporting.

 

 

Message 4 of 10
mspeer
in reply to: deanogibson55

Hi!

 

Please post your FBX and Maya scene-file.

Message 5 of 10
deanogibson55
in reply to: mspeer

FBX File

Message 6 of 10

Scene File (Wouldn't post with the scene file attached so I zipped it)

Message 7 of 10
mspeer
in reply to: deanogibson55

Hi!

I checked your FBX file and it has a colorSet with colors applied.

So it is working.

vertxcfbx.gif

 

Message 8 of 10
deanogibson55
in reply to: mspeer

I see. I was pressing '6' or whatever the show texture key is. I found the Display Colours in the drop down so now it's working on my end too. Now I just need to figure out why my FBX isn't importing the colours into UE4. Off to the Unreal Forum I go!

Message 9 of 10
unreel
in reply to: deanogibson55

I had the same issue, thanks for the pointer on Maya Display to toggle vertex color display, that helped.  To import into UE4.25 I had to use Skeletal Mesh and not Static Mesh, that worked.

 

unreel_0-1597157092058.png

 

Message 10 of 10
lzacharias2
in reply to: unreel

In Unreal (I am in 5.21) you must change the vertex color import option, from ignore to replace. Or you can change it in the static mesh details panel, then reimport.

lzacharias_0-1694729024329.png

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report