Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya Interface Scalling issue. 4k display

32 REPLIES 32
Reply
Message 1 of 33
Anonymous
8108 Views, 32 Replies

Maya Interface Scalling issue. 4k display

Hi there, 

 

I have 2 monitors and just upgraded one of them to 4k. So now one is normal 1080 the other one is 4k. 

 

So of course on the 4k monitor ui scaling on 100% everything was really tiny and hard to see. Then i changed the scaling option to 150% and on the 4k monitor everything is fine looks nice, but when i dock some of the tabs to the 1080 monitor, everything is scaled up to 150% looks gigantic.

 

so im wondering is there a way set the scaling option separately or just adopt the windows scaling settings?

Cos windows 10 does has its own scaling settings too, every other program that i use follows the windows scaling settings and show me the stuffs 150% larger on the 4k, 100% on the 1080. No issues. But maya seems to ignore the windows settings and screw everything up.

 

Please help, i attached pics to

 

32 REPLIES 32
Message 2 of 33
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

I actually have this issue as well at work and it can take getting used to.

 

I currently work on one 4k monitor in the middle and then have two on the sides of it that are at 1920x1080 resolution.

 

Through the Windows settings I have my 4k set up at 150% like you do and I have my two side ones set to 100% which I believe you have as well?

 

It may be hard to tell, but Maya actually does follow those rules. For example if you were to raise your second monitor to 150% you would see the window get even larger.

 

Unfortunately, keeping the monitor at 100% even though it will be slightly larger than your 4k is the only option at the moment.

 

Please let me know if this information is helpful or if you need any more assistance!

 

 

If one or more of these posts helped answer your question, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

 

Kudos are greatly appreciated. Everyone likes a thumbs up!

Message 3 of 33
Anonymous
in reply to: Anonymous

Hi Sean, thank for your replay.

Actually i have the exact same setup 🙂 two 1980x1080 and 1 4k in the middle. I said one 1080p to just not to over complicate it since they are identical monitors. 🙂

And yes i do know that even though the 4k at 150% and two 1080p are at 100%, the 1080s tabs gonna appear bigger and wont be the exactly same.

In my case maya is not following the windows’ scaling setup. Only way for me to see stuffs bit bigger is to change the maya’s own settings. so when i go to maya’s preference and change the scaling to 150% it enlarges everything. So the panels look 150% larger on my 1080p too.

What i want is to make maya understand that i want 100% for 1080, 150% for the 4k. At the moment its 150% on all 3 of them.

Regards
Tumen
Message 4 of 33
Anonymous
in reply to: Anonymous

What im saying is, even though i set my windows settings at 150% for 4k. When i start maya it appears as 100% which is almost impossible to see anything. Please help me to solve it. Couldn’t find a solution from the internet:)
Message 5 of 33
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

I just want to make sure your monitors are setup the same way mine are. Is this how your Windows settings look?

 

monitor_01.png

 

monitor_02.png

 

 

 

Message 6 of 33
Anonymous
in reply to: sean.heasley

yep, the settings are exactly the same. 4k2.PNG4k.PNG

Message 7 of 33
sean.heasley
in reply to: Anonymous

Hmmm this is tough Smiley Frustrated

 

It might be an odd request, but could you possible take pictures and/or video of your actual monitors and the scaling difference happening?

 

I just want to see how much it increases in size compared to mine so we can try and figure this out!

Message 8 of 33
Anonymous
in reply to: Anonymous

I Just solved the problem.

 

i was messing around all those settings and found out that there was this settings in the maya.exe's properties. 

 

So i ticked the Override high DPI scaling behaviour. Chose the System enhanced. It solved the problemss.PNG

Message 9 of 33
Anonymous
in reply to: Anonymous

**** it,

 

It seemed to work just fine for a while but the drop down menus all stuffed up.

 

when i first open it, it works just fine but after like 5 mins the drop down menus go very tiny and the placement is off. But when i tear them up it turns into the proper resolution.

 

 

Please help, i have attached screenshots. In the screenshot i have teared off the same menu to show the diffrence

Untitled-1.jpg

Message 10 of 33
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

Darn! Looks like you almost had it!

 

It's interesting because I don't have the same toggle feature for the DPI settings that you do.

 

Out of curiosity, have you tried the toggle setting to Disable Full screen optimizations to see if that helps?

Message 11 of 33
sean.heasley
in reply to: sean.heasley

Hi @Anonymous

 

Just checking in to see how things are going. Have you had a chance to try the suggestion I provided yesterday?

If your issue is solved, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

Message 12 of 33
Anonymous
in reply to: sean.heasley

Hey man,

 

Thanks for checking in, i don't think that solved the problem. The glitch is still persists.

 

i think there is just some sort of bug in the interaction between windows and maya. I noticed that the drop down menus were getting smaller when i switch  tabs. like when i use other apps and get back to maya the drop downs were tiny.

 

But i think found a way around it.

 

When i first load the maya, i hover over the all menus to open the drop down menus.

Once i did that, i think, it wasn't changing or getting smaller till next time i close my maya. 

Message 13 of 33
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

Yeah this is pretty tough to test Smiley Frustrated

 

I think you're right and it may have something to do with Windows and/or possibly the monitor that you're using. It's just unusual that we have the exact same set up surprisingly and yet it doesn't work for you.

 

By chance do you know if you're on the creators update for Windows?

 

If not you might want to upgrade to that and see if that works!

Message 14 of 33
Anonymous
in reply to: sean.heasley

Thanks Sean,

 

I just checked if there is any windows update. it says my windows is up to date. And the last update was installed in November, which is called Fall Creators update. the version is 1709. I guess this is the latest one.

 

You said it might be my monitor. Is there a way to that i can check or troubleshoot my monitor? or specific settings that i need to tweak.

 

Thanks again Sean, really appreciate for taking your time to replay me. 🙂

Message 15 of 33
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

Yes the Creators update is what I was talking about. Do you know if this issue was occurring before that Windows update?

 

As for your monitor, there should be buttons on the side/back/bottom of the monitor that will allow you to tweak some settings. While there's no guarantee that they will solve your issue they are worth looking into!

 

Let me know when you get a chance to try those steps!

Message 16 of 33
sean.heasley
in reply to: sean.heasley

Hi @Anonymous

 

Just wanted to see how things have been going. Are you still having this issue?


If your issue is solved, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

Message 17 of 33
Anonymous
in reply to: sean.heasley

Hi Sean,

 

I just tweaked the monitors settings. Unfortunately there is nothing helpful which is contrast brightness and colour tone. All just video settings, couldn't find a settings that associated with scaling DPI and that sort of stuffs.

 

im not sure if it was occurring before the update, as i didn't have a 4k display before that.

 

 

thanks for your response.

 

 

Message 18 of 33
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

Out of curiosity, could you try unplugging your other monitors and try Maya on just the 4k monitor and then on just one of the 1920x1080s?

 

Its a bit of a stretch but I'd like to see if the resolution will work normally if there's only one monitor.

Message 19 of 33
sean.heasley
in reply to: sean.heasley

Hi @Anonymous

 

I'm just checking in again to see if you need more help with this. Did the suggestion I provided yesterday work for you?

If so, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

Message 20 of 33
Anonymous
in reply to: sean.heasley

hi, sorry mate.

it did not solve my problem.

 

it only works perfect when i plug only 4k or 2 1080.

 

when i plug them together it screws maya.

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report