Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Chromium Host Execute

19 REPLIES 19
SOLVED
Reply
Message 1 of 20
Anonymous
2287 Views, 19 Replies

Chromium Host Execute

Hey Everyone, 

 

I've been animating a scene for a while in the student version of Maya 2018 on my Surface Pro and running Windows 10 without any problems. Then all of a sudden (when I was getting close to finishing it, of course), I tried opening it up and I can see it loading. However, once it's fully loaded, I don't see the characters in the scene and Maya completely freezes. When I go to the task manager, I see 4 or 5 different "Chromium Host Execute" listed inside of the Maya tab and it tells me "Maya not responding". I've googled how to fix this, but either I'm not smart enough, or I'm missing something.

 

I have had a friend open the file without any problem on his home computer, renaming it, and sending it back, but I get the same issue. I've done a complete re-install and get the exact same problems. 

 

I've run Malware software to see if there are any threats or infections - nothing!

 

I've pasted a couple of images of what I get when I try opening my file below.

 

Short of taking up residence at my friends house to finish the shot, I'm not sure what to do... any suggestions?

 

I've almost finished this shot and would love to be able to take it to completion.

 

Thank you!

19 REPLIES 19
Message 2 of 20
sean.heasley
in reply to: Anonymous

Hi @Anonymous and welcome to the community!

 

We actually have an article on this here that should help!

 

From that article:

 

Solution:

Many of these processes may need to run during a program session. However, to minimize online access and Chromium Host Executable usage try the following:

  • Disable the Welcome Screen options for each product. -- For example, in 3ds Max go to Help > Welcome Screen and in the lower left corner un-check the box to "Show this Welcome Screen at startup".
  • Add the acwebbrowser.exe *32 application to any Anti-Virus, Malware, Firewall or PC component tools/software as an exception (if applicable).
  • Log out of A360 Cloud Services (if and when possible).
  • Switch HELP to local files instead of online help files.
  • Change User Profiles to Admin (if and when possible).
  • Disable or manually start the Autodesk Desktop App. You can do this by going to:
    1. Windows Start > Run and type in "services.msc"
    2. Right-click on Autodesk Desktop App Service and select Properties.
    3. Under the General Tab choose a "Startup type" of your choice for this app (i.e. Disabled, Manual, etc.)

 

Please let me know if anything changes!

 

 

Message 3 of 20
Anonymous
in reply to: sean.heasley

Hi Sean, 

 

Thank you so much for taking the time to reply. I have taken all these steps already and I'm still getting the following image in my task manager:

maya errorr 03.JPG

 

I'm at a complete loss for what to do next. I can definitely start over, but I would LOVE if I didn't have to. Anything else you could suggest would be greatly appreciated!

 

Thank you!

 

Pablo

Message 4 of 20
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

Hmm ok.

 

This might be related to the ACWebBrowser.exe. This is a part of the Maya desktop app which comes with Maya. While it usually doesn't do much and just chills in the background it may be causing this specific issue.

I am currently running Maya 2018 and Windows 10 and if you navigate to C: >Progam Files(x86) >Autodesk>Autodesk Desktop App you will see a folder named AcWebBrowser.

As long as Maya and the desktop app aren't running (kill them in Task Manager if they are) you can delete the folder and then see if they still appear when launching/running Maya.

 

Let me know how that goes!

 

 

Message 5 of 20
Anonymous
in reply to: sean.heasley

Sorry, I forgot to mention that instead of just disabling the Autodesk App, I completely uninstalled it from my computer. So, when I navigate to that location, there isn't anything there.

 

I'm still running into the same problem though. 

 

Here's some more information that MIGHT help...

 

I had sent the file to a friend who also is using a student version of Maya 2018. He also has the Malcom rig from Anim School. He said he was able to open it just fine. He saved it out under a different name and sent me back a file to try and open it. When I open it, because of the different file path structures on our computers, I'm always asked to browse and locate the rigs. When I skip that step (locating the rigs), I can open the file without any problems - but the rigs aren't there. When I connect the malcom rig using the reference editor, it loads it, and then immediately freezes. 

 

Also, when I go back through every single previous version of this particular scene, I can't get it to open, but I can open other saved files without any issues.

 

I don't know if that helps, or was totally unnecessary, but if you can help me figure this out, I will name a child after you!

 

Thanks again, Sean!

Message 6 of 20
dgorsman
in reply to: Anonymous

I don't think Sean covered the technical "why" of this yet... most Autodesk products spin up Chromium hosts to handle things which don't directly impact the running program, such as online help dialog, some licensing checking, checking online for program updates, and so on.  This allows the core program to run while these tick away on separate threads.  Short version is, they are supposed to be there - it's not a virus or anything along those lines.

 

A few releases have had problems with these unnecessarily consuming large amounts of resources.  Typically those problems get fixed with one of the later "point" updates.

----------------------------------
If you are going to fly by the seat of your pants, expect friction burns.
"I don't know" is the beginning of knowledge, not the end.


Message 7 of 20
sean.heasley
in reply to: dgorsman

Hi @Anonymous

 

@dgorsman is correct. The chromium hosts aren't malicious in anyway and shouldn't really be affecting your work however I have seen it on a few rare occasions cause small problems.

 

Since my above post doesn't help we can try a few other things. You mentioned your peer was able to open the file fine. If you open the file and export it everything to an fbx and reimport it into a blank empty scene does it work normally?

 

If not then at this point you may need to perform a clean uninstall/reinstall of Maya and try deleting your settings/preferences as well.

 

 

Message 8 of 20
Anonymous
in reply to: sean.heasley

Cool, guys. I guess I was thinking they were a malicious type of virus or something. Which would explain why the malware scans picked up nothing. I will try exporting everything as an FBX and see if I can make it work.

 

If not, would you mind explaining what a "clean uninstall and re-install" is? I've done the uninstall of Maya. I've gone through the windows folders and deleted everything that was labeled Autodesk (although maybe I missed something), and I just barely got everything set up again, and it didn't work - which is why I posted here. So, just treat me like I'm new to this and see if I missed something... please?

 

I just want to make sure I'm doing everything right before I give up on this.

 

Thanks guys!

 

 

Message 9 of 20
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

From the sound of it you did indeed perform a clean uninstall/reinstall of Maya

 

The difference is when an uninstall is done via windows or the program itself occasionally files or folders can be left behind that can allow the issue to linger when Maya is reinstalled. By performing a clean uninstall, you're completely removing all files, folders etc literally everything related to Maya or Autodesk from your machine. That way when you reinstall its as if you're installing Maya for the first time and thus preventing any issues that may be occurring from the previous install from happening.

 

 

Message 10 of 20

Tengo el mismo problema. Pero Maya me funciona, con archivos pequeños. Cuando intento abrir archivos mayores se queda congelado. He realizado todo lo que han sugerido pero nada sirve. No abre los archivos que necesito modificar.

 

Alguna otra sugerencia?

_______________________

 

I have the same problem. But Maya works for me, with small files. When I try to open larger files it is frozen. Everything I have suggested was done but nothing works. It does not open the files that I need to modify.

 

Any other suggestions?

Message 11 of 20

Hi @soledad.ramirez

 

Is your 2018 up to date?

 

Also, does this happen on multiple scene files or only a specific one? When you get a chance can you attach the file here so I can take a look at it?

 

 

Message 12 of 20

Sucede con los archivos más grandes, los que tengo con referencias.

A principio de año realicé mi trabajo final del un Diplomado. https://vimeo.com/256843796

La última vez que utilicé un archivo de estos fue en agosto. Todos se abrían, ahora solo se abren los muy livianos.

 

Mi versión de maya es 2018.4 , yo creo que tiene que ver con window 10 y alguna actualización. O tal vez con la calidad de Internet. Pero eso es más difícil porque no he cambiado de proveedor.

 

Te adjunto un archivo que se abre y otro que no. farol.mb se abre, pero Aijpel_low.mb no se abre. Ninguna de las escenas de mi cortometraje se abre ahora.

________________________________

It happens with the biggest files, the ones I have with references.

At the beginning of the year I did my final work of a Diplomate. https://vimeo.com/256843796

The last time I used a file of these was in August. All opened, now only the very light open.

 

My version of maya is 2018.4, I think it has to do with window 10 and some update. Or maybe with the quality of the Internet. But that is more difficult because I have not changed providers.

 

I enclose a file that opens and another that does not. farol.mb opens, but Aijpel_low.mb does not open. None of the scenes of my short film opens now.

 

Saludos, Regards

Message 13 of 20

Hi @soledad.ramirez

 

Thanks for attaching the files!

 

I just opened both of them with no issues.

 

Regarding your ideas, your internet provider has nothing to do with opening files however it could be a windows update causing the issue.

 

I would recommend rolling back your most recent Windows update and/or performing a clean uninstall/reinstall of Maya.

 

 

Message 14 of 20
sean.heasley
in reply to: sean.heasley

Hi @soledad.ramirez

 

Just wanted to check in to see how things were going. Are you still having this issue?

 

If your issue is resolved, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

Message 15 of 20
Anonymous
in reply to: sean.heasley

Hi Sean,

 

I wanted to give you an update. I did a reset to factory settings on my computer (after backing everything up), and re-downloaded Maya and the character rigs. AND... I'm running into the same problem. I think it has to do with the character rig file itself. I'm using Malcom 2.0 from AnimSchool and every time I try do reference him in - even in a clean new shot - the program freezes. I can reference and open files with other rigs. I'm not sure why this specific rig is giving me a problem all of a sudden after having used it for so long? 

 

Any ideas?

 

I get a little farther when I try opening up his rig instead of referencing him in. I can see a bit more, but then Maya freezes. Seeing as how my friend could open it up just fine on his computer, I'm not sure what else to do after doing a factory reset.

 

Anyway, I figure there's not much left to do besides give up, but I wanted to give you an update.

 

Thanks for all your help anyway!

 

Pablo

Message 16 of 20

Hola tuve que reinstalar completamente window 10, probé muchas variantes pero ninguna funciónó. Ya puedo abrir los archivos. Estoy solucionando un problema de fuera de memoria, pero parece que es que me faltó un controlador.

Creo que el problema fue la penúltima actualización de window 10.

Te avisaré cualquier cosa, ahora puedo abrir los archivos y no se queda congelado.

Pero tendré que instalar todos los otros programas que uso.

Saludos

______

Hi I had to completely reinstall window 10, I tried many variants but none worked. I can open the files I am solving an out-of-memory problem, but it seems that I was missing a driver.
I think the problem was the penultimate update of window 10.
I'll let you know anything, now I can open the files and it does not stay frozen.
But I will have to install all the other programs that I use.
regards

Message 17 of 20

Hola, sigo con el problema de memoria.

Te adjunto el output de window por si se te ocurre algo.

 

Otra cosa este post no es mio yo solo me integré porque es el mismo problema.

Saludos

Sole

______

Hi, I'm still with the memory problem.
I attach "Output window" screen in case it occurs to you.

Another thing this post is not mine I just joined because it is the same problem.
regards

Sole

Message 18 of 20

Hi @Anonymous

 

Hmm that leads me to believe it may be a hardware issue on your end.

 

What GPU are you using and does the driver match up with our certified hardware list?

You can find our certified hardware list here!

 

Hi @soledad.ramirez

 

For the memory issue yes its generally a driver issue.

 

So you can try:

1. Updating you graphics card driver

 

2. Try disabling OpenCL by adding

MAYA_DISABLE_OPENCL=1

 

 

Let me know if anything changes!

 

 

 

 

Message 19 of 20

OYG!

Hi, again does not open maya, window asked me to update and zaz! They do not open heavy files.

Try for the tenth time to update the driver. Nothing
This code is not where to put it
MAYA_DISABLE_OPENCL = 1

I think that reinstall the window again and if it works I will deactivate the update.

regards

____

Hola, de nuevo no abre maya, window me pidio actualizar y zaz! no abren los archivos pesados.

 

Intente por decima vez actualizar el driver. Nada!

Este codigo no se donde colocarlo

MAYA_DISABLE_OPENCL=1

 

Creo que reinstalare window nuevamente y si funciona desactivare lo de actualizar.

 

Saludos

Message 20 of 20

Hi, @sean.heasley 

I have already added the code. look for another post
It was that!
Thanks to the end I managed to open the file.
Thank you thank you thank you.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report