Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

AutoSave skipped since "current scene is itself an auto-save file"

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
ijdallas
2487 Views, 6 Replies

AutoSave skipped since "current scene is itself an auto-save file"

I've enabled AutoSave in my user preferences but the file I'm currently working in isn't generating any autosaves.

 

Every couple of minutes when the autosave should trigger I see this warning printed in the log:

AutoSave skipped since current scene is itself an auto-save file.

 

Autosave has worked fine for me with other files. I'm using Maya 2017.5. I'm guessing this particular file is causing problems because at some point, after a crash, I copied an autosaved version to restore my data. I looked inside the ascii *.ma file but didn't see any lines that jumped out at me like, say, "autosave=true" to delete so I'm not sure WHY Maya is convinced this is an autosave file.

 

How can I tell Maya that the current file is NOT an autosave file and that autosave should be re-enabled for it?

6 REPLIES 6
Message 2 of 7
sean.heasley
in reply to: ijdallas

Hi @ijdallas

 

If you create a new empty scene and enable this feature does the same issue occur?

 

One thing you could try is manually saving this scene and name it something else. From there you can restart Maya and open that file then see if this same issue occurs.

 

Please let me know if anything changes!

 

 

Message 3 of 7
sean.heasley
in reply to: sean.heasley

Hi @ijdallas

 

I'm just checking in again to see if you need more help with this. Did the suggestion I provided yesterday work for you?

If so, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

Message 4 of 7
ijdallas
in reply to: sean.heasley

 

I think I figured it out. The problem seems to be related to the current project directory, and specifically to the workspace.mel created in the root of that directory. 

 

When I set the Maya scene's project directory (ie, File > Set Project...) to a "bad" directory then auto-save starts to fail. It stops failing as soon as the project directory is set to a "non-bad" directory. In trying to figure out what makes a directory "bad" the only difference I've found is that the workspace.mel file in my "bad" directory is shorter than normal. When I create a new project directory the default workspace.mel file that Maya creates is about 45 lines long, but the one in my "bad" directory has only 2 lines of code (for setting "templates" and "particles"). I don't know how the workspace.mel in my "bad" directory became so short, but I did not personally edit the file previously so it seems Maya did this at some point.

 

The crucial missing line in the workspace.mel which causes auto-save to start failing is:

 

 

workspace -fr "autoSave" "autosave";

 

 

If I experimentally add or remove the "autoSave" line of code (and then restart Maya) I can cause auto-save to start succeeding or failing respectively.

 

So if anyone else encounters this issue, it seems fixable by editing the workspace.mel in the project directory to make sure it includes the "autoSave" line of code above. 

Message 5 of 7
sean.heasley
in reply to: ijdallas

Hi @ijdallas

 

Awesome job! Thanks for explaining what you did and marking it as the solution!

 

Hopefully this will help any lurkers that may find this thread in the future Smiley Happy!

 

 

Message 6 of 7
A01283776
in reply to: sean.heasley

Hi, im having the same issue here but I dint understand how did the person above solved it... can you explain it to me?

Message 7 of 7

Reviving this years later to say that it did indeed help, and hopefully this lil poke will drag it up the search results a bit. XP

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums