Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Incorrect units on export

11 REPLIES 11
SOLVED
Reply
Message 1 of 12
samVBUWV
312 Views, 11 Replies

Incorrect units on export

Hello,

I have a design with active units set to inches in Document Settings before any sketches were made.  On export, it still shows inches as the active units.

 

When I export to DXF, it is changing it to centimeters.

 

Looking inside the DXF using a text editor I see:

 

$INSUNITS
70
5
9

 

Am I missing a setting or a sequence somewhere?

Tags (2)
11 REPLIES 11
Message 2 of 12
jhackney1972
in reply to: samVBUWV

If you use the Export command, the cloud server will convert the DXF to centimeters.  If you right click on the sketch in the Browser and use Save As DXF, it will maintain the units of the sketch.

 

Save As DXF.jpg


"If you find my answer solved your question, please select the Accept Solution icon"

John Hackney
Retired

Beyond the Drafting Board


Message 3 of 12
samVBUWV
in reply to: samVBUWV

Thank you!
What do I do if I have multiple sketches in one body and want them combined into one DXF?

Message 4 of 12
samVBUWV
in reply to: samVBUWV

037875CB-1856-4883-9CBC-E46D2FB61347.jpeg

Message 5 of 12
jhackney1972
in reply to: samVBUWV

You will have to combine the separate sketches.  You also can import more than one DXF.


"If you find my answer solved your question, please select the Accept Solution icon"

John Hackney
Retired

Beyond the Drafting Board


Message 6 of 12
HughesTooling
in reply to: samVBUWV

What program are you opening the DXF in? Does it let you pick the units when you open\import the design? 

 

Mark

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 7 of 12
samVBUWV
in reply to: HughesTooling

Hello,

I sent the dxf to a local machine shop for a quote, and the person there said it opened as 177 inches.  It should have been 70 inches (1771mm).  So, it opened it in inches, but applied the centimeter value.  I'm not sure what program they are using.  This seems like a pretty big flaw in the export routine for a software product that is so pervasive and mature (and expensive).

Message 8 of 12
samVBUWV
in reply to: jhackney1972

Exporting one sketch worked.  I searched for ways to copy and paste one sketch into another with no luck.  Is this possible? Or do I have to recreate the other two sketches inside the first sketch?

Message 9 of 12
HughesTooling
in reply to: samVBUWV


@samVBUWV wrote:

Hello,

This seems like a pretty big flaw in the export routine for a software product that is so pervasive and mature (and expensive).


Really it's a fault in their software, did you try inserting the file back into Fusion? The info for what units were used to create the file are in the DXF the opening program just need to read them when importing. The insunits should be read when you open the design, some programs you need to open an inch template then insert the DXF and it'll scale to the correct size.

 

Mark

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 10 of 12
samVBUWV
in reply to: HughesTooling


@HughesTooling wrote: Really it's a fault in their software...

Hi Mark,

Thank you for replying.  I don't mean this reply in an argumentative way.  I am just explaining my reasoning here, which might expose where my ignorance lay.  If I can save a sketch as a DXF and it correctly exports the $INSUNITS as 1 (inches):

$INSUNITS
70
1
9

 

Why does exporting the whole file as DXF set $INSUNITS to 5 (centimeters)?

$INSUNITS
70
5
9

 

Unless the DXF spec has another variable that tells it to convert/scale the values, and the other program is ignoring it?  I'm a software dev guy by trade, so I have a compulsion to understand the root cause. 

 

Thanks again for taking the time to reply,

Sam

Message 11 of 12
HughesTooling
in reply to: samVBUWV

@samVBUWV The problem is the cloud exporters default to CM for exports they do not read the setting in the design or your preferences. This only causes problems for programs that don't read the unit info in the exported design. The problem has come up many times and there have been suggestions it will be improved in the future but don't hold your breath as the requests for improvements have been around from the start, 8 years or so!

 

Really the program opening the file should read the insunits but a lot don't.

The problem is for a lot of AutoCAD clones, DXF's are seen as unitless (and are) so if you just open the file it will open as 27.94 units high (using your default units) and insunits is ignored but if you insert into an inch file it's scaled correctly. Not used AutoCAD for years but think it used to work the same. Insunits is a bit like a note on a paper drawing not actual units like in a units aware program like Fusion.

This is what I get if I insert your file into a design set to inches in NanoCAD.

Clipboard01.png

 

One other option you have would be to create a 2d drawing of the part using the ANSI template and save as a DXF or DWG.

 

Mark

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 12 of 12
samVBUWV
in reply to: HughesTooling

@HughesTooling That was a great response.  Thank you for taking the time to explain it in detail.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report