Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Post processing within Fusion 360

153 REPLIES 153
Reply
Message 1 of 154
GeorgeRoberts
15961 Views, 153 Replies

Post processing within Fusion 360

Good afternoon community!

 

The post-processing option has now been merged into the NC program experience. 

 

The experience and functionality you get for post-processing used to depend on both what operating system you were using and what button you used to start post-processing. Over the past few months, we have been working on unifying these experiences by expanding NC programs to ensure it has all the functionality needed to replace the multiple post-processing dialogs that exist today.

GeorgeRoberts_3-1629753537031.png

 

 

One of the important changes to be aware of is the usage of the post library for post-processor management and selection. This gives you more ways to manage your post-processors and will give a better way of consuming post-processor updates from our Fusion 360 post library.

If you would like to continue to use your local drive to store post processors, simply 'link' your local drive to the post library by right-clicking on the 'linked' option and choosing 'link folder'

GeorgeRoberts_0-1629753291114.png

 

Like always with post-processing, check your selected post properties and output code carefully before running code on your machine tool

 

-

George Roberts

Manufacturing Product manager
If you'd like to provide feedback and discuss how you would like things to be in the future, Email Me and we can arrange a virtual meeting!
Labels (1)
153 REPLIES 153
Message 2 of 154
engineguy
in reply to: GeorgeRoberts

@GeorgeRoberts 

 

George, with respect :-

 

If this is to be "foisted" upon us then at least make it actually readable, that has been the main reason why I don`t use the NC Program, it is just like the new Tool Library, too faint to see easily, the old (Legacy) Posting Dialog and the old Tool Library were great, proper contrast and not looking like something that is "greyed out".

Same as on here, I have to use the "Bold" option in order to make text good and clear to see !! 😞 😞 😞

OK once it is Posted but not while typing!!

 

Grrrrrrr!!!

Message 3 of 154
GeorgeRoberts
in reply to: engineguy

Hi @engineguy ,

 

Thanks for the reply! We have updated the styling with this to hopefully make it more readable (see screenshot below)

GeorgeRoberts_0-1629755744619.png

 

Hopefully this is better! If this doesn't feel any better than before, please let me know. I will speak with our designers and we can look at taking another pass at the styling/colors

-

George Roberts

Manufacturing Product manager
If you'd like to provide feedback and discuss how you would like things to be in the future, Email Me and we can arrange a virtual meeting!
Message 4 of 154
engineguy
in reply to: GeorgeRoberts

@GeorgeRoberts 

 

Hi George, well a little better in that the checked boxes now have a dark background so it is easier to see them when checked, however that doesn`t do anything for the unchecked stuff, fractionally better but still not good enough IMHO.

Good example, I have set this response to Bold and you will be able to read it much better, a good example is your own first Post, you did one line at the start and one at the end in Bold, reason? to make those lines stand out and make them easier to read, look at the difference between my posts here and your own, honestly, which are the easiest to read ??

Your Designers will no doubt be working in Optimal conditions with good quality hardware with excellent resolutions, the majority of us are working on computers in badly lit workshops/sheds/garages and not the best hardware (Mine is 10 years old, the i7 CPU is 2nd generation!) so please ask them to help out us poor mortals on a tight (strangulated) budget !!!  🙂

 

As for the NC Program to be brutally honest I don`t see any advantage in having the facility at all, anything that can be done in the NC Program (As it is now) can be done without it !

Just the musings of an old Machinist who has been changing the shape of lumps of metal for more than 55 years 🙂

Not against change at all, I have changed my ways many times over the years to keep up but IMHO this comes under the heading of "Change for change sake", not necessary 😞 😞

 

Again with respect 🙂

Message 5 of 154
engineguy
in reply to: GeorgeRoberts

@GeorgeRoberts 

 

Hi George

Well, updated and the new NC Program is no good at all, so faint that for me at least it is almost unusable, the Extension type (eg .nc) is particularly bad, apart from that it is badly "broken", I have tested opening file that have worked fine for many months and instead of using the correct Post Processor that has been assigned to that file since it was created it now defaults to a HAAS Post Processor so this now means that every file will have to be re-set to the correct Post Processor, many, many files 😞 😞 😞

I will therefore be staying with the old system where a file that I haven`t opened in several months still opens with all the original correct information, it does appear that once re-set it is remembered but to have to make this change to a lot of files is to me unacceptable.

See image below, don`t know about you but I can barely see what is in the nc extension box, second image is of the old style, why can the new Posting Dialog not be made as clear s the old one ????

These are just small examples of how bad the new NC Program really is, my suggestion for what it`s worth IMHO the designers need to go right back to the beginning as there is no real better functionality that I can see, anything that can be done in this new system can already be done with the old system, so I will be going back to what works fine and doesn`t need change.

If it transpires that the Legacy option is removed then that will stop me from using Fusion and as I have a 3 year subscription I think I will be asking for a pro rata refund !!!!

Very, Very disappointed 😞 😞 😞

New NC Program.jpgNew NC Program-2.jpg

Message 6 of 154
seth.madore
in reply to: GeorgeRoberts

@engineguy I'm not following what you're saying in regards to having to select the post processor all over again for every file. In my quick testing, it seems that selecting my Kitamura post (Cloud library) for one file will also default to that same post in any older file that I open. This seems consistent with old behavior


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 7 of 154
engineguy
in reply to: GeorgeRoberts

@seth.madore 

 

Hi Seth

Yes, that will work for those files that do use that Post Processor, however if the "default" PP is used on 3 Axis files then yes it carries over, however when a 4 or 5 axis file is opened it has the same default 3 Axis PP so they would all have to be changed, same goes for using Machine Configuration, even though a PP has been set in a Machine when the new NC program is used it opens with the "default" PP which can be completely different!

Again, yes, when re-set it is then remembered by the new system but still a lot of re-setting/re-selection required as far as I can see !!

I still do not see any need for this NC Program system, maybe me just being a bit dumb but I do not see any functionally that is not already currently available within the Manuafacture workspace ????

It has tool reorganize, select individual operations to run or not as desired, simply holding down the "Ctrl" key and selecting what I want right there and then without going to a separate area to do it seems the easiest way to do it ???

Message 8 of 154

Liking the Blue highlight for properties that have been changed from the default, However when re-opening an NC program for edit - the blue is gone until a change is made.

Message 9 of 154
GeorgeRoberts
in reply to: engineguy

Hi @engineguy 

Thanks a lot for taking the time to provide the feedback, it is very useful! 

 

You're correct, most of the functionality was available through the windows post-process dialog. The Mac post-processing dialog was significantly different and lacked a lot of the functionality that a CAM user would expect. This change aims to bring a single experience across all platforms that we support now and in the future. 

 

I'm not sure I follow the reselection of the posts issue. Would you be free for a call to discuss this (I'll send you a PM)? This certainly sounds like something that shouldn't be happening and should be something that we fix ASAP.

 

@carl.j.barker thanks for the feedback, I'll raise a task and get this resolved! 

-

George Roberts

Manufacturing Product manager
If you'd like to provide feedback and discuss how you would like things to be in the future, Email Me and we can arrange a virtual meeting!
Message 10 of 154

I'm having trouble with "output folder" not sticking. Have to reselect each time. 😞

David

Message 11 of 154

Hi @david.lundbergC7AM5 ,

Thanks for posting. Are you setting the output folder when first clicking the post process button, or when editing an NC program? I believe the settings are only remembered when choosing the settings when the dialog is first opened (not from editing)

-

George Roberts

Manufacturing Product manager
If you'd like to provide feedback and discuss how you would like things to be in the future, Email Me and we can arrange a virtual meeting!
Message 12 of 154

@GeorgeRoberts Ah. I'll give that a go.

Message 13 of 154

@GeorgeRoberts just like you said, that worked just fine. 🙂

Message 14 of 154

Perfect, thanks for getting back to me @david.lundbergC7AM5!

-

George Roberts

Manufacturing Product manager
If you'd like to provide feedback and discuss how you would like things to be in the future, Email Me and we can arrange a virtual meeting!
Message 15 of 154
engineguy
in reply to: GeorgeRoberts

@GeorgeRoberts 

 

Yes, that works but it still had to be changed when opening the NC Program, this should have still been as originally set in that file, yes again, all files that used that location should update, great, not so great if files are saved to numerous locations, example, a folder is created on a PC for a job, all files for that job are saved in that folder and that location would have been set for the file originally, now open a different file with a different job folder and it no longer has the correct folder path, has to be changed!

So, as many folks do save out all their work for each job to individual folders on their computer (Or Cloud even) whenever a file is opened again say a couple of weeks later to maybe change design slightly then the location will have to be re-selected if it has not been saved with the new system!!

Message 16 of 154
cmsracing48
in reply to: GeorgeRoberts

Is there a way to set options in the post properties to repeat every time.  For example, Home Position Center is not the default.  I'd like to make it the default so I don't have to check the box each time.

Thanks

Message 17 of 154
rhdfmail
in reply to: engineguy

The issue with machine-configs not fully used is... plain stupid

If I select a machine in my setup and that machineconfig has a corresponding, well proven, post attached, it probably means that I want to use that post for that machine in that setup.

i've had this issue on and off (some programs work some don't) for well over a year now with the old post-dialog. the response from autodesk seems lite "works on mine computer (since there probably is some seme-documented order stuff has to be done in to make it work 100%)
Message 18 of 154
GeorgeRoberts
in reply to: rhdfmail

@cmsracing48 thanks for the message. The option should be set as default if you change it after clicking the 'post process' button. Is this not the case for you? 

 

@rhdfmail sorry to hear that you haven't had a solution provided by Autodesk. I will drop you a PM now. I'd like to understand your issue and help get a resolution released in-product

-

George Roberts

Manufacturing Product manager
If you'd like to provide feedback and discuss how you would like things to be in the future, Email Me and we can arrange a virtual meeting!
Message 19 of 154
rhdfmail
in reply to: GeorgeRoberts

As far as I have noticed see that issue seems to been solved (or I'm just lucky) by creating a new machine-config with a simulation-model attached. (that was the reason for creating a new one)


Message 20 of 154
GeorgeRoberts
in reply to: rhdfmail

@rhdfmail thanks for letting me know. I've sent you a PM to try and understand what the issue was (so I can double-check to ensure it has been resolved)

-

George Roberts

Manufacturing Product manager
If you'd like to provide feedback and discuss how you would like things to be in the future, Email Me and we can arrange a virtual meeting!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report