Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error download thumbnail: Wrong URN. No asset ID defined. Retry

27 REPLIES 27
SOLVED
Reply
Message 1 of 28
christopher2KLSVU
1335 Views, 27 Replies

Error download thumbnail: Wrong URN. No asset ID defined. Retry

@yqliu 

@HelenChen-ElectronicsQA 

@RichardHammerl 

 

I have now problem with all the parts which I have previously assigned 3D package to.

Their 3D bodies are rendered ok, however every part which I reworked now reports this error when I browse in Library Manager, or in right click Package. Same is after I Open device. See Pictures bellow.

 

112233

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

BTW. Shortcuts type of CTR+ALT+E to hide/show design manager or inspector does not work 🙂

 

27 REPLIES 27
Message 2 of 28

I have the same issue (same error message) with new parts I create.

 

Thing what seems to fix it to push your changes to the library.io repo.

When it's done synching the error disappears and the parts shows correcly.

 

There must a bug somewhere as local library changes should not be depended on the remote library access.

 

 

Message 3 of 28

If i push parts to library IO are my parts public?

BTW why do we need library.io when We can save libs in team? What is an advantage of library IO?.

 

I know, they do not proper handle parts references, I am reporting this since August. Before last release they did not proper render 3D packages, were missing. Walk around was to add second package variant to same library and the second variant was proper referenced somehow internally and thus was proper rendered.

Message 4 of 28

I think all the library.io libraries are private by default.

 

I'm also bit confused about the functionality of library.io when everything is saved to cloud anyway.

 

 

Message 5 of 28

Hi @christopher2KLSVU , @phaggren ,

 

Sorry for any inconvenience about the thumbnail downloading issue.

We have a fix for the next release of Fusion 360 about it, I will keep you be posted if the new version is out.

 

And for the hotkey to hide/show design manager and Inspector, it works well for me on Mac and Windows.

Could you please try to reset to default layout and try the hotkey again?

截屏2020-11-20 下午10.29.07.png

 

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 6 of 28

Hi @christopher2KLSVU ,

 

The missing 3D model part in the 3D PCB design has been fixed in the latest update of Fusion 360, version 2.0.9313.

Do you still have problem about this? Hope it works well for you now. 🙂

 

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 7 of 28

NO problem with 3D package view, 3D packages are rendered ok. However every reedited part, library has problem with its sub-miniature. What is more every reworked library is listed twice in Library Manager as in picture bellow: normal one a second ghost copy with strange reference/name.err4.png

Message 8 of 28

It does not work, CTRL  +ALT +I works, CTRL+ ALT+ E does not.

Message 9 of 28

Hi @christopher2KLSVU ,

 

It's so strange..

The hotkey CTRL + ALT + E and CTRL + ALT + I both works well for me.

Did you try to relaunch Fusion 360 to have a try as well? Hope it helps.

 

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 10 of 28

Hi @christopher2KLSVU ,

 

May we know when did you create and modify the library has the strange name in local?

Could you please help to check whether you are able to reproduce this issue from a new created library? It would be very helpful for us if we know the key steps to reproduce it.

Thank you very much and so sorry for any inconvenience.

 

Regards,

Helen

 



Helen Chen
Principle QA for Fusion 360 Electronics
Message 11 of 28

1.CTRL + ALT  + E does not work, yes I have restarted it few times- nevermind i can use mouse.

 

2.This part was created for sure before last release, in  August.

Actually  I have seen very often "ghosts" of my own libraries while I was looking for them in Library Manager. I thought it is normall as probably ghosts were used during edition.

Message 12 of 28

I am using the new Fusion 360 v2.0.9313 and I still get the error message "Error downloading thumbnail. Wrong URN. No asset ID defined." on every part that I am creating.

 

I tried creating a new SOP device and left everything the way that it was set as 20 pins. Ten on each side.

I save the newly created part as Testing-Package.

 

I created a new Symbol for it and saved it as Testing-Symbol.

 

I created a New Device and saved it as Testing.

 

I added the new Symbol, then the Package. That is when I received the error message.

 

I have tried everything to fix this but still does not work.

 

Any help would be appreciated.

 

 

Message 13 of 28

Hi @cosmos46 ,

 

Sorry about any inconvenience.

The fix of the issue is not released yet, please stay tune for the next release of Fusion 360.

I will keep you be posted. 

 

FYI - The thumbnail issue not impact the View 3D PCB result.

 

Regards,

Helen 



Helen Chen
Principle QA for Fusion 360 Electronics
Message 14 of 28

Hi - 

 

I am quite new to Fusion Electronics - coming from Eagle.

 

I am having problems this as well, more particular, when trying to add a 3D package to a component already in the board design and not prior to designing a board.  I have been following this tutorial ut so far no luck:

 

For now I think I will simply hide the bodies for each part and manually add STEP files to the final design.  Would prefer to do it the correct way as I assume it will be available for later use then as well?

 

Regards,

Friedl.

Message 15 of 28

Package generator sometime works as on your sub-miniature, that the pads are only "transmitted". But when you try to do this again after restart, it works good. Do not ask why. Do not relay on sub-miniature preview, it is currently broken, this is why this topic is. Just check in 3D board view if you got right body( even there is no sub-miniature).

 

 

Second way is to get somewhere step file of interested part and add it via " insert Into current design". You add it to the part, not to the 3D board. But first you have to open step file in fusion, save the step file in your team files. Then you have it on My Recent data list from where on right click you do "insert to...."

 

Message 16 of 28

Hi - 

 

Great thanks!

 


@christopher2KLSVU wrote:

Package generator sometime works as on your sub-miniature, that the pads are only "transmitted". But when you try to do this again after restart, it works good. Do not ask why.


I will try to restart and see whether it works.  Also, if it is an existing part being updated with a new 3D package, dies it automatically sync to the board file?  In Eagle you had to choose update component. Not sure about the workflow in Fusion Electronics.

 

The second method you are describing is how I used to do it before I knew how to add 3D packages to footprints.  This works well but of course, you will have to do manually do this each time the component is used.

 

Regards, Friedl. 

 

Message 17 of 28

1. You click view 3D icon in 2D PCB editor, and 3D board view is regenerated, if there is no any changes it will be not updated, trick is to move something on PCB.

 

2. No just once at least in my way, when I adding multiple same parts I just do copy paste without going to library manager, but effect is the same. If you have already multiple same parts on board, then use "replace". Yes you have do it n times, for N parts.

This is why Fusion is Poor when you compare it even to old Pads logic , where you can make "Replace all this part type" and in one click you update for example 30 test points. Fusion is Poor and currently is the worst software I ever used, non stop crashing, no shortcuts for layer switching- JOKE

Autodesk overtook Eagle, but - it seems they got only source codes.. They are fighting 6 months with simple, really simple bugs. Without key persons from Eagle Team they will fixing it several months. It seems that big corporation does not threat Eagle successor seriously, no even elementary test procedure before Release. No proper Project Management. Seems like student startup. Every simple bug they could eliminate if they would perform simple User scenario test before every release.

The best example is this URN sub-miniature problem, these are peanuts actually but.. If they would create own 3D part and if they would try to add it to the schematic - they would see that in library manager list there is no sumbminiature listed. JOKE not a serious company.

 

Message 18 of 28

Hi - 

 

haha these are indeed annoying bugs.  Being new to Fusion Electronics, I tend to think I am doing something wring and then spend ours trying to fix a 'bug'.

 

I might just revert back to Eagle, or finally transition to Altium. 

 

Thanks for your input, always good to "know a guy" 🙂 

 

Regards,

 

Message 19 of 28

Hi @christopher2KLSVU@phaggren , @cosmos46 , @friedl.basson ,

 

Hope all is well.

 

About the thumbnail of 3D Package is not downloadable issue, we have a good news to share with you that we have put a fix in today's latest update of Fusion 360 (version 2.0.9439).

Could you please have a double check to see whether it works for you or not?

 

Thank you very much for your reporting and so sorry for any inconvenience.

Please feel free to let us know if need our further assistant.

 

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 20 of 28

It seems it works now.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report