Fusion Educators (Read-Only)
Are you an educator who uses Fusion (formerly Fusion 360) in their courses in secondary and post-secondary? This is the official Autodesk forum for educators like yourself to share the success you are having with Fusion in the classroom.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Text disappearing below 10mm

26 REPLIES 26
Reply
Message 1 of 27
CullenrVDZDT
752 Views, 26 Replies

Text disappearing below 10mm

Hi.

 

I've recently switched to a mac with an M2 processor. I still have an intel Mac and the issue I have is not present. When adding text to a sketch if I select anything below 10mm (some fonts will go to 8, but the majority won't) the text disappears completely and there is no way of getting it back. Importing older models with text get messed up too if I try to edit them.

 

I've reinstalled Fusion twice as the education and the hobbyist versions and the problem is the same.

 

Is this a known bug in the new universal binary, or am I missing a setting somewhere?

26 REPLIES 26
Message 2 of 27
dan.banach
in reply to: CullenrVDZDT

Hi @CullenrVDZDT 

Sorry that you’re seeing this issue. A few questions / suggestions.

  1. Have you updated your graphics card driver?
  2. Are all the updates installed on you Mac?
  3. Restart your computer.
  4. Does your new computer have a graphics card and an onboard graphics card?
  5. Have you tried changing the graphic settings in Fusion? Here is a link to an article that explains how to do this.

If these suggestions don’t solve the issue, could you post a couple images that show the issue before and after and export a .f3d file that also shows both states.

Please keep us posted.

-Dan



Dan Banach
Sr. Technical Manager & Community Manager

If my post resolves your issue, please click the Accept Solution button.
Message 3 of 27
CullenrVDZDT
in reply to: dan.banach

Hi Dan

The computer is a Mac mini M2 pro, so integrated apple graphics. I'm on the latest version of Ventura (13.5.1) and I only get two options in graphics card selection, either auto-select or OpenGL Core Profile. The issue is the same with both settings.

 

I've attached a couple of screen shots showing initial setting at 8mmm, then at 7mm. As can be seen the text has gone and you can't get it back other than by undoing the size change.

 

I've also included four f3d files 8 and 7mm in both auto-select and OpenGL settings. 

 

Rich

Message 4 of 27
CullenrVDZDT
in reply to: CullenrVDZDT

Due to 3 file limitation here are the other f3d files.

Message 5 of 27
dan.banach
in reply to: CullenrVDZDT

Hi @CullenrVDZDT 

Thanks for posting the files. On my Windows computer I can open the .f3d files and the text is displayed correctly for both the 7mm and 8mm files. Assuming you see the same thing on your old computer. 

 

I wonder if this is a high resolution display issue.

  1. What is the display resolution on your M2 mac?
  2. Under your Preferences, what are your settings under Graphics and Graphics > Display.

danbanach_0-1693765035932.png

 

This is a holiday weekend in the US. On Tuesday I'll ask the engineering team for their insights.

-Dan

 



Dan Banach
Sr. Technical Manager & Community Manager

If my post resolves your issue, please click the Accept Solution button.
Message 6 of 27
dan.banach
in reply to: CullenrVDZDT

Hi @CullenrVDZDT 

Can you please try the following and let us know if you can then see the smaller text.

  1. If needed, Finish the sketch that conflations the smaller text.
  2. Edit the sketch that contains the smaller text.
  3. Edit the text.

Can you now see the smaller text and is the correct text height displayed in the dialog box?

Thanks,

-Dan



Dan Banach
Sr. Technical Manager & Community Manager

If my post resolves your issue, please click the Accept Solution button.
Message 7 of 27
CullenrVDZDT
in reply to: CullenrVDZDT

Hi Dan

I've tried your suggestions and it's still the same. I've even tried a standard 1080P monitor and different HDMI lead just to be sure.

 

Rich

Message 8 of 27
dan.banach
in reply to: CullenrVDZDT

Hi @CullenrVDZDT 

Thanks for trying to edit the sketch and trying a different screen resolution. I'll ask the engineering team for their suggestions. I'll keep you posted.

-Dan



Dan Banach
Sr. Technical Manager & Community Manager

If my post resolves your issue, please click the Accept Solution button.
Message 9 of 27
LishuangLu
in reply to: CullenrVDZDT

@CullenrVDZDT , 

We have tried internally with two M1 and M2 machines, so far we haven't reproduce yet. The Ventura OS we have tested are 13.0.1 and 13.4. 
Would you please try restore the Preference settings and see if it can improve the situation? 

Thanks, 

-Lisa

Message 10 of 27
CullenrVDZDT
in reply to: LishuangLu

Hi Lisa.

Tried a rests of preferences and no change. My Mac is an M2Pro running 13.5.1

 

Rich

Message 11 of 27
CullenrVDZDT
in reply to: LishuangLu

I've done a quick screen recording to show the issue happening.

 

Rich

Message 12 of 27
LishuangLu
in reply to: CullenrVDZDT

@CullenrVDZDT Thanks for sharing the video! 

I followed the same steps in my side with M2 Max with 13.5.1, the problem is still not reproducible in my side. 

I highly recommended you restore all the preferences into default and have another try. 

 

Thanks, 

-Lisa

Message 13 of 27
dan.banach
in reply to: CullenrVDZDT

Hi @CullenrVDZDT 

You could also try Resetting Fusion by using the Fusion 360 Utility Service. See the article: Overview of Reset Fusion 360 Command from Fusion 360 Service Utility. 

 

Please keep us posted.

-Dan



Dan Banach
Sr. Technical Manager & Community Manager

If my post resolves your issue, please click the Accept Solution button.
Message 14 of 27
CullenrVDZDT
in reply to: dan.banach

Sorry for the very long delay, but college work has got in the way somewhat.

 

I have now tried all the following since the last email.

 

Reinstall Ventura and Fusion 360.

Try all the resets suggested.

Change to a small 1080P monitor....just in case.

Try USB-C to HDMI, HDMI to HDMI.

Install Sonoma.

Try the reset again and restore defaults.

Try different fonts.

 

And text still disappears below 8mm

 

Still works perfectly on my iMac 27" i7 on a hobbyist account that I had before my current job.

 

Richard

Message 15 of 27
dan.banach
in reply to: CullenrVDZDT

Hi @CullenrVDZDT

This is a strange issue. We're not able to reproduce the issue.

On your new Mac, can you try to run Fusion 360 from a browser (Chrome is preferred) by going to https://fusion.online.autodesk.com and sign in with your Autodesk Education ID (same email that you log into Fusion 360 with). Let us know if this issue if the text issue exists in this environment? 

If the text works fine in this environment, I wonder if this could be a Mac font issue. Have you tried to update the fonts on your Mac?

Thanks,

-Dan



Dan Banach
Sr. Technical Manager & Community Manager

If my post resolves your issue, please click the Accept Solution button.
Message 16 of 27
CullenrVDZDT
in reply to: CullenrVDZDT

Hi Dan

 

I have tried online through Safari and that was fine and as it should be. I've reset all my fonts and reinstalled Fusion.....and it's till the same! I've also tried different graphics drivers settings on two monitors.

 

I have also logged out of eductaion into my hobbyist account, where the issue is also present.

 

I can see and use all the fonts at any size in all my other programs.

 

Richard

Message 17 of 27
dan.banach
in reply to: CullenrVDZDT

Hi @CullenrVDZDT 

Thanks for verifying that the online version worked correctly.

 

Have you tried the different Graphic driver settings in Fusion? 

  1. On the top-right corner of Fusion's screen click on your initials or profile picture.
  2. From the menu click Preferences.
  3. From the General section, try the different options under the Graphics Driver.
  4. Restart Fusion after changing the Graphics driver.

danbanach_3-1696177540514.png

 

Could also try to reset Fusion Preferences.

  1. On the top-right corner of Fusion's screen click on your initials or profile picture
  2. From the menu click Preferences.
  3. On the lower-left corner of the dialog click on Restore Defaults.
  4. Restart Fusion.

Please keep us posted.

-Dan



Dan Banach
Sr. Technical Manager & Community Manager

If my post resolves your issue, please click the Accept Solution button.
Message 18 of 27
CullenrVDZDT
in reply to: CullenrVDZDT

Hi Dan

There are only two options on an Apple Silicon Mac. OpenGL and  auto, and I've tried both. I've reset the defaults several times especially after the last reinstall and trying everything else suggested. I've been looking at fonts and they are all visible to Fusion, so I can't see that being a problem. 

 

I'm wondering if there is a specific issue with the M2 Pro chip!

 

Rich

Message 19 of 27
dan.banach
in reply to: CullenrVDZDT

Hi @CullenrVDZDT 

Thanks for trying the Graphic driver suggestion. Since, we're not able to reproduce this issue, since and no one else has reported this issue, it may be an issue with your computer.

 

Let's see if there is something in Fusion's log files that could give us a hint to what is going on. From your M2 computers please do the following. After I get the log files, I'll ask our engineering team to review them.

  1. Start Fusion.
  2. On the top-right corner of the screen, click on the ? Icon > Support and Diagnostics > Diagnostic Log Files
  3. In the Diagnostic Log Files dialog click Open File Location
  4. Post the zip file" Fusion360DiagnosticLogs.zip"

danbanach_0-1696184585183.png

 

Thanks,

-Dan

 



Dan Banach
Sr. Technical Manager & Community Manager

If my post resolves your issue, please click the Accept Solution button.
Message 20 of 27
CullenrVDZDT
in reply to: CullenrVDZDT

Hi Dan

 

I did wonder about a hardware issue, but I have a no other issues at all.

 

Files as requested.

 

Rich

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

You've got Fusion.


Autodesk Design & Make Report