Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Does Arnold add lights to scenes without lights?

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
david.ostler2WSX9
215 Views, 7 Replies

Does Arnold add lights to scenes without lights?

I noticed a change in behavior in the latest versions of Arnold (htoa 6.2.5.2)in scenes without lights.  I attached a Solaris example where there is a keyframed prune node that removes a light.  The first frame has a light and frame number two prunes the light so that the scene doesn't have any lights.  In frame one I see a green sphere on a plane lit by an area light, as expected.  In frame two everything is pure white, but when I stop down by 15 stops it looks light there is a light at camera position, I expected a black frame.

 

I discovered this while trying to render a RGB reflection matte pass scene that worked fine in older versions of Arnold but now renders super bright white.

Is this a new feature or a bug? 

If this is a new feature is there a way to turn it off?  Perhaps the light could also be created with values that don't blow out the scene so that it is instantly more obvious that a default light has been created.

As a work around I created an area light pointing away from my scene with an exposure value of -100000.  That seems to prevent the super nova default light from being created.

 

Thanks,

David

 

Tags (2)
Labels (1)
7 REPLIES 7
Message 2 of 8

I can see (from the HDARNOLD_DEBUG_SCENE ass file) that a distant_light is created if there's no light (for the viewport only, an exported usd file won't have a light). I don't see where that happens in the arnold-usd code though.

 

It's a distant_light with intensity 1, exposure 0. 

Frame 2 of the scene does not render pure white for me. It looks like this:

 

solaris_distant_light.png

 

 

 

 

 

 

 

 

 

 

 

I don't see this change in the release notes, have to ask around...



// Stephen Blair
// Arnold Renderer Support
Message 3 of 8

@Stephen.Blair , I thought I remembered seeing something saying that a default light was created if no lights were present being added to solaris a while back, I also looked in release notes but couldn't find anything.  I should have also mentioned that interactive rendering looked fine, it was only when I would "render to disk" or "render to mplay"  that I would see this issue.

Message 4 of 8
Stephen.Blair
in reply to: ostlerda

Ok, I didn't render, I just used the USD Rop to check a usda file.



// Stephen Blair
// Arnold Renderer Support
Message 5 of 8

Yes, the render is totally blown out.

 

I notice that Karma adds the default light too, so it's not being done by arnold-usd



// Stephen Blair
// Arnold Renderer Support
Message 6 of 8

New option added in Houdini 20.0.446:
Add a new --headlight option to husk. Husk will now create a headlight on the stage for all delegates if it detects no lights on the stage. The default behaviour can be controlled using the new HOUDINI_HUSK_DEFAULT_HEADLIGHT environment variable. The headlight is created by calling husd/huskheadlight.py.

The USD Render ROP now has parameters to control this behaviour.

Message 7 of 8

@Stephen.Blair, nice find.  My mistake was thinking this was an Arnold change.  I only looked for solutions in Arnold settings.  Once you mentioned that the same thing happened in Karma I looked and noticed that the setting was in plain sight right in front of me.  

In the usdrender_rop there is a headlight mode which has the options of "No headlight", "Distant Headlight", and "Dome light".  Even when the headlight mode is not activated it seems to default to ON with "Distant Headlight"

Message 8 of 8

Arg, I didn't scroll down far enough. Now it seems obvious, and the tooltip for Headlight Mode makes it clear...



// Stephen Blair
// Arnold Renderer Support

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report