Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

UNUSABLE! Using C4DtoA with very slow/no internet freezes C4D

Message 1 of 7
814 Views, 6 Replies

UNUSABLE! Using C4DtoA with very slow/no internet freezes C4D

I've discovered that when my internet is throttled to ~1Mbps download speeds or when I turn my internet off entirely on my computer, using any functionality of C4DtoA will completely freeze C4D.

I have Arnold on my Mac that connects to a remote server to check for a license so that I am actually able to render out images locally on my Mac without the "Arnold" watermark appearing on my renders. I also am forced to connect to the remote server using a VPN, which no doubt slows my internet (This might make no difference to my issue here). The key thing that I noticed is that having a very slow internet/turning off internet on my Mac entirely, then trying to use C4DtoA in any way (even doing such a small thing like creating a standard shader) freezes C4D for at least ~11 seconds every single time. I am assuming this happens because Arnold is tries to connect to the server and forces everything to wait for it while it tries to get an internet connection?????

This is an extremely frustrating issue as it makes using C4D with C4DtoA completely unusable.

Are there any solutions to this?

Message 2 of 7
in reply to: Anonymous

I'm not sure what's causing this, but could be the licensing. I'll try to reproduce the issue and get back to you.

Message 3 of 7
in reply to: Anonymous

If you're using the Arnold IPR Window, licensing would cause a delay only when you first start the IPR session. If you see a delay even for updates of an open IPR, then it's not licensing.

Enabling skip license check is one way to test whether it's the licensing.

What type of licensing? RLM or Autodesk FLexlm?

// Stephen Blair
// Arnold Renderer Support
Message 4 of 7
in reply to: Anonymous

@Stephen Blair I am using Autodesk Flexlm for my license. I don't know anything about how the licensing works though, I had a friend set mine up for me. But I do know the license is on a remote server.

For the IPR window, C4D/the IPR window does not freeze at all when I have a good connection to the license server, even when first opening either of them.

I just did another test and I just found something interesting: I opened C4D with a good internet connection to the server, added a cube primitive, changed the render settings from Standard to Arnold, created a standard plastic Arnold shader, applied that to the cube, created an Arnold Sky object, opened up IPR. So far everything works normally. Closed and reopened IPR a few times - still working good. Then I disabled my server connection, opened up IPR which still loaded fine/no freezing but of course it takes a while to realize it can't find the license and so it displays a black screen for 20 seconds and then displays the cube with Arnold watermark on top, but then closing, reopening and then CLOSING the IPR window DURING the black screen froze C4D for 18 seconds. Deleting the plastic shader and then creating another one also then froze C4D for 20 seconds.

Message 5 of 7
in reply to: Anonymous

Honestly I don't really know what is going on at this point. I'm just very confused. But the problem is very easily replicable on my end. Something to do with internet connection being turned off and doing something with C4DtoA = ~20 second frozen C4D.

Important: I tried what you said and disable license check (with internet connection disabled still). I still get C4D freezing but now the IPR window freezes C4D just even when I try to open it 50% of the time while other 50% it just opens and renders watermarked image just fine and quickly. By creating a standard arnold plastic shader, C4D still freezes. Even selecting/deselecting the shader in the materials tab freezes C4D 50% of the time. This is all still with no internet connection to the server. Disabling license check doesn't seem to be helping. 😞

Something weird is going on and I have no idea how to diagnose this further. It all seemed to start happening when I installed the latest C4DtoA update. But thank you for your input anyways!! 🙂

Message 6 of 7
in reply to: Anonymous

Also apparently I can't post a comment so big without it not displaying in the comment section properly (yay another bug!) so I split it in half above. Life is just too difficult sometimes 😛

Message 7 of 7
in reply to: Anonymous

I'm not able to reproduce it here. When I disable the internet connection Arnold just renders the scene instantly with watermark and everything works as expected.

> It all seemed to start happening when I installed the latest C4DtoA update.

Can you check older versions to be sure if it's really an issue with the latest update?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report