Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

IPR render region sometimes fails to display final progressive pass until mouse is hovered off it

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
Anonymous
348 Views, 7 Replies

IPR render region sometimes fails to display final progressive pass until mouse is hovered off it

C4DtoA 2.6.1 [4186e70b]
Arnold core 5.4.0.0

I can only get this problem to occur when the render region in the IPR is rendered in about less than half of one second. To try and reproduce this: new scene. cube primitive. add Arnold sky - physical sky mode. Set your render settings to 720p and leave arnold samples at default so that everything renders super fast. Start the IPR. Now create a render region that is over the rendered pixels of the cube. Make the render region around 20x20 pixels - so pretty darn small. (Perhaps there should be an indicator of some sort to tell you what your render region dimensions are. that would be really handy.) Zoom in to the render region (in the IPR) so that you can see what you're doing. Now drag the render region in any direction some small distance (just don't drag it off the cube). At some point / about 1/8th of the time, the region will fail to display the final progressive pass of the render. This is with your mouse still hovering over the center of the render region where the drag tool is. When your render region does fail to render this last pass, move your mouse off the render region and you will see that it displays the last pass finally.

There have been other cases where this problem occurs much more frequently but I can't figure out what the frequency depends on.

If you can't reproduce this issue then tell me so and I'll make a video and post it back here.

Tags (2)
Labels (2)
7 REPLIES 7
Message 2 of 8
peter.horvath6V6K3
in reply to: Anonymous

I'm not able to reproduce this one.

Message 3 of 8
Anonymous
in reply to: Anonymous

@Peter Horvath

Here's my video on it. No audio.

Render region seems to update to its last progressive pass when the UI is updated by the user - as shown by me moving my mouse off the render region or zooming in/out in the IPR.

Message 4 of 8
peter.horvath6V6K3
in reply to: Anonymous

Finally I could reproduce the issue, trying to fix this in the next version. Thanks.

Message 5 of 8
Anonymous
in reply to: peter.horvath6V6K3

Fantastic! Thanks, Peter. Sorry if I didn’t provide enough information but I wasn’t able to figure out much about the problem myself. Would love to know what was causing this if you’re allowed to share.

Message 6 of 8
peter.horvath6V6K3
in reply to: Anonymous

The video was a great help to be able to reproduce it. It's a bit technical, there's a logic to synchronize the display with certain fps and it has a bug when the render is fast and the final pass ends before the time frame. Anyway it's fixed now and will be added to the next release.

Message 7 of 8
Anonymous
in reply to: peter.horvath6V6K3

Nice job. Thank you!

Message 8 of 8
peter.horvath6V6K3
in reply to: Anonymous

Fixed in C4DtoA 2.6.1.5.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators