Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bug with Toon Render/Clip_Geo

4 REPLIES 4
Reply
Message 1 of 5
mgase
291 Views, 4 Replies

Bug with Toon Render/Clip_Geo

I noticed that when using a clip_geo object in combination with a toon shader the clipped area in fills in with black. I had others on different machines verify and was advised to share here. Using 3.2.0 on r23 and/or r21. Thanks!

When moving the object:

1.jpg


When releasing the object and letting Arnold resolve the scene:2.jpg

Tags (1)
Labels (1)
  • bug
4 REPLIES 4
Message 2 of 5
lee_griggs
in reply to: mgase

Have you tried disabling receive shadows for the clipping sphere?

1604579162264.png



Lee Griggs
Arnold rendering specialist
AUTODESK
Message 3 of 5
mgase
in reply to: mgase

Yup I have both of the receive/self shadows disabled. I had not opened this for a few days, just opened and now it is working perfectly??? I'll take it.

Message 4 of 5
MarcelRuchArc
in reply to: mgase

Hello Lee Griggs!

 

we use cinema4d on Mac in combination with the Arnold-Renderer c4dtoa - we love it!

Especially the clip_geo is brilliant!

 

Unfortunately we are now facing some problems when combining the clip_geo- and the toon-shader:

Whenever the clipping_object is positioned close to a "shadow-receiving-object" (with the toon_shader applied), "tiling artifacts" occur in the shadow.  (see in the middle of the .mp4)

shadow_artefacts.pngclip_geo_toon_shadow_artifacts.png

 

We have read the comments in the c4dtoa-user-guide:

  • Self-intersecting geometry or intersecting clipping objects can cause artifacts.
  • Open objects may cause unwanted clipping (should be as watertight as possible).

For this reason, we simplified the scene with „c4d-primitives“ like cubes and tried it again: the same artifacts occurred.

shadow_artefacts_test.png

 

We already contacted Autodesk - due to the fact that Arnold is becoming part of Autodesk - but they do not seem to be that much interested in helping us.

 

Maybe you can help us?

We would very much appreciate your support!

 

Greetings,

Marcel Ruch

Message 5 of 5
thiago.ize
in reply to: MarcelRuchArc

Hi Marcel,

I would suggest making a new post for this since it looks like a new problem. That will also help ensure it gets seen by folks who weren't already following this thread.

 

In any case, I created an internal ticket ARNOLD-12281 with your reported problem.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report