Community
Maya Shading, Lighting and Rendering
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya materials topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya Arnold batch render stops after rendering a few hundred frames.

17 REPLIES 17
Reply
Message 1 of 18
valiantsina_bachkarova
619 Views, 17 Replies

Maya Arnold batch render stops after rendering a few hundred frames.

Hi there, 

Our team ran into an issue with batch rendering with Arnold in Maya 2023. When we try to do a batch render it works just fine for a few hundred frames, and then the console message says that the render is completed. I've confirmed the frame range was set correctly. This issue happens on a few different machines with different hardware configurations. 

Based on other forum posts that mentioned similar issues I've tried changing the Diagnostics settings (Unchecked Abort on Error, changed the verbosity level to Debug, increased max warnings to 100), deleted user preferences, tried running nothing but Maya, but other than a small improvement of frames rendered, the render still stopped after a few hundred frames. This issue also happens in different maya scenes with different animation lengths. 
The scene itself is rather simple, there are no complex textures/materials/geometry, but there is a lengthy motion capture animation applied to 2 mannequins. 

On one occasion, the renderlog file provided a new error: "Maya exited with status -1073740791". 

I also noticed that the memory usage goes up overtime to high 90%. Could there be some sort of an issue where more memory continues to be allocated but never gets de-allocated from the process?

Im not sure what's causing this, but any insights are welcome. I have attached the render log file with the latest render information at the bottom. Thank you

17 REPLIES 17
Message 2 of 18

Can you provide us with your scene file and the hardware specifications you are experiencing this on please?

Message 3 of 18

Sure thing,

Here is the link to one of the scenes: https://we.tl/t-uYfHDaQYpV

The specs are:
CPU: i9-9900K
RAM: 32GB 
GPU: NVidia RTX 2080 8GB
OS: Windows 10

The same issue seems to be happening on:
CPU: i9-13900k
RAM:128GB
GPU:Nvidia RTX 4090
OS:Windows 11

Thank you and please let me know if you need any other information.

 

Message 4 of 18

Did anyone found a solution for this? we also ran into a similar issue

Message 5 of 18

Apologies, I went to grab the file and the transfer had expired. Could you resend please or just zip it up and upload here?

Message 6 of 18

Sorry about that, I re-uploaded the file https://we.tl/t-X2ThDrraSr

Unfortunately it's about 1GB so I could not upload it here due to the size limit

Message 7 of 18

I would render in smaller chunks. And I'm not just saying that for this case, but in general. Rendering hundreds or thousands of frames is always a problem, from the old mental ray days up to now.



// Stephen Blair
// Arnold Renderer Support
Message 8 of 18

When I open up your render settings it shows the start frame as 1.250 and the end frame at 12.500 is this correct?
Or do you have any specific OS language and keyboard settings that are possibly adding the dots in the numbers?
What range of frames were you rendering when you hit the issue?

Also, did you try and render without the audio files?


Message 9 of 18

Ah, I believe those values were set in the master file that was using animations on half frames, but were never used ( i probably didn't resave the file after editing the frames to be 0-xxx. 

We tried rendering different frame ranges such as 0-700 as a test, and it never rendered past half of the range in one go. 
I can certainly give it a try and render without audio in the meantime to see if it makes a difference. 


 

Message 10 of 18

Also, are you indeed trying to render a sequence of jpg's? If not, what is the format you guys were trying to render?

Message 11 of 18

We are rendering out jpegs, that is correct. 

Message 12 of 18

Are you guys using Rendering menu set: Render > Batch Render
or are you using render.exe at the command line?
We assume you aren't using Render > Render Sequence.

Message 13 of 18

You are correct, we are using render>batch render. 

I wasn't really sure how sound being present in timeline would affect rendering out image files but as per your suggestion I removed the sound and tried rendering frames, the process hung up after 168 frames. 

Message 14 of 18

I just rendered 1000 frames of the scene, with the latest MtoA for Maya 2025, on Windows.



// Stephen Blair
// Arnold Renderer Support
Message 15 of 18

I was also able to batch render 750 frames of the attached scene file, on Windows using the GPU renderer without issue. I did remove the audio nodes.

Message 16 of 18

Interesting, thanks for testing it out.
And that's in Maya 2023? Are there any notable differences in hardware e.g. were you using an AMD card for example? Any changes in settings? We work for a college, are student/educator licenses at all different when it comes to rendering with Arnold, any caps? (I remember seeing a thread implying this but haven't found any concrete confirmation). 

TIA!

Message 17 of 18

I was using a machine with an Nvidia GPU which I think is necessary for GPU rendering. Which 2023 are you using? Is it 2023 or an update (2023.1 for example)? I'll have to inquire on whether or not there is a difference with edu licensed seats. I don't think there would be but I could be wrong.

Message 18 of 18

I was using 2023.3. to test. And thanks for checking about the licenses. Im going to try again on 2025 without audio clips for now since that seemed to work fine for Stephen

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report