Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Xgen can't bind geometry to description, also can't find description

0 REPLIES 0
Reply
Message 1 of 1
simon.eriksson_
250 Views, 0 Replies

Xgen can't bind geometry to description, also can't find description

Hi, 

 

I've run into a problem with Xgen. I am currently working on applying fur onto my geometry, depicting a dog, and I came across a video of a person applying fur by first making the geometry paintable and then using the Paint Vertex Tool to draw out individual lines. Then converting the lines into curves by using "Paint Effects to Curves", which were then ultimately converted  into Guides using the "Curves to Guides" option in Xgen. I have not worked a whole lot in Xgen at all, so I can't say if this method is preferred over another method, but I liked the idea of being able to quickly control the growth pattern of the "fur" in a specific pattern by drawing them individually. I know I could have also gone an alternative route using Interactive Groom Splines and just used the Comb tool and added separate Guides, to control the growth pattern.  

 

Link to the video: https://www.youtube.com/watch?v=YVSBbS6v9no&t=433s 

 

But here is the thing. I have drawn out the lines on my geometry, as well as converted them into Curves and grouped them together, while at the same time deleted the old Paint Effect lines. I have also created both an Xgen Description as well as Collection. The dog's name is Stella, so I have chosen to name the description 'Fur' and the Collection to 'StellaCollection'. 

 

But when I select my geometry, and go to the Xgen window > Utilities and choose to convert "Curves to Guides", Maya throws an error in the cmd saying "No Geometry found" . 

 

I have tried to make the geometry a child to the Xgen Description/Collection, but that didn't solve the problem. When I click on "Update the Xgen Preview" button in the xgen tab, I get a message saying "No Preview visible. The description is not bound to any geometry in the scene". Although I can clearly see that the geometry is a child to the Xgen Description/Collection. 

 

I happened to try a Python code which would automatically verify the existence of any Collection or Description in the scene based on the given names, and it threw a warning saying "No description 'Fur' exist". But strangely enough, I can still see the 'Fur' description as well as 'StellaCollection' in the Outliner window. I have also checked the existence of the xgen subfolders within the project folder, and everything seems fine. 

 

I tried to delete both the Collection and Description and start over, to no effect. Xgen still can't bind the geometry to the description for whatever reason. 

 

Am I missing something here? 

 

Any help is appriciated. 

 

 

 

 

 

 

 

 

0 REPLIES 0

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators