Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

The xgen utilities tab is empty

17 REPLIES 17
SOLVED
Reply
Message 1 of 18
geeguit
18337 Views, 17 Replies

The xgen utilities tab is empty

In maya 2019 the xgen utilities tab is empty! I tried to reset the pref folder. Reboot, but nothing helped. What is the problem?
xgen.JPG

Tags (1)
17 REPLIES 17
Message 2 of 18
sean.heasley
in reply to: geeguit

Hi @geeguit

 

Try unloading and reloading your Xgen plug-ins found in the plug in manager.

 

 

Message 3 of 18
geeguit
in reply to: sean.heasley

Thx, but still dont work..

Message 4 of 18
sean.heasley
in reply to: geeguit

Hi @geeguit

 

I looked into this more and it is actually a known critical issue and the developers are already working on fixing it asap.

 

 

Message 5 of 18
nikopic
in reply to: sean.heasley

when this problem will fix ? i need use xgen ;| 

Message 6 of 18
Christoph_Schaedl
in reply to: nikopic

There is a was to fix it. Thanks to Luke Harris!

 

open the xgUtilitiesTab.py

C:\Program Files\Autodesk\Maya2019\plug-ins\xgen\scripts\xgenm\ui\tabs\xgUtilitiesTab.py, line 115-118

and rename    $gxgmTMLookupTable     to --->    $gXgmTMLookupTable

----------------------------------------------------------------
https://linktr.ee/cg_oglu
Message 7 of 18
mspeer
in reply to: Christoph_Schaedl

Hi!

 

In previous Maya versions the lower case has been correct, so care as this may change again with an update.

Message 8 of 18
onliiaj
in reply to: Christoph_Schaedl

Hi! 

I did that, it didn't work for me, utilites still empty (and I'm using Maya 2019). Is there any other solution? 

Message 9 of 18
teke05
in reply to: onliiaj

hi i am using maya 2019 it works if you make sure you renamed the 'x' to 'X'  in both xgUtilitiesTab.py and  xgUtilitiesTab.pyo files for every instance of  $gxgmTMLookupTable    (file path C:\Program Files\Autodesk\Maya2019\plug-ins\xgen\scripts\xgenm\ui\tabs  )

 

 

Message 10 of 18
geeguit
in reply to: onliiaj

Make sure that changes to the file are saved. In my case, due to a conflict with disk administration, the system did not allow me to make changes to the file. I copied it to another disk, made changes to the lines, and copied it with the replacement back. And it all worked!

Message 11 of 18
onliiaj
in reply to: geeguit

Yes, I've had the same issue, couldn't save it. But I saved my file and reopened it in Maya 2018 (where xgen was totally lost, that's why I tried 2019 version), and that file kinda made it appear again, so it's all fine. Thank you for your help 🙂

Message 12 of 18

I have located the file but don't know how to change this script if that what it is, any help would be much appreciated.

Thank You,

Message 13 of 18
carlosZ2A2Q
in reply to: deminapho

open the text file, you can ctrl(or cmmmand) F to search for the line then replace the lower case x for X and ctrl or cmd save the file.

Message 14 of 18
rbrunetart
in reply to: carlosZ2A2Q

I updates the python script which fixed the ui. After grooming, it no longer displays the guide curves. 

"The Grooming tools are only avilable for groomable splines" 

 

Any way around this?

Message 15 of 18
305577361
in reply to: geeguit

Message 16 of 18
deminapho
in reply to: 305577361

First off THANK YOU SOOOO VERY MUCH!!!! I tried all these other solutions with no success. This WORKED! i desperately needed this tool and appreciate you explaining it that I could follow!


😀

 

Message 17 of 18
eileneje1
in reply to: geeguit

I had difficulty finding the files to change, but finally found them in a strange path because I have Maya 2019 and 3ds Max 2020.  Here's where I found mine - in case it helps someone:

Program Files\Autodesk\3ds Max 2020\Maya2019\plug-ins\xgen\scripts\xgenm\ui\tabs

Message 18 of 18
mayer.elena90
in reply to: geeguit

This problem is not resolved yet. I'm using Maya 2023 and when I launch Maya seems working propertly but after I change the tab is empty again (forever), please fix it.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums