Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

super annoying bug that requires force quit

10 REPLIES 10
SOLVED
Reply
Message 1 of 11
nick.holliday
249 Views, 10 Replies

super annoying bug that requires force quit

Everytime i hover over the menu to assign  new materials i get this error ehich im unable to escape for and so need to force quit.!  I cant be the only one (i know im not).  Surely this could/should be fixed asap?

 

nickholliday_0-1687515990679.png

 

10 REPLIES 10
Message 2 of 11

Which Maya and Arnold version are you using?

----------------------------------------------------------------
https://linktr.ee/cg_oglu
Message 3 of 11

Hi

 

im using 2024.1  and arnold 5.3.1.1

Message 4 of 11
brentmc
in reply to: nick.holliday

Which platform are you running Maya on and do you have any other plugin shaders loaded?

Also, could we get a bit more detail on how to reproduce the issue. Like a screenshot showing which menu are you are hovering over when the error occurs. 

Thanks.

Brent McPherson
Principle Engineer
Message 5 of 11

sorry, it was a bit of a rage post. Ill get a video  (im on windows 11)

Message 6 of 11

Her'es a vid. It doesnt happen with every mesh.  Just certain ones.

Message 7 of 11
brentmc
in reply to: nick.holliday

Hi Nick,

 

Thanks for this. Any chance of getting one of the scene files that triggers this error?

You can send it to brent.mcpherson@autodesk.com and it will only be used for investigating this issue.

Thanks.

Brent McPherson
Principle Engineer
Message 8 of 11
brentmc
in reply to: brentmc

Hi Nick,

A quick update on our investigation.

The security issue is coming from the uiConfigurationScriptNode in the file and deleting these two lines from the file fixes the issue.

-docTag \"isolOutln_fromSeln\"
-docTag \"RADRENDER\"


There are also settings in Preferences > UI Elements that prevent Maya from generation and/or using the uiConfiguration node and disabling these also avoids the issue in my tests.

screenshot_000190.png

Thanks.

Brent McPherson
Principle Engineer
Message 9 of 11

oh!  thanks for the update - ill give it  try.  Was there something i did that might have caused that to happen?

Message 10 of 11
brentmc
in reply to: nick.holliday

No, it isn't anything you have done.

It only seems to happen in the context menu, not in the main Lighting/Shading menu in the main menubar!?

Another workaround is to uncheck the Python compile command in the Python Security preferences:


screenshot_000191.png

Brent McPherson
Principle Engineer
Message 11 of 11

thanks again. It seems unchecking those initial prefs seems to have done the trick!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report