Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Setting preferences errors

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
0512nathanlee
517 Views, 2 Replies

Setting preferences errors

Hi

 

 

It's my first hour of my first day of Maya and already bumping into way too many problems 

 

What I am trying to do is change rendering engine from OpenGl to DirectX on Preferences window.

 

 

 

 

 

Problem 1 :

 

When I try opening preferences, this error pops up and does not open preferences window  : 

 

// Error: file: C:/Program Files/Autodesk/Maya2020/scripts/startup/colorManagementUtilities.mel line 99: Error has occurred while exporting color management policy file "C:/Users/이정훈/AppData/Local/Temp/tempPolicy.xml" .

 

Funny thing is when I try some actions, e.g F8 to change from object type to component type and open preferences again, it sometimes does open preferences window, but also sometimes crush into another error code : 

 

// Error: file: C:/Program Files/Autodesk/Maya2020/scripts/startup/updatePrefWndUI.mel line 133: Value is out of range: 0

 

What could be causing this error to show up?

 

 

 

 

 

 

Problem 2

 

When I am lucky and finally open preferences, change OpenGl to Direct X,

 

When I press Save, this code appears : 

 

// Error: A permanent scriptJob cannot be killed.

 

When I press Cancel, this code appears : 

 

// Error: file: C:/Program Files/Autodesk/Maya2020/scripts/startup/prefsHoldCurrentState.mel line 1124: Cannot convert data of type int to type float[].

 

What is causing these?

 

 

 

 

 

Below are some things I tried :

 

  • reinstalling did nothing
  • changing prefs  >  prefold did not nothing 

 

 

 

 

At this point I am thinking I should be relieved to close Maya without crushing into another error code

 

I really want to learn and like Maya 

 

Please lmk if any other elaboration is needed

 

 

 

 

Thank you all in advance

 

Tags (1)
Labels (1)
2 REPLIES 2
Message 2 of 3

your Maya prefs are held in the user folder, and your account name is in Korean characters. usually everything beyond ASCII chars causes problems.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 3 of 3

Thanks to hamsterHamster, 

 

 

 

Apparently Maya does not get along too well with Korean language and I am assuming neither with other languages apart from English.

 

This means, for example, if your OS username is written in foreign language, 

 

when you save your Maya file, the location directory will contain non english text 

 

and trigger the problems I had 

 

 

Making another user & naming it in English solved this. 

 

 

I am unsure if there is a shorter way to solve this but  :  

 

After copying the files to & opening from the new user, all those errors never show up

 

 

 

 

Use English and dont be like me looking for answers 30 min straight

 

 

 

 

 

 

 

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums