Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya 2017 render presets not working

10 REPLIES 10
Reply
Message 1 of 11
andy
2407 Views, 10 Replies

Maya 2017 render presets not working

In trying to create new render presets for our new installations of Maya 2017, we're running into the issue of not being able to save and/or load presets.  Sometimes they will save, but on trying to load the .json file, we get this error:

# Error: line 1: RuntimeError: file C:\Program Files\Autodesk\Maya2017\Python\lib\site-packages\maya\app\renderSetup\views\renderSetupPreferences.py line 109: Invalid preset found C:\Users\xxxxxxx\Documents\maya\Presets\TD_VR_Initial.json

 

Any ideas?  Autodesk help isn't very helpful.

10 REPLIES 10
Message 2 of 11
mrHalaby
in reply to: andy

Same here on 2016 ext2 sp2.

 

You save the preset and maya tells you it's not a correct file when loading it. I would like to share this preset with my team on a network location by setting the correct environment variable, but no luck.

Message 3 of 11
mrHalaby
in reply to: mrHalaby

It actually works in some scenes whilst it doesn't in others. Haven't found any pattern so far

Message 4 of 11
damaggio
in reply to: mrHalaby

Yeah sometimes they vanish, I use Vray and it seems to work when I select Default preset, then again I select the preset I want and it loads.

Message 5 of 11
mspeer
in reply to: andy

Hi!

 

I'm  not sure if this is the problem, but there is something noted in the release notes of update 1:

https://knowledge.autodesk.com/sites/default/files/Maya_2017_Update1_Readme_enu.htm

 

"If you import a Render Setup template, and an existing override is merged with an override of a different type (for example, an override on a float attribute in the current scene is merged with an override on a float3 attribute from the imported template), you may encounter an error in the Render Setup window that requires you to restart Maya. This error is most likely to occur if you import a Render Setup node that has the same name as an existing Render Setup node (for example, if you import collection1 into a scene where collection1 already exists)"

 

Please make sure to use the latest update version with Maya 2017.

Message 6 of 11
damaggio
in reply to: mspeer

Cool, thanks mspeer.

Message 7 of 11
mrHalaby
in reply to: mspeer

That refers to Render Setup, which is the new way of doing the render layers.

 

So if you use the old render layers, you can still use the old render presets in .mel files. If you want to use the new Render setup, you have to use the new .json presets that load only whenever they want to.

Message 8 of 11
mrHalaby
in reply to: mrHalaby

In case this helps anybody,

 

apparently this has been solved in 2017 Update 2.

 

No solution for 2016 ext2 users so far, apart from not using the new system.

Message 9 of 11
gigayo
in reply to: mrHalaby

Well, maybe its solved for you. My maya will never remember presets and will not allow me to save ANY preset at all. Not from the render settings, not from the material presets. 

 

In fact, i didnt try it yet, but it is possible that update 2 mess my maya installation everytime i try to install it. I already uninstalled maya and re-installed twice, at first it seems the problem is solved, but after a while, again, with no apparent reason, i cant save or load presets anymore. 

 

I cant use mental and material x presets, i cant use render presets, i cant use regular presets of any kind. Seriously Autodesk... this is nuts. Sadly i already invested too much money and learning curve on maya to ditch it, but i hope for the sake of people that you get your product fixed as soon as you can.

Message 10 of 11
TrevorHoward
in reply to: andy

I was having the same errors but I am able to work around it for now if anyone else is still having this problem. I am working in maya 2016.5 and Redshift but perhaps it is the same in 2017 as well.

I dug around the renderSetup API a bit and found  that an attribute listed in the json file did not exist which caused the error in one of the renderSetup modules. For me it was specifically the "redshiftOptions.physicalSky" attribute. Apparently this attribute does not get created on the redshiftOptions node until the first time the rsPhysicalSky node is created and connected. The renderSetup seems to account for missing nodes, but not missing attributes.

What I have done is loop through the attributes in the json file and check to ensure they exist first. So long as the attributes all exist, I have not yet had an issue loading presets.

Message 11 of 11

Nope, didn't work. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report