Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't delete an object - error line "No object matches name: nameoftheobject:"

7 REPLIES 7
Reply
Message 1 of 8
fuensantaolmos2016
10374 Views, 7 Replies

Can't delete an object - error line "No object matches name: nameoftheobject:"

Hey there! I'm a student using Maya 2018. I combined two different meshes using Mesh > Combine and obtained a single object (I don't know if it's important to note that I was using the UV Editing workspace). After that, I tried to delete that object because I needed to, but Maya keeps sending me the error line "doDelete.mel line 37: No object matches name: BAG_bell1_f_1:". I tried deleting the history of the object and rebooting Maya but the problem persists (BAG_bell1_f_1: is the name of the object I obtained upon making the aforementioned actions).

 

Any ideas on how to solve this? 😞

 

Thank you so much

Student
7 REPLIES 7
Message 2 of 8
mspeer
in reply to: fuensantaolmos2016

Hi!

 

Please upload the scene-file.

Message 3 of 8
zombiejump2012
in reply to: mspeer

Hi

My boyfriend's maya scene has the same problem, I've tried to change nodes name, or assign different shader none of it seems work. The mesh can be duplicated in order to edit. In addition, the scene cant be saved as mb file neither. 

Message 4 of 8
mspeer
in reply to: zombiejump2012

Hi!

I can't help further without a scene-file.

 

The second problem is because of a missing plug-in that's needed for some nodes to enable a proper conversion of the used file type.

Load (maybe install first) the required plug-in or simply delete those nodes.

Message 5 of 8

I had the same thing happen to me. I combined a mesh with the UV editor open and it gave me pCube534_f_0:Shape which I couldn't delete, edit, or rename.

 

My fix was, first I duplicated the object, which created an error free mesh (because I wanted to keep my mesh). Then I went to the Outliner and at the top went to Display> Shapes and checked it on. Then I found the error mesh and un-collapsed it using the little plus sign. It was composed of the mesh node and a transform node. I selected the mesh node and hit delete. I couldn't delete the transform node though. I return the Outline back to normal by unchecking shapes. Then I saved my scene and closed Maya. Upon reopening my scene no errors popped up and both the error mesh and transform node where gone.

 

I still don't know what caused the error in the first place, but it's gone now.

Message 6 of 8

Open Hypergraph Connections (Window > General Editors > Hypergraph Connections), find the broken object, select it in the Hypergraph Connections window and delete it.

Message 7 of 8
guymils
in reply to: Ant_Thief

You Legend! Duplicate for the win!

Message 8 of 8

I literally just had this same issue. Like above I tried all the things like delting, renaming, by hand or code. for me the solution was :
ctrl X - ctrl V
For some reason delete is not allowed but "cut" is and if all goes well and the same way I had it you will get your object with a default name inside a group in your scene

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report