Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Animation and "Cache to USD" not working ?

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
sebastianZ4FWN
590 Views, 5 Replies

Animation and "Cache to USD" not working ?

Hi there,

I've been struggling to cache Maya animation to USD format without any luck.

 

I've followed this specific tutorial https://www.youtube.com/watch?v=XW9Pu2ep-kM

 

I can follow the instructions until minute 3:01. When I right click and press "Cache to USD" it doesn't playback the animation and the result is the robot with no animation.
I have tried several times with this, and also with other super simple scenes, like a cube animated.

Replicated exactly and in detail all of the steps.
I'm able to import to an USD Stage Layer the Maya references without any issues, animation looks good until then.
But after pressing "Cache to USD" then I get the model with no animation.
It doesn't seem to really work.
There are no Warnings or Errors in the Script editor, so I have no clue.
I'm in Maya 2023.3 and MayaUSDPlugin 0.20.0.

Any help??

USD is the future of large scale production workflows. In this video, I show you how to cache Maya animation to a native USD cache and vice versa. For more information on USD, check out these resources: Pixar's official USD Home: https://graphics.pixar.com/usd/release/index.html My primer on USD ...
5 REPLIES 5
Message 2 of 6

Update to Maya_USD 0.22
https://github.com/Autodesk/maya-usd/releases/tag/v0.22.0

----------------------------------------------------------------
https://linktr.ee/cg_oglu
Message 3 of 6

Thanks!

I have just installed latest MayaUSD plugin 0.22 for Maya 2023.3 in MacOS.

I see Maya is loading this plugin version correctly.

 

However same exact issue keeps happening.

 

Any idea?

 

No Playback Cache erros at all. Object doesn't move after "Cache to USD"

Script Editor output seems OK, just a minor warning:

// Warning: file: /Applications/Autodesk/mayausd/maya2023/0.22.0_202302061132-12c3665/mayausd/MayaUSD/plugin/adsk/scripts/mayaUsdTranslatorExport.mel line 435: Converting string "1.0" to an int value of 1.
// Warning: file: /Applications/Autodesk/mayausd/maya2023/0.22.0_202302061132-12c3665/mayausd/MayaUSD/plugin/adsk/scripts/mayaUsdTranslatorExport.mel line 432: Converting string "1.0" to an int value of 1.
# Opening layer 'anon:0x60000f07a140:tmp.usda' for writing
# Writing to already-open layer 'anon:0x60000f07a140:tmp.usda'
# Saving stage
# Layer [tmp.usda] / Path [/MayaReference1] / Field [kind]: prim metadata: changed.
# Layer [test.usd] / Path [/Xform1{Representation=MayaReference}MayaReference1.mayaAutoEdit] / Field []: preserving destination.
# Layer [test.usd] / Path [/Xform1{Representation=MayaReference}MayaReference1.mayaNamespace] / Field []: preserving destination.
# Layer [test.usd] / Path [/Xform1{Representation=MayaReference}MayaReference1.mayaReference] / Field []: preserving destination.
# Layer [tmp.usda] / Path [/MayaReference1] / Field [properties]: keep all children: mayaAutoEdit mayaNamespace mayaReference

Message 4 of 6
ray
Advocate
in reply to: sebastianZ4FWN

I have the same problem, I tried to export some character animations to USD but no luck at all. I tried with geometry only, with the skeleton, with the complete rig, but there is no way to export correctly. Anyone can help ?

I'm on Maya 2023.3 and Win 10

Message 5 of 6
ray
Advocate
in reply to: sebastianZ4FWN

Just an update to say I finally was able to export animation data from Maya to USD format. After many tests I realized that "Skeleton" and "Skin clusters" options must be set to "none" , otherwise Maya tries to export skin and joints, if they are turned off Maya exports a geometry cache.

Message 6 of 6
pablomercado
in reply to: ray

I tried with the geometry cache and it works. But still would be nice to export the skeleton + skinned geometry, since this is easier to modify and is lighter on disc.

 

Does anyone knows if this is a bug from the plugin or we are just trying the wrong export workflow?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report