Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Animating issue: Maya Keeps On Reverting My Pose To The Last Keyframe

16 REPLIES 16
Reply
Message 1 of 17
smillz999RZXKH
5128 Views, 16 Replies

Animating issue: Maya Keeps On Reverting My Pose To The Last Keyframe

I have a weird issue that happens after a little while when I'm animating. So, I'm testing out a new rig that I put together, and after a while, whenever I move a controller, it starts to revert the values of itself and everything related to it back to its last keyframe. For example:

 

 

I set a keyframe. Then I move to another frame. I select a leg controller. I translate it 5 units. Then I rotate it 20 degrees. While I do the rotate, it

automatically just snaps the translation back to where it was at the last keyframe.

 

 

It's pretty bizarre behavior. I thought that it might've been the rig, but that wouldn't actually make sense for the fact that restarting Maya fixes it for a bit, but then it starts doing it again. I'm using Maya 2016 extension 2. And I know that I *could* use Autokey to fix the issue, but that would mess with my particular workflow. Has anybody else had this issue before? And if so, were you able to fix it?

16 REPLIES 16
Message 2 of 17

Hi @smillz999RZXKH and welcome to the community!

 

Can you attach your scene file here or via dropbox/google drive so I can take a look at it?

Message 3 of 17

Sure. Here it is. The scene has the rig along with a short test animation. I'm also including a script that is one of the main features of the rig. I have it saved to a hotkey, but here's the script so that you can use it. The strange thing is, I cannot consistently replicate the problem. No specific action seems to trigger it. After about an hour it started happening again, and I just saved and reloaded the scene and it fixed it. Then, about 20 mins passed and it happened again, and froze up the scene to the point where for some reason I couldn't even open the task manager. Then I just restarted my computer, picked up the scene from where I was before the freeze (I saved after every pose, so it wasn't too much earlier than where I was at the freeze), and then it worked perfectly for two hours straight after that. I don't get it lol.

 

The one thing that's consistent with the issue is that every time before things start getting screwy, I get this error:

 

Warning: file: C:/Program Files/Autodesk/Maya2016.5/scripts/startup/initHUDScriptsEvaluationManager.mel line 121: Error detected in Parallel evaluation, reverting to Serial evaluation mode. // 

 

 

And then shortly after, things start getting weird. All I have to do is reset the scene and I'm fine again, but I don't fully understand what's triggering it. I have heard that errors in parallel evaluation could be caused by dependency issues. My rig does have about a dozen faux-interdependent systems, but nothing that actually cycles. Do you think sticking with Serial evaluation might prevent this issue from occurring? Or maybe something else?

 

 

In any case, here's the scene:

https://www.dropbox.com/s/acudth4lc5x6ufi/AutoRotatorRigStressTest.mb?dl=0

 

And the text for the rotator control script I'm using:

https://www.dropbox.com/s/zsd4qkxx9jy6gc2/RotationModeScript.txt?dl=0

Message 4 of 17

Hi @smillz999RZXKH

 

The link isn't working/expired. Can you post it again please.

Message 5 of 17

Sorry, I just restored the links. Here they are again:

 

Scene with Test Animation:

https://www.dropbox.com/s/acudth4lc5x6ufi/AutoRotatorRigStressTest.mb?dl=0

 

 

 Rotation Mode Script:

 https://www.dropbox.com/s/zsd4qkxx9jy6gc2/RotationModeScript.txt?dl=0

Message 6 of 17

Hi @smillz999RZXKH

 

I just tested it out on 2017 to see if this issue carries over from 2016 and I'm having zero issues. The animation plays fine and even if I delete all the keys and do my own short animation the issue doesn't reproduce.

 

Can you possibly post a video/gif of your issue?

Message 7 of 17

Yeah, I can record a short vid of it when I come across it again. But I have to admit, it's even hard for me to replicate the problem consistently haha. Thanks for all your support up to this point though. I'll post a vid if I can make it happen again

Message 8 of 17

Ok well let me know if anything changes or if you can recreate the issue!

Message 9 of 17

So I finally been able to narrow down the issue a bit. I still don't really understand what causes it to start, but once it does, it seems to only affect things set in the channel box. So, if I were to use any of the translation or rotation widgets to move, it doesn't cause this issue. But if I were to set a value in the channel box, it reverts back to what it was once I move it with a widget. And it reverts ALL changed attributes, not just movement based ones.

 

My current workaround has been to just set the keyframe, save the scene, and reload. Which honestly only takes about 5-15 seconds total, but it's still a bit of a bother since it has been popping up relatively frequently as I've been working. Here is a screen capture of it. Can anyone make heads or tails of this one?

Message 10 of 17
Anonymous
in reply to: smillz999RZXKH

I have a gut feeling it's Maya Viewport 2.0 and/or Maya Parallel evaluation making sure your valuable time is wasted as much as possible. That's what Maya excels at.

Message 11 of 17
mspeer
in reply to: smillz999RZXKH

Hi!

 

As long as the field is light red there is no "new" key set, so you have 2 options:

 

1. After changing a value, set key manual (just entering a value does not replace the old one)

2. Enable Auto Key (just entering a value creates a new key or overrides an old value)

Message 12 of 17
smillz999RZXKH
in reply to: mspeer

Thanks for your suggestion! I know autokey would technically be a workaround as I said in my first post, but I have two reasons why I don't want to turn on autokey. One is that I have a bad habit of posing before actually moving to a new keyframe haha, and often find myself using MMB to move to a new keyframe after the fact. And the second reason is because when it starts reverting all the poses, shortly after, Maya starts to freeze up. I'm fairly certain that with whatever that has been happening, the reverting poses aren't actually the core of the problem, but rather a byproduct of it. So it's been a good warning sign to save and refresh the scene before I lose any work. If I autokey, I lose that indicator of the doom that's soon to come haha. 

 

And I'm actually also suspecting that parallel evaluation might be contributing to the issue. I thought viewport 2.0 might have been too, but the same thing has been happening using the legacy viewport. The screen capture I used was actually using the legacy viewport

Message 13 of 17
spaehling
in reply to: smillz999RZXKH

hey even if its an older topic,  i also ran into the issue. overall i also had "Maya Parallel evaluation" in mind, but it did not help. i also saw that everything works well in graph editor and i also had the same issue with setting a keyframe in  channel box.

i also tried auto key and there i saw that translate worked fine, but rotation jumped back. i turned off "discrete rotate" and it feels like it helped a bit, but not complete.

Message 14 of 17
spaehling
in reply to: spaehling

overall its an strange issue. i try to investigate more and it feels liks it only happens on one rotation axis. feels like y. but yeah... also not on all controllers, just on some. maybe it has something to do with space swichting?
maybe you can workaround with setting animation layer to "additive or override". right mouse button on anim layer.

Message 15 of 17
kemenyz
in reply to: smillz999RZXKH

Hello,
Is there a solution for this? Because I constantly encountered to this issue and I'm going crazy now. Because of fighting with this crap behaviour while animating a character is 20x slower........

Message 16 of 17

I've run into an issue like this frequently.  In my case, it seems to be related to animation layers- particularly after I've created a new animation layer with controls included.  I try to adjust animation on the layer, but the control continuously pops back to its original position as soon as try to adjust on a different axis.  When I do this, non-zero keyframes are visibly set in the graph editor for the animation layer.  So, the animation data seems to be there, but the control is not respecting it.  To fix this issue, I typically have to close and restart maya.  When I re-open the scene, the issue will usually be fixed and the animation will have taken on the data from the anim layer.  However, the issue returns frequently.  It is very frustrating and a major slowdown.

Message 17 of 17

I've had a similar issue where if I touch any controller on my rig the entire thing reverts to the last frame position. The way I found to fix it was to go windows > setting/preferences > Preferences, then find "animation" under the "settings" heading. Change the Evaluation mode at the top from DG to any of the other option then back to DG. Somehow this fixed the issue. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report