Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Ambient Occlusion AOV output issue

8 REPLIES 8
SOLVED
Reply
Message 1 of 9
Anonymous
2032 Views, 8 Replies

Ambient Occlusion AOV output issue

Hi everyone, 

I used to create custom aiAmbientOcclusion AOV, but after a while on a project it started to give me some problems.

The AO output is not smooth but covered in grey triangles. I think it may be normals-related but I can't solve it. I tried using aiUtility ambocc but it doesn't work. 

 

I tried to export the model and open it in another scene, it worked for a while but then the same problem occurred.

 

I attach the incorrect AOV.

 

I work with Maya 2018 on a Mabook Pro (Catalina).

 

Thank you in advance!

8 REPLIES 8
Message 2 of 9
mspeer
in reply to: Anonymous

Hi!

 

Are the triangles connected in Maya?

Please provide a scene-file for further help.

Message 3 of 9
Anonymous
in reply to: Anonymous

Hi!

Did you ever find a solution to this? I'm having the exact same problem! They're moving in my render sequence so it's creating an awful flickering. 

Message 4 of 9
damaggio
in reply to: Anonymous

We need the scene, not an image.

Message 5 of 9
Anonymous
in reply to: damaggio

That's okay, I did some more research and figured it out, but thanks. 

https://answers.arnoldrenderer.com/questions/18546/im-getting-artifacts-black-faces-when-using-ambie... Here's the article that helped for anyone in the future.

To get the triangles off, you need to go into the shape node for your geo. Under 'render stats' > uncheck 'double sided'. This should fix that issue. 

To make it an override for a render layer; toggle AO render layer on (in render set-up menu toggle the eye icon next to the layer you want to affect). For the AO example, make a collection that includes all your geo. Have that collection selected, then select any piece of geo in your scene. Go find the menu I described above, and right click the box next to 'double sided', select create override, then the box should go orange and you can uncheck the box. 

This should create the override for all the geo in that selection! & the override will ensure the double sided box stays toggled on/default for your other render layers. 

Message 6 of 9
Ninurta
in reply to: Anonymous

same problem here

Message 7 of 9
Ninurta
in reply to: Anonymous

thanks !

it's work for me!
but maybe more easy way is go to "Attribute Spread Sheet".

select all geo. Go to "Render" tab.
and just set for all objects "Double Sided" to off at once.

Message 8 of 9
le_daiii
in reply to: Anonymous

Hello, I'm having the same problem, but i am using an SSS texture wich needs to have Double Sided on to work. Does anybody have another solution rather than disabling Double Sided ?

Message 9 of 9
le_daiii
in reply to: le_daiii

Replying to my own question, the real way to make these artifact go away is to change the near clip value of the AmbiantOcclusion shader. It is at 0 by default, here i put it to 0.1 and it solved my problem. Unchecking Double sided works, but if you need double sided like me with SSS material, this is how to solve it. Hope this helps somebody else.

 

Down here is my AOV with said artifacts, i tried to uncheck double sided but since my character has SSS material on his skin, I couldnt uncheck it here

forum1.jpg

 

And here is after I change the near clip of the Ambiant Occlusion Shader from 0 to 0.1

forum2.jpg

 

AO.PNG

  

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report