Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bug: decimal point format set to , instead of . breaks gerber file output

19 REPLIES 19
SOLVED
Reply
Message 1 of 20
helmut.krausEBCDG
907 Views, 19 Replies

Bug: decimal point format set to , instead of . breaks gerber file output

Hi,

after installing Fusion 360 as proprietary Eagle User I tried the basic functions and found that the CAM output generating gerber files was not working correctly.

The reason behind is that I have set in the windows region settings the decimal point to "," (as it was default for my country)

Because of this the generated gerber files also used "," as the decimal point separator which seems to be against the gerber file format as my usual gerber file viewer assigned diameter 0 to D-codes.

incorrect gerber code:

%ADD10R,0,040000X0,040000*%
%ADD11R,0,021654X0,047244*%

...

setting the decimal point to "." in the region format Fusion 360 generated

correct gerber code:

...

%ADD10R,1.016000X1.016000*%
%ADD11R,0.550000X1.200000*%

...

As the gerber file format is not country specific Fusion 360 should not use the region setting and should also genererate correct gerber code when the decimal point is set to ",".

19 REPLIES 19
Message 2 of 20

Hello @helmut.krausEBCDG,

I hope you're doing well. I just wanted to follow up, we've released two Fusion updates since this. We can't reproduce the issue and I wanted to follow up to see if it was still happening for you.

Best Regards,


Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 3 of 20

@jorge_garcia2,  I recently tried to reproduced my issue and was not able to do so.

I wonder if I have done something wrong causing that issue (it was clearly reproducible at the time of my post ) or if you have found and fixed that bug (in case it was really a bug).

 

If  I've done something wrong then I'm afraid it could also happen in the future, in case it was a bug I would have been happy when I have gotten some feedback like "will be fixed with next version".

 

Best regards

Helmut

Message 4 of 20

Hi @helmut.krausEBCDG,

I hope you're doing well. Our developers tried to look into it, however no one could reproduce it. I think it's possible that someone else may have fixed it.

Let's me know if it pops up again.

Best Regards,


Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 5 of 20
BFeenstra
in reply to: jorge_garcia2

Hey I had exactly the same issue.. Found out when I uploaded my gerbers to a manufacturer and they said I was missing D-code. After changing the number format in windows, and restarting fusion, the output is good.

 

For clarification: In windows control panel > Clock and Region > Change date, time, or number formats > Additional settings... > Decimal symbol

Was set to a comma (as per the standards here). Changing the decimal symbol to a dot fixed it. (I also changed the digit grouping to a space instead of a dot to separate the two..)

Message 6 of 20
frank8R448
in reply to: jorge_garcia2

Hi @jorge.garcia ,

 

I am experiencing the same issue in Fusion 360 v2.0.8412.

When the language settings of Windows are "German (Germany)", one of the generated Gerber files contains these lines:

%ADD10R,0,036256X0,038197*%
%ADD11R,0,061886X0,016016*%
%ADD12R,0,048189X0,019571*%

When the language is "English (United States)", however, the same Gerber file contains these lines instead:

%ADD10R,0.036256X0.038197*%
%ADD11R,0.061886X0.016016*%
%ADD12R,0.048189X0.019571*%

The generated Gerber files should always use the English format (with "." instead of ","), independent of the regional settings in Windows.

Files with "," as decimal separator cannot be processed by PCB manufacturers.

 

Regards
Frank

Message 7 of 20
jorge_garcia2
in reply to: frank8R448

Hi @frank8R448,

I've sent this to my colleague Richard, to see if he can reproduce this. We've had a few reports of this but so far none of us can duplicate it.

Let me know if there's anything else I can do for you.

Best Regards,


Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 8 of 20
gmstar
in reply to: jorge_garcia2

I have the same problem. 

 

Windows region is Danish same goes for format, but my display language is English

 

All decimal values in PCB layoyt are shown as 1.00 and not 1,00

 

Generated gerber files are also wrong.

 

It works if I change all windows settings to US alone.

 

Valid gerber using US windows settings:

G04 EAGLE Gerber RS-274X export*
%ADD10C,1.524000*%
%ADD11P,1.429621X8X112.500000*%
%ADD12R,1.803000X1.600000*%
%ADD13C,0.812800*%

 

Invalid gerber using danish windows settings:

G04 EAGLE Gerber RS-274X export*
%ADD10C,1,524000*%
%ADD11P,1,429621X8X112,500000*%
%ADD12R,1,803000X1,600000*%
%ADD13C,0,812800*%
%ADD14C,0,152400*%

 

This is a serious problem!

 

Fusion version:

2.0.8950

 

Windows 10 Build:

(18363)

 

 

Message 9 of 20
jorge_garcia2
in reply to: gmstar

Hi @gmstar,

Here's a fix you can try to avoid having to change your regionalization settings. Set up the following environment variable on your machine.

Here's the procedure for creating a new environment variable:
https://docs.oracle.com/en/database/oracle/r-enterprise/1.5.1/oread/creating-and-modifying-environme...

The variable you want to create is:
FORCE_DECIMAL_GERBER_OUTPUT

it's value needs to be set to:
true

Let me know if this works for you.

Best Regards,


Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 10 of 20
gmstar
in reply to: jorge_garcia2

Hi @jorge_garcia2 thank you for your reply.

 

I haven't tried your suggestion just yet...

 

However I changed, as previously mentioned, the Windows region/format to US after which the gerber files were formed correctly.

 

But now the format is changed to US  format for the entire Fusion application, even though I have changed the windows region back to Danish and restarted.

 

This seems to be a general problem related to how Fusion reads the windows settings or some cache issue or...

 

So how do I get my normal format back i Fusion...

 

Best 

 

Message 11 of 20

I just wanted to chime in and let you know that this is a real problem. I just got some unusable boards back from my fab because of this issue. I'll try settings the global system variable mentioned above. However, this is definitely a real bug that should be fixed.

I'm running Windows 10. My Windows and Fusion 360 are set to the English language, but I'm using the Dutch date and number system (which uses a decimal comma). Maybe this slightly strange mix is part of the cause of this bug.

Message 12 of 20
andy.ball
in reply to: jimUR4RG

Our initial fix for this issue apparently did not resolve it for most users that were experiencing it.  We have another approach that will appear in the next September Hotfix release.  It will be controlled by the same environmental variable. ---An elusive problem for us, because we have not actually been able to duplicate the issue, in-house.

Message 13 of 20
gmstar
in reply to: andy.ball

@andy.ball Got my fingers crossed 🙂

 

However i can't get F360 to go back to my normal danish format layout - now it is stuck to the US version of formating dates and numbers....

 

Do I have to reinstall? I have tried to empty the cache with no luck.

 

Is there a specifik reason that F360 rely on the windows settings rather than a program specific setting?

 

All the best.

 

Message 14 of 20

I'm experiancing exactly the same issue.

i've tried your fix and it works

 

PS : i'm using windows 10 located in france

 

thanks

Message 15 of 20

@AutoDesk - I would suggest to activate this workaround without the user needed to set any environment variable as  gerber files with the wrong comma delimiter are for no use at all.

best regards

Helmut

Message 16 of 20

I just ran into this bug again. Luckily my PCB manufacturer caught it, I've gotten useless boards back due to this bug. I agree with the poster before. A comma is not a valid decimal separator in a gerber file so the software should always use a dot, regardsless of system language settings or environment variables.

 

Adding the environment variable does, luckily, solve the problem.

Message 17 of 20
bjomag
in reply to: jorge_garcia2
Message 18 of 20
bjomag
in reply to: helmut.krausEBCDG

I too ran into this bug, using English langague but with Swedish date, time, etc.. 

It unforunaley took me some time since strange enough it does no brake the gerber files completly only omitted some traces.

 

One tip If one needs to have some more debug about gerber files and if something is wrong with them a good online viewer is ucamco's gerber viewer it shows a debug of all uploaded files, very helpful. 

 

Debug information:

Windows 10 (17763)

Fusion 360 version 2.0.9512

Message 19 of 20

Has any progress been made on this issue?
a while ago I've send three gerber files to my manufacturer. Two had no issues, but one had all traces mixed up. We would only solve it by sending them my fbrd file and let them create the gerber files.

I'm also from the Netherlands, use windows 10 with a comma as decimal separator. 

Do I need to do something with setting that environment variable, or is a fix on the way?

 

Message 20 of 20

Hi @AutomaticRock ,

 

I hope you're doing well. For now I would say to setup the environment variable. There is a fix on the way but I don't know when it will come into the program.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums