Community
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Don't mess with my OSNAP settings

Don't mess with my OSNAP settings

There are some commands that automatically remove my OSNAPs. One of them I know of is Insert Elevation Point on a feature line. This behaviour is incredibly annoying. I have a handy button that many people call F3. If I want to turn off all my OSNAPs I will use it. Normally when I insert elevation points I want to snap to something.

Please leave control in the hands of the people and leave my OSNAPs alone!

 

(I think another command is add PI to an alignment. In this case the only OSNAP removed is END, all the others are left alone. Please fix this too, and any others.)

16 Comments
Cadguru42
Advisor

Yes! This is so annoying. It happens in other commands as well and it's annoying when you're working and all of a sudden your OSNAP is off. 

sboon
Mentor

This one has been on my personal list of annoyances since 2005.  IMHO the software should not ever change the OSNAP setting.  Let the user do it when necessary.

 

Steve
Please use the Accept as Solution or Kudo buttons when appropriate

C3D_TomR
Collaborator

If the osnap needs to be changed in the middle of a running command that doesn't require my interaction, I'm fine with that. On something like this (inserting an elevation point) I want to be in control of my osnaps settings. Even more annoying, if I enable them then pick a point, most times it gets disabled again for the next point selection. Please remove this unwanted behavior.

jmayo-EE
Mentor

OMG what a PITA.

jmartt
Collaborator

I'm with ya. Kudo'ed. Probably you know this; maybe someone won't. I have this lisp code in my startup suite and press q whenever the osnaps get changed. Also handy if I change them on purpose and want to get them back to normal quickly.

 

(defun C:q () (command "_osmode" "175")

  (princ))

 

Change the 175 to whatever you want using the osnap numbers shown here http://knowledge.autodesk.com/support/autocad/learn-explore/caas/CloudHelp/cloudhelp/2015/ENU/AutoCA...

troma
Mentor

@jmartt can you get that to work transparently?

jmartt
Collaborator

I haven't tried. I don't know how to embed something into a transparent command. I'm a mere mortal. I didn't even write that little osmode code that I'm using.

troma
Mentor

That's the thing. It needs to be transparent, becasue the stupid program just turns it off for the duration of the command and then on again afterwards. I need to turn it back on during the command.

Status changed to: Future Consideration
 
Status changed to: Accepted
 
abbythralls
Participant

AGREE!

This is a PITA.

troma
Mentor

AAAAAAAARRRRRRHHHHHGGGG  Smiley Mad

robert06
Collaborator

To overcome this I assigned keyboard shortcut macros of my favourite Osmodes with apostrophe, so they can be set also without interrupting a command. For instance: 'osmode;1263;

C3D_TomR
Collaborator
Great tip, @robert06. I'm going to give that a try. Thanks!
shortbrandon
Advocate

What does it mean for an idea to be accepted, and why isn't it implemented 9 years later?

imr38L8L
Explorer

this is so frustrating. there is no reason to turn off O-snaps when starting a command/edit etc. we all know that we can simply turn off the snaps by hitting F3. LEAVE THEM ON and let the user decide whether or not we need them. I hope this fix comes soon as this has been a problem for YEARS!

Can't find what you're looking for? Ask the community or share your knowledge.

Submit Idea  

Answer Day

Rail Community


 

Autodesk Design & Make Report