Community
Civil 3D Forum
Welcome to Autodesk’s Civil 3D Forums. Share your knowledge, ask questions, and explore popular AutoCAD Civil 3D topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Civil 3D 2020 - Delay in Creating or Editing Mtext

8 REPLIES 8
Reply
Message 1 of 9
CADvisers
632 Views, 8 Replies

Civil 3D 2020 - Delay in Creating or Editing Mtext

I'm getting a major delay in either creating or editing Mtext.

About a minute until I get the cursor to pop up in editor.

... All support paths are the same as in C3D 2018.

... Tried both Hardware Acceleration on and off

... tried both .shx and ttf fonts

... tried both custom template and default template

 

I have all current 2020 updates installed.

Any ideas???

Jonathan Stewart
CADvisers
P.O. Box 7811
Lancaster, PA 17604
Ph. 717-468-3111


8 REPLIES 8
Message 2 of 9
SMorykin
in reply to: CADvisers

@CADvisers  - this may be a dumb question but have you checked to ensure your OS is up to date or your graphic cards?  Whenever a command starts acting up on me, it's usually an update that needs applied.

Did you recently install any other software on your machine that could potentially conflict?


If this post solves your issue or answers your question, Please select the ‘Accept as Solution’ button so other Community members may benefit. Thank you!
Message 3 of 9
Jeff_M
in reply to: CADvisers

I've experienced this issue, off & on, in C3D 2016, 2018, & 2020. It occurs in some drawings but not others. I have never found a solution, other than to shutdown C3D and restart which seems to 'fix' it for a time.

Jeff_M, also a frequent Swamper
EESignature
Message 4 of 9
pendean
in reply to: Jeff_M

@Jeff_M That sounds like a memory "leak", aka not being released. Win10, correct?
Message 5 of 9
pendean
in reply to: CADvisers

@Anonymous did you use the migration tool to move from 2018 to 2020? Or did you recreate everything from scratch? If yes, reset 2020 and see if the problem goes away.

How many total fonts do you have (SHX and TTF) that C3D may tap into?

Message 6 of 9
Jeff_M
in reply to: pendean

@pendean , yes, Win10.

 

Jeff_M, also a frequent Swamper
EESignature
Message 7 of 9
pendean
in reply to: Jeff_M

@Jeff_M WIn10 solutions to try https://www.thewindowsclub.com/memory-leaks-in-windows

or

https://windowsreport.com/memory-leak-windows-10/

 

Is this a corporate PC? If yes, do you have apps like Trustedinstaller running? Turning them off (if allowed) might help.

 

Other things to try in C3D itself:

  • Type SAVEFIDELITY on the command line in AutoCAD and change the value to 0 (zero).
  • Install the latest updates for AutoCAD (you said you already did, but confirm)
  • Update to the latest graphics card driver (sometimes an older driver works better).
  • Install DirectX to make sure it is up-to-date.
  • Reinstall Visual C++ (required admin rights, you need to remove then reinstall).

 

Message 8 of 9
CADvisers
in reply to: SMorykin

So you'd think I'd be on Win 10, and probably should be.

But still on 7 Professional. 

It's just odd the Mtext is instant in 2018, and then has a minute lag in 2020.

This is having them both running side by side using same template and settings.

Jonathan Stewart
CADvisers
P.O. Box 7811
Lancaster, PA 17604
Ph. 717-468-3111


Message 9 of 9
CADvisers
in reply to: CADvisers

It seems like it's graphics card related as with most issues in 2020.

I installed it on a similar computer that's fairly equal in processor speed and ram.  But it has a slightly better graphics card.  With that computer there's still lag but only a few seconds.

 

Jonathan Stewart
CADvisers
P.O. Box 7811
Lancaster, PA 17604
Ph. 717-468-3111


Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Rail Community


 

Autodesk Design & Make Report