Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Translate/Transform cached Bifrost Graph Simulation

Message 1 of 10
823 Views, 9 Replies

Translate/Transform cached Bifrost Graph Simulation


Is there a way to translate a cached aereo simulation within Maya or the Bifrost Graph Editor? I know it is quite easy with polyObjects (as described in this tutorial: but it doesn’t seem to work with aereo simulations.

I am asking, since I cached a huge simulation already, and I would like to reuse it and therefore I have to be able to move and rotate it.


Thank you in advance!



  • Windows 10 Build 17763
  • Maya 2019.2
  • Bifrost Version
  • TR 1950X
  • 32 GB RAM
  • RTX 2080 - 430.86 Studio Driver
Message 2 of 10

If you store a VDB you can import it with your render engine and move rotate scale it.

Message 3 of 10

It would be incredible if simulations could be deformed ... does anyone know about this topic?
Message 4 of 10

Thank you for your reply!

Ok I see. I tried to export a few frame now in VDB and reimporting it with Arnold>Volume. What i dont understand is which properties/channels I have to write/insert into the "Grids" field (AttributeEditor>aiVolumeShape>VolumeAttributes>Grids). Since whatever i choose Arnold keeps rendering the Voxels instead of the Volume_Density. Are there any special settings in the Bifrost Graph file_Cache node i have to consider when exporting with VDB, since until now I used BOB?


Thanks in advance!

Message 5 of 10

Have you assigned the aiStandardVolume Shader and use the Bifrost preset?


Message 6 of 10

Thank you for the reply!

Yes I have applied the aiStandartVolume. I attached a screenshot, so it is easier to have an overview what I am talking about.


Thanks in advance!

Message 7 of 10

Have you turned on use default material in the viewport?

Message 8 of 10

It was not turned on. But even if I turn it on it doesnt change anything. I added a screenshot again. 


Thanks in advance!

Message 9 of 10

You need to use the bifrost preset.

There is a preset button on top of the shader tab.

Message 10 of 10

Ok I see! Yes this solved the issue.


Thank you very much!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums