Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya crashes when rendering in Bifrost

31 REPLIES 31
Reply
Message 1 of 32
Sik-Kee
1491 Views, 31 Replies

Maya crashes when rendering in Bifrost

I keep on getting this error whenever I try to render in a complexe Bifrost scene in Arnold.

 

(Exception code: C0000005: ACCESS_VIOLATION - illegal read at address 0x000000BF
Fault address: 914C840D in C:\Program Files\Autodesk\Bifrost\Maya2023\2.5.1.0\bifrost\bin\AminoPrivateDM_2_1_0.dll
0001:0021740D Logical offset (see .map file for location)

 

I would clean uninstall and clear the registry and then reinstall. it would work then crash randomly again when i try to render a cpomplexe scene and afterwards won't render again not even a simple mesh connected to the output. I would have to go through the same unistall procedure over again.

 

Should clean install my whole system? I have windows 11 a Ryzen 3700X and RTX 3060 wih 64GB ram. I am planning to get a 5950x in a couple of days. I haven't found a single similar problem all over the internet and it seems to be an issue specific to me... Maybe reinstalling windows is the only solution.

 

It's extremely annoying and frustrating. Please help me !!!

31 REPLIES 31
Message 21 of 32
Sik-Kee
in reply to: Christoph_Schaedl

I have had to uninstall all Autodesk products i had, deleted the registry and all folders. Then whe the problem persisted I formatted my system drive as well as my project drive NVMes and swapped them. I am on Windows 11 can it be something with it? I am always anxious when i launch Arnold but it only crashes with Bifrost...
I have unistalled Maya 2023 and all its components and will reinstall and try again now. Yes I did delete the prefs folder.

Message 22 of 32
Sik-Kee
in reply to: Christoph_Schaedl

... just a duplicated post sorry.

Message 23 of 32
Christoph_Schaedl
in reply to: Sik-Kee

Does rendering with GPU and CPU crash?

----------------------------------------------------------------
https://linktr.ee/cg_oglu
Message 24 of 32
Sik-Kee
in reply to: Christoph_Schaedl

With Bifrost yes both crash...I did another clean install it worked a bit and then crashed out of the blue. I then tried in 2022.4 it crashed with the error i have attached. I am just confused and fed up, I don't understand what;'s going on. Maybe I will try to revert to Windows 10 on a different drive and see if it still crashes.

Message 25 of 32

please could you tell me what this file "AminoPrivateDM_2_1_0.dll" is for?

Message 26 of 32
Sik-Kee
in reply to: Sik-Kee

@Christoph_Schaedl& @morten.bojsen-hansen,

Maya failed again and I did a clean install of all Autodesk stuffs. I have been saving  my Bifrost coumpounds folder on another drive so that I could copy and paste it in the new installation without having to copy every single custom compounds.

My fresh installation worked once and crashed at the second try. As I had the compound folder still opened I undid the copy & paste action and it worked again.

Before I can confirm that it is the one thing that was causing me trouble I will run some more tests and see if it fails again...

Message 27 of 32

@Sik-Kee If that does indeed turn out to be the problem we would very much like a copy of your compounds folder so we can try to reproduce and fix the problem!

Message 28 of 32

so far, it seems to have been the cause since I am now able to render heavy scenes i couldn't render before. But still i ill give it to the end of the day just to make sure. I have attached my Bifrost folder as requested anyways...

Message 29 of 32

Thanks @Sik-Kee I was able to reproduce the crash locally using your Compounds folder. I have logged BIFROST-8067 internally to get this fixed. Thank you very much for your patience and help tracking down this crash.

Message 30 of 32

Thank you very much @morten.bojsen-hansen 

Message 31 of 32
brandaosa
in reply to: Sik-Kee

I have or had same problem.
I am using the "BurningBarrel" scene from the Bifrost sample folder with some modifications.
 - the emitter is using an animated object on scene.
 - the start frame is about 500..
 - there are some animation on the source_fuel node.

The first attempt was to render from frame 500. But after few frames Maya started to crash.
I then cached the simulation, so I was able to render from any frame - and I believe this is the way to go, but then Maya started to crash every 3 to 10 rendered frames.
I thought the cache folder needed to be on a local folder (it was on a server), but that didnt help anything.

It was inconvinient, but I had to create a new scene with only the animated emitter from original scene, run the simulation and render sequence - cache didn't work at all - than, compose with a fake light. I wish I could have some sempai to ask about these issues at my workplace.

Message 32 of 32

BIFROST-8067 (this bug) has been fixed internally and the fix will be in the next release.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums