Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bifrost liquid simulation run too fast on real time playback

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
Anonymous
852 Views, 4 Replies

Bifrost liquid simulation run too fast on real time playback

Hello, I am trying to run Bifrost liquid simulation. I already set the voxel, killplane, colliders, emitter, and everything. I also changed the gravity to 980 and density to 1, which I believe are the correct units for Bifrost liquid simulation. I also set the emitter to pour the liquid continuously. The problem occurs when I set the playback speed to real-time mode. They run too quickly (the particles just fall down within the 5th frame). But when I set the playback speed to play every frame, the particles run down normally. Why is this happening and how can I fix this? 

I am a Mac user. 

 

Screen Shot 2020-05-09 at 12.27.27 AM.png

Playback on 27th frame, set to play every frame 

 

Screen Shot 2020-05-09 at 12.27.53 AM.png

 Playback on 27th frame, set to real time 

Labels (2)
4 REPLIES 4
Message 2 of 5
mspeer
in reply to: Anonymous

Hi!

 

For a correct simulation every frame needs to be evaluated.

If you force Maya to real time playback it skips frames if the playback is not fast enough, this breaks the simulation.

So for all dynamics and simulation stuff you need

a) "Play Every Frame", or

b) you need to cache the simulation first, then skipping frames is not a problem.

 

Message 3 of 5
Anonymous
in reply to: mspeer

Thank you so much for the quick reply!

Can you explain how to "cache simulation"? I'm pretty new to Maya so I still don't quite understand the concept 😞

Also, do I HAVE to set the playback mode as Play Every Frame, and then hit render sequence in order to get the liquid in my rendered image? I'm trying to render at least 5 seconds of the simulation. From the sample render I've tested so far in Real-Time settings, the liquid just did not show up. 

Screen Shot 2020-05-09 at 12.28.03 AM.png

This is when the frame was at 27 and the liquid did not show up. 

 

 

 

Message 4 of 5
mspeer
in reply to: Anonymous

Hi!

 

1) Bifrost Fluids > Compute and Cache to Disk...

 

2) If a frame is simulated it can be rendered, the playback settings do not have any effect on the rendering.

Message 5 of 5
aaronfross
in reply to: Anonymous

The appropriate playback mode is "Play Every Frame, Max Real Time". You can set this easily by right-clicking the timeline. Every frame is evaluated, and the playback speed never exceeds your current frame rate.

 

In Maya, dynamic simulations assume a scene unit is a meter. Everything else assumes a scene unit is a centimeter, regardless of your Preferences settings. This is a big PITA. For best results, build your scene to 1/100th scale.

 

If your scene is built to 1:1 scale, then the measurements are in centimeters:

 

Gravity = 980 cm per second

Density = 0.001 kilograms per CUBIC centimeter

 

You will also need to increase the Master Voxel Size, otherwise your simulation will be super ultra detailed and take forever to calculate.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums