Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Adding quaternion_to_axis_angle or quaternion_to_rotation_vector nodes causing maya to crash when publishing bifrost graph.

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
dave_olivares
500 Views, 2 Replies

Adding quaternion_to_axis_angle or quaternion_to_rotation_vector nodes causing maya to crash when publishing bifrost graph.

Adding the quaternion_to_axis_angle or quaternion_to_rotation_vector nodes to a bifrost graph and then attempting to publish the graph causes Maya to segfault.  (Maya v2020.4, Bifrost v2.3.0.0, Linux CentOs 7.9.2009)

 

Interestingly, if I explode any quaternion_to_axis_angle nodes contained therein to their constituent parts, publishing does not cause maya to crash.  Even grouping them again into a compound still works.

2 REPLIES 2
Message 2 of 3

Hi,

 

We've reproduced this issue and are tracking it as BIFROST-6396.

 

Thanks for reporting!

gray


Grahame Fuller
Learning Content Developer
Message 3 of 3

Just to give an update: This was caused by the same underlying issue as another item (BIFROST-6216 Publishing: Crash during compound re-publishing).

 

It has been fixed in our internal builds, so stay tuned!

 

gray


Grahame Fuller
Learning Content Developer

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report