AutoCAD Map 3D Forum
Welcome to Autodesk’s AutoCAD Map 3D Forums. Share your knowledge, ask questions, and explore popular AutoCAD Map 3D topics.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Is there the correct way to import points from google Earth as the KLM file?

Message 1 of 26
7543 Views, 25 Replies

Is there the correct way to import points from google Earth as the KLM file?

Hey All,


I'm not a surveyor or experienced AutoCAD Map 3D user, but really need your assistance. I have read a lot of post on this forum and seems like I could not find the solution to the problem.

I have been working on the project where I have a data(few points from the Google Earth) and I'm trying to import to the CAD, but have no luck. All my points end up 100 feet away and all of them really close to each other(scale down). I set all the drawing units in meters, the GIS system I'm using is WORLD-MERCATOR, REF. IS wgs84, unit is meter, EPGS CODE IS 3395. when I import KLM file I'm selecting the same GIS coordination system and the same units.

Please Help!


Message 2 of 26
in reply to: Anonymous

Are you drawing in Georgia East Zone?


If you are, do this:

  1. In modelspace of Map 3D, assign an appropriate Georgia State Plane and Zone, examples include, but not limited to, are GA83-EF (EPSG 2239), NSRS07.GA-EF (EPSG 3519), NSRS11.GA-EF (EPSG 6554) or whatever Projected coordinate system is appropriate to your site location. Don't assign a Geographic coordinate system. (Projected will use units of feet or meters while Geographic will use unit of degrees, such as Lat/Long).
  2. In Google Earth Pro, highlight the points shown in the Places Panel on the left. Right click and choose 'Save Place As....' then save the points in a dedicated folder using 'kml' or 'kmz' as the extension.
  3. Back in Map 3D, Planning & Analysis WS, Insert tab=>Import panel=>Click Map Import icon. 'Change Files of type' to Google KML and browse to your Point Folder. Import the points. If you have multiples use Shift+click or Shift+Alt so you don't have to import them individually.
  4. Next, in the Input column, un-check ALL rows with the exception of PLACEMARK (a Placemark is the GE Pro term for point).  Notice the Input Coordinate System column, it shows LL84, the coordinate system used by GE Pro. Leave LL84 as-is, if you change it you'll have issues, big time. While still on the Placemark Row, notice the Points column. It displays the default object <ACAD_POINT> which will be used to represent your point. You should enter PTYPE on command line after the Import procedure so you can change the point style for better visibility, otherwise you're limited to a mere tiny dot.
Message 3 of 26
in reply to: ChicagoLooper

Thank you so much for your help, but it didn't solved it. I'm not sure if I understand you correctly, but how do I set the projected coordinate system? The only option I see is the coordinate system assigned to project. I can't find the option for projected coordinate system. please clarify.



Message 4 of 26
in reply to: Anonymous

Assign a coordinate system in the drawing: _MAPCSASSIGN



-- Alexander, private person, pacifist, english only with translator 🙂 --

Object-modeling _ _ Help

Message 5 of 26
in reply to: АлексЮстасу

I did assign the GA83-W. I wasn't sure if it is there projected coordination system vs geographic coordination system.

Message 6 of 26
in reply to: Anonymous

You have chosen Georgia State Plane West zone, Meters (not feet). Are you absolutely sure you want west zone and not east? Caution, if you guess wrong, you'll have issues.


What is the lat/long for the 'center, of your site? Go to Google Earth Pro and get the Lat/long then upload the coordinates so the correct State Plane and Zone can be determined. When it comes to selecting the correct CS, close doesn't count, it must be spot on.

Message 7 of 26
in reply to: ChicagoLooper

The project is in meters. 

Center of site Latitude = 33.9523 and Long=-84.2308. 

When i place the points as the "mark position" (position marker) option it will end up on the correct place. the only problem with that i have a 200 points.

Message 8 of 26
in reply to: Anonymous

Your site is in Gwinnett County which is in Georgia West Zone. Start from a clean, brand new Imperial template. Then do this:


  1. On command line enter, MAPCSASSIGN. Then in Search Box, enter Georgia. From the results of the search, select Georgia NAD83, West Zone, US feet, or GA83-WF EPSG 2240. Click ASSIGN. Refer to image below.
  2. MAPIMPORT command and import the kml file you made using Google Earth Pro. In the Input column, place check on only on the row named PLACEMARK. All other rows must be un-checked. Keep all other columns at their default values. click OK.
  3. Enter PTYPE on command line. Change from the default 'dot' point style to one of the other styles such as one that uses a 'square' or 'circle' in the style.
  4. Turn on Bing Aerial imagery.

MAPASSIGN on command line. Search Georgia to get results like shown below.MAPASSIGN on command line. Search Georgia to get results like shown below.

Message 9 of 26
in reply to: ChicagoLooper

When i bring the points they are 2 million feet away. i following every step you mention, but no luck. File is attached.

Message 10 of 26
in reply to: Anonymous

You are using the WRONG coordinate system in modelspace. 


The correct one is GA83-WF

GA=Georgia State Plane

83=North American Datum (NAD)

W=West Zone

F=US Feet


You are using GA83-W

Someone took the F out? Gotta leave the F in.

If you are using a State Plane and Zone without the F at the end, then you are defaulting to meters.



Message 11 of 26
in reply to: ChicagoLooper

 Thank you very much for your help Sir,  points are way off unfortunately. Seems to me that AutoCAD cannot transfer points  imported from Google earth,  unless  each point individually as a position marker. 

Message 12 of 26
in reply to: ChicagoLooper

 Does Georgia state Plane using the northing  and easting? But I am trying to import the data with coordinate system  in longitude and latitude. Does the AutoCAD will convert that type of data?

Message 13 of 26
in reply to: Anonymous

Of course it can understand lat/long from Google Earth Pro and put them into a dwg which uses State Plane. Upload your kml points or a sample of those points. Solving this is not hard at all. 


This is not a GE Pro-to-dwg issue. This is understanding how coordinate geometry works issue. 

Message 14 of 26
in reply to: ChicagoLooper

One more thing I notice it when I import points from GE, just one of the many points, after import is complete I select one of the points and in the properties I see position x=2277009.27219(easting), y=1437630.4572(northing), but when I place the same point as the position marker via Lat/Long(33.9521/-84.2312) I end up few million feet away. All conversion is done on the Hopefully everyone understand what I trying to explain.

Message 15 of 26
in reply to: Anonymous

From what you are describing, it sounds like you are having an issue with importing a point created in GE Pro which uses Lat/Long Coordinates (LL84 referenced to WGS84). Here's a screencast that demonstrates how to import your kml point that was created in GE Pro (it has the same Lat/Long as the point you mentioned in post 14 of this thread). 


Things to consider before you try to duplicate this exercise.

  1. Start from a brand new, clean IMPERIAL template being extra careful not to use metric.
  2. Use the correct State Plane coordinate System, GA83-WF, EPSG 2240. Don't use GA83-W, EPSG 26967 because that one is metric.  
  3. To establish the CoordSys in modelspace use MAPCSASSIGN command.
  4. Do not ignore #3. You may have used other commands in the past or have used recommendations by others to set your CS. Those other commands, although accurate, are tricky to use and even more difficult to explain in a thread on a forum.  

Once you have opened a brand new, clean imperial template and have assigned your CS, you can view the video.




If screencast doesn't upload, click >>HERE<<.

Message 16 of 26

I am also facing the same problem. I have to work in feet my site is in Pakistan or UTM WGS48  Zone42, need HELP

Message 17 of 26

Based on your uploaded images, using one of those coordinate systems will give you 'grid coordinates' in units of meters. (If you use PAK-I/a or PAK-II/a then your coordinates will be in Indian Yards, and whatever that is I don't know--refer to image named auto.jpg in Post #16.)


When you draw in Modelspace, you can use various units such as, but not limited to, millimeters, meters, inches, feet. This means when your drawing units are in meters and want to draw a circle with radius 3 meters, you would use the circle command and enter '3' for the radius. If your circle needed to be 7.25 meters, then you would enter '7.25' for radius. However, if your circle needs to be 500mm, then you would enter '0.5' for radius because 500mm is equal to one-half or 0.5 meter. If you accidentally enter 500 for the radius, then your circle would have a radius of 500 meters, not 500mm. 


If you have to work in feet using a coordinate system that uses meters, you will need to convert all your feet numbers into meters. This means you will have to convert all your imperial measurements to metric. You will need to gather all your imperial measurements, put them in a spreadsheet then convert them using formulas: one formula for distance, another formula for area, etc. etc. Once you have converted all measurements, then you can efficiently draw using a Pakistani coordinate system.


Why must you convert the numbers? Because the drawing units in modelspace will inherit or adopt the units of the 'Assigned Coordinate System.' Since there is no out-of-the-box coordinate system for Pakistan that uses feet, you are relegated to using one that uses meters.


Only the United States still uses feet, all other countries use meters or have already switched from the King's Foot to metric. Yes, we are stubborn and like to go our own way.


One final note, your uploaded image named auto.jpg3.jpg indicates you have highlighted UTM84-42S. Do not use that coordinate system! If you want to use UTM coordinates, use UTM84-42N instead. The 'S' indicates a zone south of the equator while 'N' indicates a zone north of the equator. Since Pakistan is northern hemisphere, you will want to use UTM84-42N. 



Message 18 of 26

I'm trying to import a .kml into AutoCAD Map 3D 2022 but there is one problem. I have the klm file with all the information and I want to import it to autocad to edit the information. The only problem comes when I have to choose a Coordinate system. I dont know wich system Google earth export it. 

what should I do to select in autocad the coordinate system, which from Google Earth pro as klm has been exported?



Message 19 of 26

Data in Google Earth in WGS84.
In Map 3D, the corresponding code is LL84.


But you can choose another coordinate system, whichever you prefer.

For example, metric, foot. Or so on. MAPIMPORT will convert from WGS84 to the assigned coordinate system




-- Alexander, private person, pacifist, english only with translator 🙂 --

Object-modeling _ _ Help

Message 20 of 26

are you saying I shouldnt select in Autocad Maps 3D the coordinate system? because I searched the one you meaned (LL84) and also I got more than a coordinate. Do you know where do I find more information about coordinate system between Google Earth pro and Autocad Maps 3D? 



Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators

Autodesk Design & Make Report