Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Transmission shadow with eyeball wet line

21 REPLIES 21
SOLVED
Reply
Message 1 of 22
stuparyk
1466 Views, 21 Replies

Transmission shadow with eyeball wet line

Hi,

 

When rendering this portrait, the wet line geometry for my eyeball is causing a weird darkening effect as illustrated in my supplied screenshot showing both beauty and sss aovs. I am using Maya 2024 with Arnold MtoA 5.3.1.

 

The wet line geometry is extremely simple with subdivisions being applied at render time. The shader is basic with transmission turned on, ior 1.33 and specular roughness 0.02. Turning off Opaque and Cast Shadows in the Shape Node for the geometry yields no results.

 

How can I remove this darkening effect?

 

Thank you.

 

Labels (2)
21 REPLIES 21
Message 2 of 22
lee_griggs
in reply to: stuparyk

Are the normals correct? Are transmission, diffuse and specular ray depths high enough?

Is standard_surface.coat_color black? Maybe something here may help identify the issue.

 

Also, remember to enable standard_surface.caustics for the outer eyeball geo and the wet line.

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 3 of 22
stuparyk
in reply to: lee_griggs

Thank you very much @lee_griggs! Enabling caustics for both geometries worked. I also increased the ray depth samples first (which had no change). I appreciate your assistance.

 

Kind regards.

Message 4 of 22
stuparyk
in reply to: stuparyk

Hi @lee_griggs, I am having similar issues as above with a different project. I was hoping you could assist me with this. Basically, I am doing the exact same thing in a different project, but this time, I've applied all the suggestions you previously gave me. I've increased the ray depth, and caustics are on both materials with transmission turned on. In my screenshot, the eyes on top, have the wetline geometry turned on and are creating a light/white "strip" across the whole eyeball texture. When viewing the eyes on the bottom with the geometry turned off, you can see how it looks. I'm not sure what is causing this artifact and I've exhausted all previous options you have given me.

 

Any advice you have is greatly appreciated. Thank you very much for your time.

edit: I forgot to add that toggling "opaque" and "casts shadows" in the shape node yields no visible difference.

Message 5 of 22
lee_griggs
in reply to: stuparyk

Are you talking about the wet line looking a bit 'milky'? What are the shader settings? How is it being lit?

lee_griggs_0-1687758891520.png

 

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 6 of 22
stuparyk
in reply to: lee_griggs

Hi @lee_griggs, thank you for your response. Yes, exactly. I was unaware of the term "milky". But you can see that whitening band across the whole geometry. I've attached my shader settings for the wetline geometry, as well as a photo of my lighting setup. The lights are extremely simple. I have an HDRI in the scene, key and rim light at the moment.

One thing to add, I have since disable caustics and now the eye renders "normally". I do not understand what is happening in these projects. With the first one, enabling caustics solved the shadow issue. With this, it creates the milky effect. I am unsure what I am doing wrong and don't know how to else to trouble shoot these artifacts.

 

Any insight you can provide would be greatly appreciated. Thank you again for your time and efforts helping me with these issues.

Kind regards.

Message 7 of 22
lee_griggs
in reply to: stuparyk

Are you able to upload the eyeball/wetline scene here?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 8 of 22
stuparyk
in reply to: lee_griggs

Would it be possible to privately send you the file? I can try to send the exact Maya scene or a stripped down version. Thank you @lee_griggs

Message 9 of 22
lee_griggs
in reply to: stuparyk

Sure. Have you tried assigning a different shader to the wet line and changing that? ie Advanced -> indirect_diffuse/indirect_specular.

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 10 of 22
stuparyk
in reply to: lee_griggs

Thank you @lee_griggs, I have sent you a private message with my project file. Unfortunately, I do not know about that advanced shader. I am very much a novice with creating shaders. In the meantime, I will try to research the documentation regarding the indirect and direct specular shader. Thanks.

Message 11 of 22
lee_griggs
in reply to: stuparyk

Advanced in standard_surface is here.

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 12 of 22
lee_griggs
in reply to: stuparyk

I enabled standard_surface.thin_walled (Geometry) and increased transmission visibility for the area_light and it seems to look better. Hope that helps.

 

lee_griggs_1-1688040479687.png

 

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 13 of 22
stuparyk
in reply to: stuparyk

Hi @lee_griggs, I have enabled those settings and it actually has brightened the geometry, as illustrated in the attached screenshot. Not sure what you recommend.

Thanks again.

Message 14 of 22
lee_griggs
in reply to: stuparyk

What happens when you disable standard_surface.caustics?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 15 of 22
stuparyk
in reply to: stuparyk

It appears to create the original issue where it darkens again. Very weird. I don't know if there is anything else that could be contributing to this? Thanks @lee_griggs.

Message 16 of 22
stuparyk
in reply to: stuparyk

Hi @lee_griggs, just wondering if you had any other suggestions. Thanks!

Message 17 of 22
lee_griggs
in reply to: stuparyk

So it's either too bright or too dark? Did you add transmission visibility to the light?

This is what the Emily wet line shader looks like (without caustics).

lee_griggs_0-1688449662000.png

 

 

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 18 of 22
stuparyk
in reply to: stuparyk

Hi @lee_griggs. Yes, it's either too bright or dark. And yes, I added transmission visibility to the lights. Not sure what else to do here. The caustic settings are the same as your example above. The Sclera textures are 40mb each, maybe I could attach them to the test file I sent you? It might help reproduce the issue on your end? Thank you for your help.

Message 19 of 22
lee_griggs
in reply to: stuparyk

Try the Emily eyeball scene first.

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 20 of 22
stuparyk
in reply to: lee_griggs

Hey @lee_griggs, I tested the file on my machine and there are no issues with shadows or any artifacts. I don't get it, my transmission shader is exactly the same and I my sclera geometry just has sss. Thank you for your assistance.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report