Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Primvar AOVs in Solaris are not working.

2 REPLIES 2
Reply
Message 1 of 3
AlexOddbratt
107 Views, 2 Replies

Primvar AOVs in Solaris are not working.

I'm trying to create some simple AOVs that are reading primvars.
I can't get them to work and they just render black.

 

I've created a simple solaris scene where I have a sphere with a Cd and rest attribute.

I'm now trying to access these in a render var node using the primvar source type.

If I do a karma render the attributes work great but if i render with arnold they just come out black.

 

I'm sure I must be doing something wrong here and any help would be wonderful.

 

We are using:
- Houdini 19.5.752
- HtoA 6.2.4.0_r6fafaf5_houdini-19.5.752
- Windows 10

Tags (3)
2 REPLIES 2
Message 2 of 3

I tested Pref (rest) last week and it worked...



// Stephen Blair
// Arnold Renderer Support
Message 3 of 3
AlexOddbratt
in reply to: AlexOddbratt

So if I rename the default houdini rest attribute to Pref and use the builtin Arnold Pref AOV it works for me as well.

It's using the "rest" or "displayColor" primvar that doesn't seem to work.

 

Turns out doing some more testing that if I do a "direct USD render" with arnold it renders fine and the primvar aovs work in the exr file. But using husk or the arnold delegate in the viewport it just renders black.

So it seems that the bug might be limited to husk/delegate and not to sick/kick. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report