Community
Arnold for Houdini Forum
Rendering with Arnold in Houdini and Solaris using the HtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Arnold not rendering material Houdini Solaris

20 REPLIES 20
Reply
Message 1 of 21
Anonymous
1947 Views, 20 Replies

Arnold not rendering material Houdini Solaris

Hi,


I have an issue in Houdini / Solaris, where I am unable to get Arnold to render the material I have assigned to a piece of geometry.


  • Inside a LOP network I am using "sopimport" to import a basic cube

  • I am using the "material library" node with an "Arnold material builder node", which has a "standard surface" inside of it. The standard surface just have a constant color, no maps.

  • I am then then assigning the "Arnold material builder" node via an "assign material" node.


When I switch to Arnold renderer it renders white. If I do the exact same thing, but using a "principled shader" from Karma, I can see the material assigned when I switch to the Karma renderer.


Am I missing something here with Arnold, doing it the wrong way?


Arnold result:

7364-1592157505188.png




test file here: test.zip



I am using the following:

Houdini: 18.0.460

htoa: 5.3.0_r233605f_houdini-18.0.460


I also noticed that if go to Preferences > Rendering, I do NOT see the Arnold renderer in the list to choose from. Is this expected?


Any help would be appreciated!


cheers,

Klaus

Labels (5)
20 REPLIES 20
Message 2 of 21
Anonymous
in reply to: Anonymous

you need to add a light !

Message 3 of 21
pal.mezei
in reply to: Anonymous

Hi!

Rachid is correct, the scene is missing a light. If you set emission to 1 and emission color to any value, you can see the emission color showing up in the viewport.

However, there is definitely something we can improve here. When using Houdini GL, Storm or Karma, you can see a camera light lighting the scene. This is not supported in the Arnold render delegate, and is something we definitely should support.

I created a github issue for your problem: https://github.com/Autodesk/arnold-usd/issues/462

Cheers,

Pal.

Message 4 of 21
Anonymous
in reply to: Anonymous

Hi,


Thanks for the answers. I do actually have another scene where I had a light in it, however even in that scene it fails to render the mat. Also I tried putting emission on the material and I still get no material rendering.


I have uploaded a simple houdini scene below, would someone be willing to check if I have set it up correctly for Arnold? I guess it would be the same as for Karma? No extra Arnold specific things I need to do right?


test.zip


Perhaps my Arnold is not installed correctly? Should it be showing in the list in Preferences>Rendering ? I have the Arnold menu in top left, plus all the Arnold nodes showing when I hit TAB. Any other way I can check everything is working correctly?



arnold.jpg7367-arnold.jpg



Versions:

versions.jpg7369-versions.jpg


Message 5 of 21
Anonymous
in reply to: Anonymous

Hi,


Thanks for the reply. I do not think that is the issue here, as when I add a light it shows Karma still rendering just fine. If I use the same light in Arnold it actually doesn't even render the shadows of the light?


karma.jpg7365-karma.jpg


arnold.jpg7366-arnold.jpg


Perhaps my Arnold is not working at all? Is there a houdini scene that has a cube, with a material on it and a light that I can download from somewhere?



Message 6 of 21
Anonymous
in reply to: pal.mezei

hey, I had some replies pending mod review from last night and this morning. Would you be able to check please, as I don't think its a light issue. Thanks

Message 7 of 21
pal.mezei
in reply to: Anonymous

Hi!

Looking at your images, the material is not applied to the surface and you are seeing the default material of the render delegate.

I will need to do more tests to figure out what's going on. This is how your file looks locally after setting the distant light's normalize power to true.

7330-screenshot-from-2020-06-15-23-50-32.png

Cheers,
Pal.

Message 8 of 21
Anonymous
in reply to: Anonymous

Okay I literally just opened up Houdini and again and bam... Arnold is now rendering it correctly. Network is exactly the same as it was earlier.


arnold_working.jpg

Message 9 of 21
pal.mezei
in reply to: Anonymous

Could you please go to Help / About Houdini, click on Show Details then Save and share the resulting file?

Message 10 of 21
Anonymous
in reply to: pal.mezei

Hi,

No problem. File attached here:

Houdini_Info.txt



Message 11 of 21
pal.mezei
in reply to: Anonymous

Thanks! There is nothing obviously wrong with your environment setup. I was thinking it could be a second install of HtoA lingering around and causing a random behavior, but no luck.

I tried your scene again using 460 and the latest HtoA release, but the behavior was consistent for me, both on Linux and Windows.

Please let me know if you keep seeing this behavior in the future. One thing you could try is to reinstall HtoA and make sure the existing installation is completely removed from the disk.

Message 12 of 21
Anonymous
in reply to: Anonymous

Hi,


So this started happening again this morning. I had a scene going last night where Arnold viewport was showing everything fine, including materials and lights. I open up the same scene again this morning and it shows only white material again and no lights.


See screenshot here: whiteRender.jpg



Anything I can do my side?


Thanks,

Message 13 of 21
pal.mezei
in reply to: Anonymous

One thing I noticed in your Houdini Info, you have a USD 20.02 build setup in the environment. Most importantly, the 20.02 python libs are added to PYTHONPATH.

The shader translation from Houdini to Solaris happens using a python script shipped in HtoA (husdtranslators/arnold.py). This script uses some standard pxr modules, some of which could be overridden by the custom build in the PATH. Could you try removing entries of X:\technology\software\thirdparty\USD\USD-0.20.2 from your environment. Most likely it would be enough to get rid of the ones from PYTHONPATH and PATH.

Message 14 of 21
Anonymous
in reply to: pal.mezei

Hi,

Yep that could have been the issue. I have been able to render fine since removing those paths. I'll keep you updated in case it happens again and is not caused by the custom paths!


Thanks for your help again, much appreciated!


Message 15 of 21
pal.mezei
in reply to: Anonymous

Sounds good! Please keep us in the loop, if this issue resurfaces.

Message 16 of 21
kirene.vfx
in reply to: Anonymous

Hi,


I am also experiencing a similar problem here!

The interactive renders in the viewport and MPlay within the Solaris appears to be functioning correctly. The issue occurs when i am sending renders to the background - it either doesnt render correctly or doesnt appear to be taking into consideration the Solaris lights and Arnold material assignments.


The below example is using a dome light with a mapped hdr. I have created a MaterialLibrary node (Arnold material builder connected to a Collect node --> Surface Standard only with base color 1.0 / 0 / 0 and metalness 1.0) and subsequently used an AssignMaterial node.


Env file here -- Houdini_Info.txt

10340-img-001.png

img-002.png

Message 17 of 21
pal.mezei
in reply to: kirene.vfx

Hi!


I think our shader translator for Solaris fails to run when rendering in the background. That's a python script, and looking at your setup, you have C:\Users\ik\AppData\Local\Programs\Python\Python39\Scripts\;C:\Users\ik\AppData\Local\Programs\Python\Python39\ in your Path. Could you remove them from the global PATH and try again? Please let me know if that makes any difference.

Cheers,

Pal.

Message 18 of 21
pal.mezei
in reply to: kirene.vfx

I think I know what's happening in your scene. Go to the "rgb" LOP and set the "Format" parameter to match your "Data Type".


Something like this:

1623316354602.png

From the solaris documentation:

The data format that should be used when saving this image plane to the output file.


It's set to "float" by default, so a color rendervar gets converted to a grayscale color.

Message 19 of 21
kirene.vfx
in reply to: pal.mezei

Thank you for answering! I tried removing both the contents of C:\Users\ik\AppData\Local\Programs\Python\Python39\Scripts\ and the entire of C:\Users\ik\AppData\Local\Programs\Python\Python39 but Arnold shaders are still missing from the background renders.

Message 20 of 21
kirene.vfx
in reply to: pal.mezei

Thank you for answering! Have tried just the above (data type change) and also in combination with the removal of python scripts but the Arnold shaders still doesnt show up in final renders 😞

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report