Arnold for 3ds Max Forum
Rendering with Arnold in 3ds Max using the MaxtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cryptomatte and Z depth doesnt work

Message 1 of 6
220 Views, 5 Replies

Cryptomatte and Z depth doesnt work

Hi all,

so I am experiencing issues with my Maya scene when my rendered multi-layer EXR sequence has incorrect/ broken Cryptomatte and Z depth passes.



- they are set up from AOVs, nothing changed to its default settings (like this in the past it worked without issues)

- rendered with Render Sequence, its multiLayer EXR with Merge AOVs checked

- in Nuke when I try to use Cryptomatte to select either by object or by material, I see this: 




You can tell just by looking at it something's wrong. Selecting the car body selects also tyres, spoiler and background (while there is no background to start with, its a render layer of a car only). it happens with all render layers in the scene (car/env/etc...)... not to mention they are NOT the same material...


Z DEPTH issue:

- my Z depth comes out as solid flat color without any actual Z depth to it.. when I contrast/under expose my Z depth AOV to see the depth, its either flat or has only some weirds scanlines instead of actual Z depth...

- again, all settings are default I didnt change anything to it (as far as I am aware)




In previous scenes I used exactly same settings (as far as I am concerned) and I didnt have any of these issues so Im not sure what Im missing here. Im rendering on CPU

Specs: Maya 2023, Windows 10 64 bit, 64GB ram, RTX2080 8GB, rendered in ACES (as set by default)


Any suggestions as to what might be causing this ? Is it some bug or did I just screwed something in settings?


Thanks in advance

Message 2 of 6
in reply to: AdrianDudak

I don't remember seeing any issues like that. Do you have repro scene you can share?

Is there anything in the log? What else is in the scene (imagers, operators, ...) ?


If you render just Z, or just cryptomatte, are the both still broken?

// Stephen Blair
// Arnold Renderer Support
Message 3 of 6
in reply to: AdrianDudak

thanks for the reply. The scene is actually quite heavy to share, but perhaps I can try to reduce it to a minimal area. No it doesnt contains any imagers or anything like that


EDIT: but what I do have in the scene is quite a few alembic caches of animated characters


EDIT 2: I solved the Zdepth issue - it was read node's color space that caused the Z pass to go flat. Due to ACES workflow I was swtiching read nodes from Scene Linear to Output sRGB to match the look of my Arnold Render's view, but it doesnt solve the cryptomatte issue


EDIT3: removing Z and N AOVs to keep just cryptomattes as you suggested ddint help either

Message 4 of 6
in reply to: AdrianDudak

Here is the archived reduced scene, hopefully it will work on your end.


Apart from that I noticed another issue I forgot to mention (I dont want to start a new thread because something tells me this all has a common root) is that when I break my beauty pass in Nuke to diffuse/specular/coat/transmission and plus them all together, they dont match the beauty, there is a slight difference:


this is the actual difference: 


I checked my scene and I dont miss any other AOV such as sheen etc as I dont use those in my shaders... Any idea what might be causing this?




Message 5 of 6
in reply to: AdrianDudak

Just to be sure you get everything, can you try with
diffuse, specular, coat, transmission, sss, volume, emission, background

// Stephen Blair
// Arnold Renderer Support
Message 6 of 6
in reply to: Stephen.Blair

Hye, so after investigating further it seems like both issues were caused by color spaces, more precisely wrong output transform that was impacting Z and Cryptomatte passes. It all seems to work now

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators

Autodesk Design & Make Report