Visual LISP, AutoLISP and General Customization

Reply
Valued Contributor
Posts: 99
Registered: ‎05-17-2006
Message 1 of 2 (113 Views)

Workspaces and Partial CUI's

113 Views, 1 Replies
05-22-2007 10:14 AM
I have spent a couple of hours here trying to find an answer to my question and have not found an answer that made sense to me:
Why won't my partial CUI's load when I change Profiles and Workspaces?

I have two Profiles set up, Profile 1 and Profile 2, with Support Files Search Paths going two different places. That all works just fine.

Profile 1 is used with Workspace 1, which is set up for Company 1's standard menus and toolbars.
Profile 2 is used with Workspace 2, which is set up for Company 2's standard menus and toolbars.

In the Customize User Interface dialogue, Customize tab, Customizations in All CUI Files is set on All Customization Files. This is where I have my Partial CUI Files loaded. When I set up the Workspaces, Workspace 1 shows the partial CUI's for Profile 1, and Workspace 2 shows the partial CUI's for Profile 2. The problem is when I switch back-n-forth between the profiles and change the workspace, the respective partial CUI's for that particular combination don't load and I have to load them manually each time.

Is there a better way to set up the customizations so that the partial CUI's load when they are supposed too? What am I missing here?

This is pretty much the only time I really miss the old menu structure.

Sherri
*R. Robert Bell
Message 2 of 2 (113 Views)

Re: Workspaces and Partial CUI's

05-22-2007 10:26 AM in reply to: sfarris4310
A primary CUI file remembers the partial CUI files attached to it. What you
are describing is the old technique of menu swapping. That doesn't work so
well in CUI-land.

You have two options:
1) Keep both partials loaded and use workspaces to control what is visible
in the interface.
2) Create different main/enterprise CUI files, each that loads only the
partial CUI files you need.

--
R. Robert Bell


wrote in message news:5593980@discussion.autodesk.com...
I have spent a couple of hours here trying to find an answer to my question
and have not found an answer that made sense to me:
Why won't my partial CUI's load when I change Profiles and Workspaces?

I have two Profiles set up, Profile 1 and Profile 2, with Support Files
Search Paths going two different places. That all works just fine.

Profile 1 is used with Workspace 1, which is set up for Company 1's standard
menus and toolbars.
Profile 2 is used with Workspace 2, which is set up for Company 2's standard
menus and toolbars.

In the Customize User Interface dialogue, Customize tab, Customizations in
All CUI Files is set on All Customization Files. This is where I have my
Partial CUI Files loaded. When I set up the Workspaces, Workspace 1 shows
the partial CUI's for Profile 1, and Workspace 2 shows the partial CUI's for
Profile 2. The problem is when I switch back-n-forth between the profiles
and change the workspace, the respective partial CUI's for that particular
combination don't load and I have to load them manually each time.

Is there a better way to set up the customizations so that the partial CUI's
load when they are supposed too? What am I missing here?

This is pretty much the only time I really miss the old menu structure.

Sherri

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community