Revit Cloud Worksharing Forum
Welcome to Autodesk’s Revit Cloud Worksharing Forums. Share your knowledge, ask questions, and explore popular Revit Cloud Worksharing topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Central Files and UNC Paths

20 REPLIES 20
SOLVED
Reply
Message 1 of 21
john_nordmark1
6997 Views, 20 Replies

Central Files and UNC Paths

Hi,

 

Has there been a change in how Revit uses UNC patht in Central files? In 2014 and prior the central files always used the UNC-path when it was saved to a network drive, even if we have browsed via the mapped drive path. In 2015 we discovered that Revit uses the mapped drive path. Since we have a couple of offices whitch all have same drive letters mapped to different servers and we work in projects on other offices, it doesn't work so well in 2015. We have to make sure that the projects alwaty uses the UNC-path when they save their central models.

2014.png

From 2014

 

 

2015.png

From 2015

 

Any other who have experienced this?

 

Regards

 

John Nordmark

 

20 REPLIES 20
Message 2 of 21
thamizhz
in reply to: john_nordmark1

i think ur central file model currently not in proper location or server cant accessible. check ur path path now changed or not?
Message 3 of 21
john_nordmark1
in reply to: thamizhz

I don't really understand exactly what you mean but our Central models are located on an shared resource on our server. Yhe users have fully rights to the locations on the server and it has worked just fine on versions prior to 2015. It is not a major problem since it works just fine if, when we save the central model for the first time, browse via the UNC path to the right location.

 

My question was, since there seems to have been a change between the version, why I couldn't find any information about it.

 

Regards

John Nordmark

 

Message 4 of 21
Anonymous
in reply to: john_nordmark1

Hi John We are experiencing the same issue. I've come across this today after finally getting around to deploying 2015 and updates R2 Release 6 (just downloaded & but can't imagine that will help) Only to find that we can't make local files across the network because our drives are mapped differently. I've done a number of tests today and files in the same locations with 2014 are fine but the 2015 ones have the issue. I can't find any useful info on this at this stage and I can't see anything in the known issues or updates that have changed this. Hope to hear something soon otherwise I've just wasted weeks rolling out software we can't use. I would have thought I was late in deploying 2015 in which case I would expect many others to be having these issues too so I'm suspecting that it may have been one of the recent updates perhaps. Regards Mark

Message 5 of 21
Anonymous
in reply to: Anonymous

That was meant to read (just downloaded 7 but can't imagine that will help)
Message 6 of 21

Resource mapping has always been an issue with Revit and Worksharing when a given computer has been mapped to a resource differently than the computer used to create the central file. The underlying path (UNC) must be the same. With more recent versions of Windows it became possible to share a resource using a Named Location. It is also possible to map a drive using the IP address versus the share name.

 

Whenever this mapping inconsistency occurs the relatively recent feature Create New Local becomes disabled for the computer user(s) that is/are mapped differently than the user who created the central file to begin with.

 

When pressed on this the initial response from IT is usually "everything is the same, nobody is mapped differently." Inevitably, after pressing harder, they find a script file that was supposed to revise how things are mapped didn't run on the troubled computer or myriad other situations...ultimately it means you need to revisit every computer involved in the project to verify they are all mapped correctly, exactly the same way.

My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 7 of 21
Anonymous
in reply to: SteveKStafford

Hi Steve

 

Thanks for your response. Knowing you, your probably right, the curious thing is that we havn't experienced this issue in the past. Today I created Two test workshared files, one in 2014 and one in 2015 and put them in the same folder on the network. Then got a user from another office to try and open by creating a new local and found that they could not for 2015 but could for 2014. I repeated the test on another drive and location and with another user and found the same results.

We've been working like this for a long time and have only really had issues with linked files needing to be UNC but not a problem creating locals.

 

Anyway I'll continue to look into it and see if I come up with anything otherwise we'll probably need to have a batch files to remap peoples drives when working inter office.

 

Thanks again Steve.

 

Regards

Mark

Message 8 of 21

You wrote a user in another office so does that mean you are using Revit Server? I'm pretty sure can't mingle versions using RS so that may be the issue.
My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 9 of 21

Hi again,

 

Autodesk has made this an support case after I made my firs post about this.Haven't heard anything so far.

 

Mark - It seems that we have the same problems. All of our workstations are mapped with the same drive letters and we save all our projects to R:\. But R:\ are different depending on whitch office you are working. In 2014 an prior it hasen't been a problem to work with central files on an other office server since Revit always saved the UNC path. The users could eiher brows via the UNC path or they could map an other drive letter to that office recource. All worked just fine. But not in 2015. The solution I foud was to save the central file with the UNC path. Then the users could open it from the mapped path but it would still have the UNC path saved to it.

 

Steve - Yes, we uses Revit Server, but only in one project. There is no problem with the central models on the Revit Server. It works just fine. The problem is linking. Now we uses UNC paths all over just to mak it work for everybody.

 

/John

Message 10 of 21
Anonymous
in reply to: john_nordmark1

Are y'all using DFS? We actually have the opposite problem here since we are still on Revit 2014, our IT manager has everything mapped using DFS which causes hell for worksharing between physically separate offices.
Message 11 of 21
john_nordmark1
in reply to: Anonymous

No DFS for our project shares. Isn't DFS for syncing files between different servers? In our company every office has it's own fileserver for their projects. The client machines is mapped the same for every machine in the company, R:\ for projects. But R: points to different server share depending on whitch office you work.

 

/John

Message 12 of 21

And that is precisely the problem, different resource but mapped with the same drive letter. I don't know why you've only run into this with 2015 but it has always been an issue. Perhaps the project was created by a user whose computer was configured differently at the time or maybe Autodesk will find a bug?
My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 13 of 21

Take look at the images in the first post. That is how it looks like for us. They show central models created exactly the same way in both 2014 and 2015, browsed via the mapped drive (in that case Z:\).

 

In 2014 when we save our central models, even if we browse via the mapped drive, the central model shows the UNC path for the Central Model Location. In 2015 it doesn't work like that. The central model shows the mapped drive path for the Central Model Location.

 

Since Autodesk created a support case after I posted on the forum I hope they are looking to it.

 

/John

Message 14 of 21

Ok I can confirm that 2015 is doing something differently so you are not crazy, at least not about this. In chatting with a friend about it we suspect this may have something to do with the recent development of A360 and Collaboration for Revit (C4R). That's probably why Autodesk has replied, they realized that something internal may be involved.

 

Fwiw, I find that I can get Revit to focus on the UNC path, as it should, if I use the Browse option in the Synchronize with Central dialog and select the file via the shared path instead of the drive letter path. It is important to do that before any users get into the project though. I'd be interested to see if you can get it corrected this way too.

 

Edited: Okay, I was logged into A360 during my testing. When I logged out of A360 I got the UNC path saved as I expected. It seems to be important to make sure you are not logged into A360 when you create a central file that won't be used with that service.

My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 15 of 21

Me again...

 

I find that Revit 2015 is sensitive to how the path is established. Disregard my A360 comments added to the previous reply, it doesn't seem to factor into the following observations.

 

Saving the File to Create the Central File:

via My Computer and selecting the mapped Drive letter: Revit stores the drive letter path (wrong, not desired result)

via My Network and selecting the shared resource: Revit stores the UNC path (correct desired result)

via My Computer > manually typing in the shared resource name (for example: \\MyServer\Projects): Revit stores the UNC path (correct desired result)

My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 16 of 21
Anonymous
in reply to: SteveKStafford

Still Looking into this.

 

John it sounds like out set up is essentially the same R is projects but R is a different server in each offices. In the past the only issue this has caused was linking files but we could type the UNC path in the link and it was fine.

Thinking back to one of the first 2015 project we started in 2014 approx 12 months ago and then eventualy upgraded maybe 5 months ago we didn't have this issue with someone accessing it from another office. I'v egone back to that file today and had that person try to access it again and it's fine.

I've done some more tests today just making new files on my local project server (same location as that project that does work) and found the following:

sync 2013 from 2013.jpg

above: file sync path from a 2013 file still in 2013 (UNC and works fine)

sync 2013 upgraded to 2015.jpg

above: file sync path from detached 2013 file from above upgraded to 2015 (now uses drive letter but same location)

2014 sync from 2014.jpg

above: file sync path from 2014 file still in 2014 (UNC and works fine)

Sync 2014 in 2015.jpg

above: file sync path from detached 2014 file from above upgraded to 2015 (now uses drive letter but same location)

2015 Sync.jpg

above: file sync path with new 2015 file in 2015

sync older file in 2015.jpg

above: Oddly however this is the path when syncing an older file that was started in 2014 and then upgraded to 2015 but upgraded before the Revit 2015 updates where installed. (not entirely sure what updates may have been done back then.) I guess this was created in a way which utilsed the UNC path and continues to be ok.

 

I've tried reinstalling 2015 on a machine up to update 3 thinking that perhaps one of the latest updates has been the cause but still have the same issue with it not using the UNC path.

 

So there is clearly a difference in the way 2015 is generating a central file path, as seen from those tests today where all were made the same way in the same location (being my local projects folder) and you can see 2015 is not reading the UNC.

 

Reluctantly I will have to work on a work around to ensure central files are created through the server name etc so others from other offices can access. (one option seems to be, each time a file for Sydney needs to be made, get someone in Melbourne to make it. Then it's file path is UNC but this is not overly practical)

 

I would still like an explaination from Autodesk as to what has changed and why.

We're not on Revit Server either just to cross that off the list.

 

If I find any more discovering regarding this I'll keep you posted.

 

Regards

Mark

 

 

 

 

Message 17 of 21

I believe I explained what is different, how the path is "browsed", the specific clicks, which folders, shortcuts etc were clicked on to get to the path.

I can't explain why it is different just what is different between 2014 and 2015.
My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 18 of 21


Hi all,

Much as described in the very first post, this behavior change in the 2015 release has already been reported, and identified as needing correction, to behave back as it was in previous releases. Plans are to have this corrected in the upcoming release.

 

Francisco



Francisco Eloy
Message 19 of 21

Thanks Francisco, that will be a welcome change.

My other older self here: http://forums.autodesk.com/t5/user/viewprofilepage/user-id/46056
Message 20 of 21

Hello All, I've got 30+ tabs open on this subject at the moment and this seems to be the only place with half decent discussion..


Firstly, Which is the 'correct' path.  Mapped Drive or UNC?  I would have thought it would be Mapped drive, just easier for the user to understand.  I accept that some network environments may setup differently.  


Also would it make sense to be Mapped Drives as the manage links uses that solution if you're in a Mapped Drive environment.  As seen below (terrible cropping due to sensitive info) I have the confusion of the links being relative but showing the full path as the central model is UNC.  Even though the Central model was created via the Mapped Drive?...

 

I would have also thought that it would work either via Mapped or UNC by the way the user interacts?  

 

Currently using R2016 update 7 R2 and mixed Windows 7 & 10

Capture Manage Links.PNGCapture Sync.PNG

 

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report