Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

July 12, 2019 Product Update Breaks McMaster-Carr Imports

14 REPLIES 14
Reply
Message 1 of 15
Careless_
1792 Views, 14 Replies

July 12, 2019 Product Update Breaks McMaster-Carr Imports

I just tested this numerous times, also with deleting program cache from the help menu at the top right corner.

 

Simple steps to recreate:

 

  • Create New Project
  • Create New File
  • Save as Untitled 1
  • Insert Component from McMaster-Carr
  • Select any item (literally anything, I tried 6 random fasteners and items)
  • Select 3D STEP in the drawing menu
  • Save
  • F360 CRASH window appears and closes program.

I tried importing into existing projects first, that wouldn't work. I tried importing the same M12x1.0 18-8 Stainless Jam nut (91938A160) and that didn't work 3 or 4 times. I then tried to import it into a new file. Still crashed. Then again into a new project in a new file. Crashed again.

 

It seems I can't import anything from McMaster-Carr since the July 12, 2019 Product Update.

 

Also, the input box for searching items in the McMaster-Carr modal box that pops up is STILL not fixed, and requires you to right click on the search bar, and press escape in order to actually be able to type into it.


I've tried this now on multiple macOS computers, both Mojave and High Sierra, and you still cannot just directly click on the search box. It just keeps greying itself out.

 

The search bar bug has been a longstanding issue since the McMaster-Carr import feature was implemented, but the importing bug itself is new as of today for me.

14 REPLIES 14
Message 2 of 15
jhackney1972
in reply to: Careless_

This must be an issue with Fusion 360 on a MAC, I have no issue replicating your process on Fusion 360 running on Windows 10.


"If you find my answer solved your question, please select the Accept Solution icon"

John Hackney
Retired

Beyond the Drafting Board


Message 3 of 15
Phil.E
in reply to: Careless_

@Careless_ 

This problem is a known issue that we are working to fix. It affects only mac.

 

The workaround is to download the parts from McMaster-Carr using their web page, and then upload them to your project for use in your models.

 

Sorry for the inconvenience, this is a top priority issue for us.





Phil Eichmiller
Software Engineer
Quality Assurance
Autodesk, Inc.


Message 4 of 15
Careless_
in reply to: Phil.E

sounds good.

 

will there finally be a fix for the search input field so that we don't have to fumble with clicking and right clicking and trying to get it to accept a keyboard cursor?

Message 5 of 15
Phil.E
in reply to: Careless_

I've not heard of or seen this issue. Can you post a screencast video so I can see the clicks you are missing?





Phil Eichmiller
Software Engineer
Quality Assurance
Autodesk, Inc.


Message 6 of 15
Careless_
in reply to: Phil.E

It is not the first time you've heard about it, as you had replied to my previous attempt at getting closure on this bug before- but no viable solution or fix was implemented, and it was forgotten:

 

https://forums.autodesk.com/t5/fusion-360-support/mcmaster-carr-import-causes-program-lock-up/m-p/82...

 

On macOS High Sierra & Mojave, when opening the McMaster-Carr window to insert an item, clicking on the search bar does not focus on the input field.

 

You need to fumble around and click multiple times, or right-click on the input field and press the escape key to clear the right-click context menu in order for the keyboard cursor to appear in the search input field.

 

Sometimes it takes multiple attempts. Even the escape key trick does not work all the time. 

Message 7 of 15
Careless_
in reply to: Careless_

Just saw the July 19 Update. Seems that McMaster Importing is fixed (thanks a ton! what a relief!)... but the focus on the search bar is not fixed.

 

This happens on both my macOS Mojave and High Sierra computers:

 

Here is a link to a screencast. It's fairly straight forward. Left clicks don't register well. Right-click and then ESC key works more often, but still not always:

 

<iframe width="640" height="620" src="https://screencast.autodesk.com/Embed/Timeline/c2d72251-ca73-4433-9a93-019c0d408754" frameborder="0" allowfullscreen webkitallowfullscreen></iframe>

Message 8 of 15
Careless_
in reply to: Careless_

Has there been any investigation into this issue?
I've posted a screencast- and yet no response...

Message 9 of 15
Careless_
in reply to: Phil.E

still no response on this issue after posting a screencast and posting about it a long time ago.

this bug is annoying.

Message 10 of 15
Anonymous
in reply to: jhackney1972

It also has issues running Windows 7.  When using the INSERT feature and you try to save file in mcmaster carr the current selection is 3d solidworks.  It is locked up and will not allow you to change it to a STEP file download.  I also tried going to mcmaster carr direct and downloaded the STEP files to my computer and uploaded them to my fusion 360 file.  This worked for about 8 or 10 uploads.  Now when I try to upload a step file into my project it gets about half way through and fails.  One of the original step files that I uploaded got corrupted.  I tried deleting joints that used that corrupted uploaded file and things got worse and I finally gave up and deleted the project.

Message 11 of 15
Anonymous
in reply to: Phil.E

I am running windows 7.  The work around of downloading a STEP file direct from mcmaster carr and uploading to my project worked for about 8 to 10 items and then had issues with one of the uploads and now when I try to save STEP file directly from mcmaster carr and try to upload it freezes about half way through and the upload fails.

Message 12 of 15
Anonymous
in reply to: Anonymous

Now this morning try the direct import of a step file from mcmaster carr and it works.  Don't understand what is going on here.

Message 13 of 15
HughesTooling
in reply to: Anonymous

The job status icon has an orange dot on it at the moment indicating there are problem with cloud services. seems to be import\export. When the dot is remove you should be able to upload.

image.png

Mark

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 14 of 15
Anonymous
in reply to: HughesTooling

Many thanks for the excellent tip.  Didn't think to look there and didn't realize the meaning of the orange dot. I am definitely a novice and new to Fusion 360 so all help is appreciated.  One minute is was working and the next it was not.  I thought the file got corrupted and deleted it out of frustration.  A lot of work down the drain, but I needed the practice on applying joints.  Ha Ha  Made my first resolute joint and set the min-max limits.  I am making an assembly with several parts and a lot of joints i.e. installing mcmaster carr hardware.  My goal is that I have some articulating arms on this project that I want to show movement on when I get it done.   I really like fusion360 but lately it has been giving me a hard time.

Thanks again, because your tip informed me to probably what has been causing me a lot of grief.

John

Message 15 of 15
Careless_
in reply to: Careless_

I have uploaded a screencast of the McMaster search box issue and have brought it up in another thread before, and still no response from the F360 dev team. 

This bug is really annoying and sometimes makes importing from McMaster a chore, as I cannot directly focus the keyboard on the search function.

Please provide a status update.

 

Here is the screencast:
<link removed due to privacy concerns>

 

Here is the other thread where I've mentioned it already:

https://forums.autodesk.com/t5/fusion-360-support/mcmaster-carr-import-causes-program-lock-up/m-p/82...

 

Edit: I removed the screencast and its link because it publishes my name in the top right of the screen. I will repost the screencast at a later date with my acct name changed.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums