Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How can i change my live tooling S code? PostProcessor

21 REPLIES 21
SOLVED
Reply
Message 1 of 22
mxdawg121
832 Views, 21 Replies

How can i change my live tooling S code? PostProcessor

We have a Swiss lathe here, with a mitsubishi m800 control. Quite the funky control when it comes to gcode. The live tooling requires an M113 S3=2000 , to turn on the live tooling. Is there a quick way to edit the post to make it S3=2000 instead of S2000

 

Im using a doosan lathe post currently , its the closest thing i have to a working post, and it required a bit of tinkering to work. This is one of the last things i have left to make this a mostly working solution until a post is made for this machine.

 

Also getting way undersized radius's when im doing a helical interpolation on the live tooling side. Any input there would be much appreciated.

21 REPLIES 21
Message 2 of 22
serge.quiblier
in reply to: mxdawg121

Hello @mxdawg121 

 

Search at the beginning of your post for the line:

 

var sOutput = createVariable({prefix:"S", force:true}, rpmFormat);

 

 

Add another line :

 

var s3Output = createVariable({prefix:"S3=", force:true}, rpmFormat);

 

 

This will define a specific formating when outputting the spindle speed for the live tools.

We now need to instruct the post to use this formatting when needed.

 

When we are using the sOuput variable, we may need to alter the code as in this modified function

 

function onSpindleSpeed(spindleSpeed) {
  if (rpmFormat.areDifferent(spindleSpeed, sOutput.getCurrent())) {
    writeBlock(
machineState.liveToolIsActive ? s3Output.format(spindleSpeed): sOutput.format(spindleSpeed));
  }
}

 

 

Depending if the section is using a live tool or not we switch the format used.

 

Below in the code,

In the StartSpindle function:

 

  writeBlock(
    gSpindleModeModal.format(spindleMode),
    machineState.liveToolIsActive ? s3Output.format(spindleSpeed): sOutput.format(spindleSpeed));
    spindleDir,
    spOutput.format(getCode("SELECT_SPINDLE", getSpindle(TOOL)))
  );

 

 

In the StopSpindle function :

After the sOutput.reset();,

Let’s add another line with

S3Output.reset();

 

Regards.

 


______________________________________________________________

If my post answers your question, please click the "Accept Solution" button. This helps everyone find answers more quickly!

 

 



Serge.Q
Technical Consultant
cam.autodesk.com
Message 3 of 22
BrandonTBFBF
in reply to: mxdawg121

I hacked out pieces from the post I sent you and put them in this.

Message 4 of 22
mxdawg121
in reply to: mxdawg121

Thanks guys, both of those worked. It works perfect now!

 

Message 5 of 22
mxdawg121
in reply to: mxdawg121

Ah, guess I spoke a little too soon. 

with the first method, it won’t apply the prefix to the first live tooling operation , but will with the following live tooling operations. Does it check if it’s live tooling after declaration of prefix?

 

could this be modified to check before deciding which prefix to use on the first live tool operation?

 

the second method works as expected except the post thinks a static drill is a live tool. The way I read it is, is turning tool true/false then {  the drill isn’t considered turning tool, or live tool from what I gather. 

could this be modified with an or statement? Tooltype drill || turning? 

Message 6 of 22
BrandonTBFBF
in reply to: mxdawg121

I just tried the post I attached and it worked fine. Are you sure the hole you're drilling is on center? Check your setup.

Message 7 of 22
mxdawg121
in reply to: BrandonTBFBF

This is what it outputs on my end - 

M8
2000 M113
G0 C0.
 
missing prefixes on all the spindle lines it appears
 
Message 8 of 22
BrandonTBFBF
in reply to: mxdawg121

Attach your file.

Message 9 of 22
mxdawg121
in reply to: mxdawg121

Here you go, thank you for taking a look brother.  really appreciate it.

Message 10 of 22
BrandonTBFBF
in reply to: mxdawg121

Can you attach the F3D file.

Message 11 of 22
mxdawg121
in reply to: BrandonTBFBF

yes, here it is.

 i never got to op2. got hung up here.

Message 12 of 22
BrandonTBFBF
in reply to: mxdawg121

This is what I'm getting:

 

N1(DRILL2)
G0 G28 G53 B0. (SUB SPINDLE RETURN)
G28 U0. V0.
G28 W0.
G54
G99 G18 M39
T1414
M8
S1=1500 M3
G0 Z-0.6
X0. Y0.
Z-0.2
Z-0.08
G1 Z0.35 F0.005
Message 13 of 22
mxdawg121
in reply to: BrandonTBFBF

I see, maybe i didnt have the correct post loaded. but i just loaded it. Seems like it puts s3= for everything - live or not. something easy to fix?

 

Message 14 of 22
BrandonTBFBF
in reply to: mxdawg121

This is the post I used.

Message 15 of 22
mxdawg121
in reply to: BrandonTBFBF

And your getting regular Scodes on turning ops and S3=codes on live tools? ugh what am i doing wrong here. Im a mill guy, just got throw onto a lathe. a swiss nonetheless.

 

Message 16 of 22
BrandonTBFBF
in reply to: mxdawg121

This is the program it's spitting out.

 

I feel your pain. I'm a standard lathe guy that got thrown a Swiss and it's still a headache.

Message 17 of 22
BrandonTBFBF
in reply to: mxdawg121

Do you have axial live tools on this machine?

 

If so, I'd ditch that deburr toolpath, model a chamfer on that end and use blend. Multi-axis feedrates are almost always wrong in the base post processors. It took me hours of work to get them corrected in my Swiss post.

Message 18 of 22
mxdawg121
in reply to: BrandonTBFBF

okay, so your getting the same thing i am. The regular operations should be standard m3's and they all come out in the live tool format

 

Message 19 of 22
BrandonTBFBF
in reply to: mxdawg121

What do you mean "standard M3s"? I'm seeing M3 for all the turning operations and the static drilling operation. The live tools are using M113.

Message 20 of 22
mxdawg121
in reply to: BrandonTBFBF

Im sorry , i meant Scodes 

 

 

T0202
M8
G97 S1=1000 M3
 
Should be 
T0202
M8
G97 S1000 M3

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report