AutoCAD Map 3D Forum
Welcome to Autodesk’s AutoCAD Map 3D Forums. Share your knowledge, ask questions, and explore popular AutoCAD Map 3D topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Map 2012 Coordinate system files missing

20 REPLIES 20
SOLVED
Reply
Message 1 of 21
Anonymous
7569 Views, 20 Replies

Map 2012 Coordinate system files missing

 

  I'm working with 2012 now, and trying the new coordinate system tools, but it doesn't look like everything's installed correclty. I get an unhandled exception, and it tells me the specified file was not found:  Datums.CSD. I'm assuming the datum files didn't install correctly - when connecting to FDO data sources (Shape files) with a projection file, I'm getting an error that it's an unknown projection file (common projections).

  Dows anyone know were the new projection files are stored in 2012, or know of a cause for this?

  Thanks,

  Rick

20 REPLIES 20
Message 2 of 21
Anonymous
in reply to: Anonymous

  It's interesting - the datum files do exist in the common folder where the previous versions are. Now I have 2 different installs where the datums can't be found, and 1 that installed and works correctly.

 

Message 3 of 21
Anonymous
in reply to: Anonymous

Good afternoon,
then finally getting work for you coordinate systems? How?

I can not do anything that works for the assignment of coordinate systems, there is a fatal error!
Any help is welcome

Message 4 of 21
andram
in reply to: Anonymous

I had to completely uninstall all previous versions of Map, and that included deleting all Autodesk folders found in

 

Program Files

Program Files/Common Files

And if using 64-bit Windows:

Program Files (x86)

Program Files (x86)/Common Files

ProgramData (usually hidden, so you'll have to set Windows Explorer to view hidden files/folders)

Message 5 of 21
andram
in reply to: Anonymous

Oh, you'll have to uninstall 2012 as well, remove all the AutoCAD Map folders, and reinstall 2012.

Message 6 of 21
Anonymous
in reply to: Anonymous

I, in the end I made a clean uninstall and also disable the antivirus during installation ... Prevented the loading of some libraries it seems. Now it works! Thank you for your help!

Message 7 of 21
Anonymous
in reply to: Anonymous

  I tried the uninstall of all Autodesk products, but had no luck. After trying a few times, I noticed I still had MapGuide OS installed. I included that in the uninstall, and the next reinstall worked.

  During the unsinall, I made sure to eliminate any Autodek entries in the registry. CCleaner helped with that.

  Rick Chappell

  http://www.cadsoft-consult.com/blogs/geo/

 

Message 8 of 21
Anonymous
in reply to: Anonymous

If you have Project Galileo installed, uninstall that as well and do reinstall and will be fine.

 

Thanks,

 

Andre

Message 9 of 21
Anonymous
in reply to: Anonymous

  The machine I had the problems with didn't have Gallileo installed. I'm glad that worked for you. If I run into it again, I may just try that first.

  Rick CHappell

  http://www.cadsoft-consult.com/blogs/geo/

Message 10 of 21
Anonymous
in reply to: Anonymous

My problem stated that when trying to assign a coordinate system it could not find the Datums.csd file.  Through discussions the Autodesk customer support it was determined that the problem arose because I had previously installed Open Source Mapguide Server and Maestro.  These programs set an environment variable "MENTOR_DICTIONARY_PATH" to F:\Program Files\OSGeo\MapGuide\CS-Map\Dictionaries.  Unfortunately the install of AutoCAD MAP 3D 2012 recoqnized this and tried to use this directory for the coordinate system files when it should be using the following directory C:\Documents and Settings\All Users\Application Data\Autodesk\Geospatial Coordinate Systems.  My solution was to rename the environment variable "MENTOR_DICTIONARY_PATH" to "OLD_MENTOR_DICTIONARY_PATH".  I then created a new environment variable named "MENTOR_DICTIONARY_PATH" with the following value C:\Documents and Settings\All Users\Application Data\Autodesk\Geospatial Coordinate Systems.  This solved my problems.

 

The full text of the final discussion with the Autodesk Technical support is below, as it provides more detail than the above description.

_______________________________________________________________________________________________________

Thank you very much for your message, the error details, the screenshots, and the NFO file.

The reason why I wanted the NFO file is because it shows the environment variables that are active on your computer as well as the values of those environment variables.

Your computer has an active environment variable called MENTOR_DICTIONARY_PATH, as you can see in the screenshot I made (after loading your NFO file into the System Information utility) and placed at this address:

http://screencast.com/t/h3SlnCDbLI

I believe that MENTOR_DICTIONARY_PATH was created automatically when you installed MapGuide Open Source. The value of MENTOR_DICTIONARY_PATH defines the path to the folder in which the coordinate system definition files for MapGuide Open Source are stored. (Currently, MENTOR_DICTIONARY_PATH has a value of F:\Program Files\OSGeo\MapGuide\CS-Map\Dictionaries on your computer.)

If you were to install AutoCAD Map 3D 2012 onto a computer on which MapGuide Open Source is not installed, MENTOR_DICTIONARY_PATH would not get created.

But it turns out that even though AutoCAD Map 3D 2012 does not create the MENTOR_DICTIONARY_PATH environment variable, AutoCAD Map 3D 2012 will recognize MENTOR_DICTIONARY_PATH if it already exists.

This recognition of MENTOR_DICTIONARY_PATH is undocumented, and I am sorry about that. The reason for this behavior is that the coordinate system technology in both AutoCAD Map 3D and MapGuide was originally devised by Mentor Software, which Autodesk acquired. (The blog post at http://geospatial.blogs.com/geospatial/2008/08/autodesk-contri.html has some background information.)

It appears that what is happening on your computer is that AutoCAD Map 3D 2012 is reading the MENTOR_DICTIONARY_PATH variable and is looking inside F:\Program Files\OSGeo\MapGuide\CS-Map\Dictionaries for the coordinate system definition files that it needs, instead of looking where those files actually are — C:\Documents and Settings\All Users\Application Data\Autodesk\Geospatial Coordinate Systems (and/or Geospatial Coordinate Systems Temp2012).

To resolve the issue in AutoCAD Map 3D 2012, please take these steps:

  1. Close AutoCAD Map 3D 2012.
  2. If MapGuide Maestro is running, please close it too; and if the MapGuide Open Source service is running, please stop it.
  3. Open the System item in the Control Panel.
  4. In the System Properties dialog, click the Advanced tab.
  5. In the Advanced tab, click the Environment Variables button.
  6. In the Environment Variables dialog, select MENTOR_DICTIONARY_PATH (in the System Variables section).
  7. Click Edit.
  8. In the Edit System Variable dialog, change the name from MENTOR_DICTIONARY_PATH to OLD_MENTOR_DICTIONARY_PATH (and leave the value intact).
  9. Click OK to close the Edit System Variable dialog.
  10. Click OK to close the Environment Variables dialog.
  11. Click OK to close the System Properties dialog.
  12. Open AutoCAD Map 3D 2012.
  13. Test whether you can assign global coordinate systems to drawings. Please reply to this message with that information.


Because my colleagues and I here in Product Support only have Autodesk MapGuide Enterprise installed and do not have MapGuide Open Source installed, I have not been able to test whether the steps above will affect MapGuide Open Source. (Autodesk MapGuide Enterprise does not create the MENTOR_DICTIONARY_PATH variable.) So after you have completed the steps above, please take these steps:

  1. Close AutoCAD Map 3D 2012.
  2. Start the MapGuide Open Source service, and open MapGuide Maestro.
  3. Test whether you encounter any issues with coordinate systems. Please reply to this message with that information.


If you do encounter issues with MapGuide Open Source, then you should be able to resolve them by stopping the service, changing the name of OLD_MENTOR_DICTIONARY_PATH back to MENTOR_DICTIONARY_PATH, and restarting the service. Of course, then you will have the same problem in AutoCAD Map 3D 2012 again, unfortunately, until you change the name of the variable back to OLD_ MENTOR_DICTIONARY_PATH. You might wish to test whether leaving the name as MENTOR_DICTIONARY_PATH and setting the value to C:\Documents and Settings\All Users\Application Data\Autodesk\Geospatial Coordinate Systems will allow both products to work without any issues.

Dan

Message 11 of 21
Anonymous
in reply to: Anonymous

Excellent. Thanks for sharing!

Message 12 of 21
Anonymous
in reply to: Anonymous

I have installed Civil 3D  2012 and I have the same problem with the coordinate system library. I have already created the new environment variable but the problem still persist. I must say that when I go to the system properties menu I can´t find any variable named MENTOR_DICTIONARY_PATH so I create one with that name and the value C:\Documents and Settings\All Users\Application Data\Autodesk\Geospatial Coordinate Systems. However I'm having the same problem and appreciate if you colud help me.

 

P.D. Sorry for my english

 

David Marin Trujillo

Message 13 of 21
andram
in reply to: Anonymous

Hi David,

 

You will have to do a clean uninstall of all Autodesk products including Civil 3D, and clean out your registry of all Autodesk entries. See the solution to this thread written by Rick Chappell.

Message 14 of 21
Anonymous
in reply to: andram

Thanks andram. But what about if I want to maintain my old installations of Civil 3D 2010 and 2011?

 

David

Message 15 of 21
Anonymous
in reply to: Anonymous

The MENTOR_DICTIONARY_PATH (MDP) varible is created for the MapGuide Installation.  My Map3D 2012 tried to use the coordinate system files associated with Mapguide in the MDP path.  Since your conflict is with Civil 3D you may be having a somewhat different conflict, ie your problem isn't with the MDP path since it never existed on your system until you created it.  In the following directory "C:\Documents and Settings\All Users", I have 6 different folders with varied names regarding the Geospatial Coordinate Systems.  It sounds to me like the software you installed last (MAP3d guessing) is trying to use the existing Civil 3D coordinate system folder and thus it is unable to find the "Datums.CSD" file.  I am no expert though, so please take my suggestions with a grain of salt.

Message 16 of 21
andram
in reply to: Anonymous

Unfortunately, you won't be able to reinstall 10 or 11 and have all three work properly. At least not that I've discovered.

Message 17 of 21
Anonymous
in reply to: Anonymous

Well this worked for me. The issue here is a simple conflict of file folder names and newer code it appears. I cant believe all these people that have been installing and reinstalling over and over. That is just crazy to reinstall everything and uninstall everything just because a folder has a naming conflict. All you should have to do is go to the following location:

 

C:\Documents and Settings\All Users\Application Data\Autodesk

 

Most likely if you have multiple installations of civil 3d, you will see the folder Geospatial Coordinate Systems and then several others with the same name and Temp at the end or Temp2012. Civil 3d 2012 is looking for the folder that does not have the temp2012 at the end, despite having created that folder itelf. This is a simple bug and the programmers need to fix it.

 

You can take the existing folder named "Geospatial Coordinate Systems" and simply add the word OLD to the end of it. Now, I made a copy of the one that 2012 created (on my computer it was named Geospatial Coordinate System Temp2012). Then i reneamed the copy to what 2012 is looking for: "Geospatial Coordinate Systems". You probably dont need to make the copy but can simply delete the "Temp2012" part, but i retained it. Now it should work for you. I am not sure how that will affect your older versions of cad, but you can at least go in and rename the folders again if you need to use 2010 or 11. At least this way you dont go through the hassle of reinstalling everything and needing to uninstall your previous versions because of a simple folder name conflict that can be fixed in about 45 seconds.

Message 18 of 21
Anonymous
in reply to: Anonymous

I tried what you suggested, but it did not work for me. I will keep trying though because I do not want to have  to reinstall all of my software. Anyone else find alternate solutions?

Message 19 of 21
LeafRiders
in reply to: Anonymous

Seriously this hasn't been fixed with SP1?

 

I have the same issue with Civil 3D 2012. Basically an expensive paper weight as we speak. I cannot define the coordinate system, the list that was available in 2011 and previous is not available. When I type anyting into the GUI there is an immediate Fatal Error.

 

I don't recall these things ever being an issue in past versions. I guess our IT department will send Autodesk the bill for 100s of computers they need to fix with 1-2 hours of IT work... Or i'll uninstall everything, cleanup all the registry files and proceed to reinstall 2011. Since my subassemblies also failed to install within Civil 3D 2012.

Message 20 of 21
Anonymous
in reply to: Anonymous

Renaming the folder and restarting C3D did it for me..everything came right back..Thanks!!!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


”Boost