Community
AutoCAD Forum
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

AutoCAD 2016 mc3.dll / mc3d.dllARX Command Error

94 REPLIES 94
SOLVED
Reply
Message 1 of 95
sguinan
13091 Views, 94 Replies

AutoCAD 2016 mc3.dll / mc3d.dllARX Command Error

Upon opening a drawing in AutoCAD Architecture 2016 I get the error Exception in mc3.dll / mc3d.dll ARX Command. Unhandled Exception C0000005 (Access Violation Reading 0x0000) at Address C9C860F4h I am running windows 7 and Autocad is completely up to date. This randomly started happening after windows forced close the application to restart
94 REPLIES 94
Message 2 of 95
sguinan
in reply to: sguinan

I tried to repair installation with no success.

Message 3 of 95
sguinan
in reply to: sguinan

After hitting OK the AutoCAD Error Aborting message says: FATAL ERROR: Unhandled Access Violation Reading 0x0000 Exception at cb1060f4h

Message 4 of 95
sguinan
in reply to: sguinan

Then a screen pops up saying AutoCAD Error-abort: Error handler re-entered. Exiting now.
Message 5 of 95
jesse.russell
in reply to: sguinan

I'm having this same exact issue as well.  My entire company to be exact.  Mix of Win10, 8, & 7 all 64bit.  AutoCAD MEP 2016 Service Pack 1.

 

This is bringing our entire production to a screeching halt.

Message 6 of 95

I know it's a reply to myself, but it seems that anyone that has updated to Service Pack 1 has the issue.

Message 7 of 95
Anonymous
in reply to: sguinan

I am having the same issue! I completely unistalled all 2016 software and restarted the machine many times and completely reinstalled.  Now OOB it is still giving me the error!  I did install the Service Pack 1 and it gave me the error before and after the install.

 

Now what do we do?!

Message 8 of 95
pgraf
in reply to: sguinan

Chiming in here - I'm having the exact same issue right now. It started between 10 and 11 this morning.
Message 9 of 95
sgallant-P_2137
in reply to: sguinan

same problem here: all the computer in my company equiped with mep 2016, sp1 or not, have the MC3D.dll error ! the problem arrive here in Quebec, Canada this morning exactly on november 5.

Message 10 of 95
Anonymous
in reply to: sgallant-P_2137

I should have mentioned this too - I am using ACA 2016.  It started for me about 7-7:30 CST.

 

Of course, there is a deadline tomorrow! Smiley Mad

Message 11 of 95

After a little more research it does affect any installation of AutoCAD 2016, regardless of service pack install.  A current possible fix for us so far has been to replace the mc3.dll on local machines with mc3.dll found within the installation/deployment folder.

 

I'll update more with more testing.

Message 12 of 95
nicwalte
in reply to: sgallant-P_2137

we are having the same issue.   could it be a microsoft .net 4.5.1 or a .net 4.5 issue?

Message 13 of 95

Seems the temporary fix is easier than expected.  We simply renamed the mc3.dll file to something different (mc3.dll.bak in our case) and AutoCAD repopulates this file on its own.  I only say temporary fix because this is a blatant Autodesk issue and they should have a real fix coming soon.

Message 14 of 95
rob.reuland
in reply to: nicwalte

I installed SP1 and the issue seems to have stopped.  

Message 15 of 95
jesse.russell
in reply to: rob.reuland

Just wait, it will come back.  We have done it all: Update to SP1, failed eventually.  Uninstall-reinstall, failed immediately.  Uninstall-reinstall-update to SP1, failed eventually.

Message 16 of 95
bryan
in reply to: jesse.russell

This problem has occupied my entire morning looking for a solution and I am glad to have found this thread. PLEASE post if you have been informed of any real fix from Autodesk.

Just to add to the burning pile of frustration: I have restarted the computer after every attempt of normalizing the software, repaired and reinstalled AutoCAD Arch 2016, fully uninstalled and reinstalled the program. Nothing has worked, it shuts down due to the fatal error every time.

 

Edit: I have also installed the service pack, which allowed the program to work for a longer duration than other attempted remedies, but ultimately resulted in the same fatal error.

Message 17 of 95
dbroad
in reply to: sguinan

Just so you know you're not alone, it is happening here as well. Started this morning.  Our only workaround has been to back up to AutoCAD 2015.

Architect, Registered NC, VA, SC, & GA.
Message 18 of 95
chughes
in reply to: dbroad

Same error, Autocad Architecture 2016 SP1 Windows 10

Message 19 of 95
edonacho
in reply to: sguinan

Good evening I am an Italian student and I had the same problem: Error C0000005.
I installed Autocad Architecture 2016 English version with Italian package 1 week ago and only now this problem presents to me.
What I have to do now?
Maybe I have to uninstall ACA 16 and install it again? Or do you think I have to wait that Autodesk resolve the problem?
Thank you everyone
Edoardo
Message 20 of 95
david.sides
in reply to: jesse.russell

So Jesse, how's that rename workaround doing? Is it holding so far?

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report

”Boost