Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Skydome light: How to disable visibility in alpha channel

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
Anonymous
28233 Views, 7 Replies

Skydome light: How to disable visibility in alpha channel

Hi guys!

As the normal "primary visibility" setting is not available for Skydome lights (Arnold 5, Maya 2018) and the "Visibility - Camera 0" setting changes the look of my render, is there any other possibility to do that?
I don't mind it being in the RGB channels, just the Alpha channel should be clear of the Skydome light.

Addon question: Same as above but with black empty RGB also?

Thanks so much for any help!

Tags (1)
Labels (1)
7 REPLIES 7
Message 2 of 8
ashley.handscomb.retallack
in reply to: Anonymous

Adjusting the camera visibility should only affect how it displays in camera rays, are you getting other effects from disabling camera visibility? How is it changing the look of your render?



Ashley Handscomb Retallack
Senior Software Engineer (Arnold)
Arnold Documentation | Arnold Downloads
Message 3 of 8
Anonymous
in reply to: Anonymous

I just tested it in an empty scene and I noticed that some reflections are missing in combination with a shadowMatte ground plane.

Without ground plane there is no difference with setAttr "aiSkyDomeLightShape1.camera" 0;

The following 2 renders have the only difference of setting the camera visibility to 1 or 0.

837-camera-0.png

839-camera-1.png

Message 4 of 8
maxtarpini
in reply to: Anonymous

The shadowmatted plane is blocking your indirect reflections (that looks like they are traced from camera rays) so simply disable 'Cast Shadows' under Arnold Visibility shape attributes for the obj you use as shadowmatte. Then you can set skydome Camera visibility to 0 to not have it in the alpha while keep having your indirect refl in the beauty or refl pass.

Message 5 of 8
Anonymous
in reply to: Anonymous

Good call, thanks! I set it up so I have one plane that catches the shadow and one plane that throws the shadow. That way it works!

I'm sure this could somehow be done with a rayswitch shader but for my purposes a second plane is okay.

Thanks again!

Message 6 of 8
anim8
in reply to: Anonymous

I have the same problem.

I selected both OBJECTS and deselected Cast Shadows in AE > ARNOLD.

I really need the ALPHA on this scene.

SkyDome Visibility On:

1476-dome-visible.png

SkyDome Off:

1477-dome-off.png

Message 7 of 8
Anonymous
in reply to: Anonymous

You can off the camera setting in skydome

Message 8 of 8
Anonymous
in reply to: Anonymous

Visibilty> camera = 0

in skydome setting

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums