Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

multiple aiStandins in MASH with ID Node don't get instanced correctly

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
Anonymous
880 Views, 2 Replies

multiple aiStandins in MASH with ID Node don't get instanced correctly

Hi,

I know this is more a maya question, but it is related to using arnoldStandins...maybe someone here has expereinced this as well:

So I have been experiencing a problem which seems to me like a bug.

I set up a Mash network, where I use 3 ArnoldStandins in the instancer, then add an ID node to MASH set to linear and 3 to get a distribution of the 3 different nodes from the instancer. When I do this, I get multiple instances on one point and no instance on the other, both in viewport as in the render.

I set up the whole same set up but use standard polymeshes instead, it works fine.

I set it up with just one ArnoldStandin instead of 2 oder 3 different ones, it works fine.

Please see on the pictures attached what I mean. The outer circle is the setup using polymesh, the inner ArnoldStandins.

The first picture shows how it works fine with 1 ArnoldStandIn, the second one how it acts when you have 3 ArnoldStandIns.

2074-oneassworksfine.png

2073-multipleasserror.png

I tried a work around, with proxy objects, where I used a cube, set the Arnold Translator to procedual, set the path to the ass file, then instancing those cubes via MASH. I am wondering, is this the only way this is supposed to work?

We tested this on 3 machines with different configurations and I could reproduce this error on all of them.

MAYA 2018.3 , Nvidia GeForce GTX 1080Ti driver version 390.77 MtoA 3.0.0.2 arnold core 5.1.0.1

MAYA 2018.3 , Nvidia GeForce GTX 1080Ti driver version 398.63 MtoA 3.0.0.2 arnold core 5.1.0.1

Maya 2018, Nvidia Geforce GTX 650Ti Boost driver version 391.01 MtoA 3.0.0.2 arnold core 5.1.0.1

Labels (3)
2 REPLIES 2
Message 2 of 3
brian_Foley
in reply to: Anonymous

@caroline kiessling

It is a viewport bug. I got the same results but it rendered correctly. If you toggle visibility on the instancer node then it should correct itself.

2077-instancer.jpg

Message 3 of 3
Anonymous
in reply to: Anonymous

Thanks! I toggeled the visibility and then recached the MASH network. That fixed it. Hopefully it stays that way!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums