Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to get Arnold to cast shadows on tranmissive glass objects ?

8 REPLIES 8
Reply
Message 1 of 9
remi
2741 Views, 8 Replies

How to get Arnold to cast shadows on tranmissive glass objects ?

Hello everyone,I'm running into a big problem on a project where i need to render glass objects with moving shadows.The problem being : i can't seem to get any shadows from a glass material !

Tried :

  • Opaque ON/OFF (does nothing)
  • Lowering transmission a bit (start to create shadows but not strongly enough and we loose quickly the glass so not an option at all)
  • trying all light types
  • C4DtoA and also MtoA : same result

I've come across a few tutorials where there is indeed shadows being casted (eg :https://www.youtube.com/watch?v=QYmq_cSb5Mg ) But opening this scene or trying to replicate it doesn't produce anything.

Can somebody point me in the right direction or should i simply switch render engine for this job ?

best

6296-glass-no-shadows.png


Labels (3)
8 REPLIES 8
Message 2 of 9
lee_griggs
in reply to: remi

No need to change render engines. Just reduce the Transmission Weight so that it is not fully 1.

6274-1584106429246.png

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 3 of 9
remi
in reply to: remi

Hi Lee,

Thanks for the reply but that was my second point in the list : the shadow produced when reducing the transmission to 0.9ish is not realistic, it's just a "faded" shadow. So not a good work around for me sadly 😞


Message 4 of 9
lee_griggs
in reply to: remi

Can you upload the scene somewhere?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 5 of 9
Stephen.Blair
in reply to: remi

Another way is to use a rayswitch (to get around "smart opaque") and use opacity / caustics for the shadow

6287-c4dtoa-glass.png



// Stephen Blair
// Arnold Renderer Support
Message 6 of 9
s.thifault
in reply to: remi

You can leave the transmission to 1 and use transmission depth instead and some scatter, it will give you more realistic shadows.

Message 7 of 9
rico
in reply to: remi

In older versions of Arnold ther was a shadow. Now the opake switch is set automatically if you have a transparent object. I think it would be helpful to have the option to acticate the old behavior.

Message 8 of 9
lee_griggs
in reply to: remi

Did you try any of the above suggestions? Can you upload a simples scene somewhere?

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 9 of 9
diego_marcelino97VGE
in reply to: remi

It was quite difficult to find a solution for this, I looked for several tutorials and found nothing. However, testing Arnold's settings I found a very simple solution! Just open "Render Settings" (in C4D); then go to “Arnold” and open the “Ray Depth” option; find the "Transparency Depth" option and reduce it to 1 or any other value that leaves the shadow visible in your scene. I hope this helps!

 

Simplified process:
C4D > RENDER SETTINGS > ARNOLD > RAY DEPTH > TRANSPARENCY DEPTH > VALUE IN 1 OR ANY OTHER VALUE THAT MAKES THE SHADOW VISIBLE.

 

Captura de tela 2023-09-08 200855.png

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators